Opensuse 11.1 / LTSP 4.2 / SAPGUI / keyboard layout trouble

Hello Forumers,

Couple of days ago I setup a x86_64bit machine with opensuse 11.1 and LTSP 4.2 upgrading from a veeeeery old ltsp-environment, running on Debians with kernel 2.4.xx.

Main goal is running a simple X-Environment with SAP JavaGUI and after some trouble finding the right Windowmanager (I had some window positioning problems, tested a lot of WMs till openbox solved them) I thought the parts (Clients and Servers) were rockin’ …

BUT: now I’m facing a really strange thing on the clients: the comma from the numeric keypad produces nonsense, some kind of unknown special character. Numbers and the calculating symbols are fine (/, *, +, -).

Weird: running the X on the local console, guess what? Right, there it is, the comma

Even weirder: the comma-problem ONLY persists on the wonderful, glorious, perfect SAP-GUI :-. Xterms, Browser, OpenOffice are painting the comma without ending.

Same thing if I run the Gui across the net via ssh -X from the server to my local workstation (OS 10.3), again those special char instead of the comma …

The big shame: the old debian-ltsp-servers do not have this problem >:(

I grepped around, googled (okay, LTSP, xdm and sap javagui seem to be quite rare) but I have no idea what the problem could be. Why does the server its job fine locally but not over the net on the client? Does anybody has an idea?

Thanks in advance


That’s quite puzzling and I have no idea really. But you say comma. There is no comma on my numeric keypad. I’m guessing you have a different country layout and you mean the key next to 0, which has a period on mine, and which I guess would have a comma in countries where the comma is used as the decimal separator. So, some kind of keymap gone wrong in the application? Or some keymap not installed? Something to think about anyway.

Sorry, haven’t mentioned that it is a german keyboard. Yes, right beside the zero key, english keyboards have a dot


It was the Java Runtime which lead to that misbehaviour! Used jre 32bit for SAPGUI 7.10 rev8.
Tried jre 32bit and WHOAAA there is the comma!

I’m thinking most of questions are solved by oneself in this forum … :’(

No need to cry, it may be telling, that Posters are able to solve their problems themselves and any other can google the solution :wink:

By the way: another solution to my problem would have been following:
vi .xinitrc in users-homedir and insert these two lines:
export LANG=de_DE
xmodmap -e ‘keycode 91 = comma’