OpenSUSE 11.1 LiveCD on HP Pavilion 310n


I am having issues trying to get the subject configuration to work. When I attempt to boot from the LiveCD, I get past the point of X Windows being configured and see a spinning mouse pointer, however, I never get to the point of obtaining a login prompt.

The PC has 128MB of RAM and a single Intel Celeron 1.1GHz processor with 128KB of cache.

If I press the <SHIFT> key to boot the LiveCD into the text mode menu, I do obtain a “login:” prompt and can successfully login to the command shell via the root user with no password.

Is there anything special I need to do so that I can get booted into the GNOME desktop environment from the LiveCD so that I may perform an installation of openSUSE?

The hard disk currently has Windows XP Home Edition installed on it and as best I can tell that NTFS partition is the only partition present on the disk. Windows XP does boot.

I also experience similar behavior if I attempt to boot from a Fedora 10 Desktop Edition LiveCD.

I searched the compatibility list for the HP Pavilion 310n desktop/tower and found no information. Any help is greatly appreciated.

Best Regards,


Haven’t had much experience with suse live cd. If there is a resolution setting at the bottom of the screen, try a lower resolution, els when you have logged in as root, run sax2 to configure the x-server.

Thanks for your response whych. I did try booting the Live CD in text mode, ran sax2 and it did display a white rectangle around the border of the screen with very small rectanges in each corner. Eventually, a dialog box for me to accept the settings determined by sax2 was displayed.

I clicked “OK” to accept and the X server started and returned me to the command line. I then issued “rcxdm restart” which shutdown the gdm service and restarted the X server. At this point I was back where I always am if I boot the Live CD in VESA video mode, with a black screen and a white mouse pointer that I can move around but nothing to select and no dialog box to log into.

Best Regards,


Is that the infamous intel 810e graphics set, or do you have a separate video card?

Here’s one… have you tried letting it boot up with out touching anything? Normally, It’ll start to up with the bootloader then it should auto select the cd. If all goes well you’ll see nothing… ??? hit CTRL-F2 or CTRL-ALT-F2 or F2. that should bring you to the boot message screen that’s shoot out of TTY2; TTY7 is for X usually. If the messages keep going then don’t do anything. If something naughty happens it’ll let you know.

Since it’s a livecd the boot process should take longer due the cd bottleneck and doing a complete scan of all your hardware. After boot, it should auto loggin with a normal user account. On the desktop, there should a folder widget with an install button. Need I go on? The process is the same as suse’s normal install.

Video card should be an issue on a laptop. If it can’t find the right driver then the least you should get is X with really crappy resolution and maybe even screen size. Install it anyways and then update the driver.

LiveCD’s pretty much load the entire OS into RAM with some psuedo partitions made into the ram. when you get it running type mount and you’ll see what I mean. It only mount’s your HDD so you can work with it; i.e. access files and yada yada…

A little more info… I just tried booting an old Knoppix v3.9 LiveCD and I get the following messages early in the boot process:

You passed an undefined mode number.
Press <RETURN> to see video modes available,
<SPACE> to continue or wait 30 secs.

If I press <RETURN>, I get the following:

Video adapter: VESA VGA
0 0F00 80x25
1 0F01 80x50
2 0F02 80x43
3 0F03 80x28
4 0F05 80x30
5 0F06 80x34
6 0F07 80x60

I suspect this same “undefined mode number” condition may be occurring when booting openSUSE 11.1 on the LiveCD (and probably Fedora as well) but it isn’t being presented so clearly.

Is this an issue with the graphics controller (i.e. the Intel 810e graphics set that Hirschacker referred to).

Thanks for the responses.

Best Regards,


I should imagine its the same thing with suse live.
When you setup x as per post 2 and 3 of the thread, If you aren’t satisfied with the display you see, click the change and it should allow you to change some of the settings.
Exit the setep when satisfied, and just type startx to start the x-server.
(Like I said, I don’t have a suse live cd to try)


Yes, this PC does have the Intel 810e chipset and I am using the builtin video adapter.

Best Regards,


Found another thread where someone had success installing a GeForce 5200 FX in a HP Pavilion 310n to get around issues with the builtin graphics of the Intel 810e chipset.

I installed a PCI-based GeForce 5200 FX, confirmed that the BIOS setting for the primary video adapter was set to PCI, and booted up the openSUSE LiveCD. I now get a message on the monitor before I get to an X login display that states the following:

Out of Frequency Range
Attention out of Range
H:27.9KHz V:62.2Hz

If I check the Dell Monitor I have attached it shows the following frequencies:

H:48.2KHz V:59.9Hz

I tried changing the Video Mode setting on the initial menu prior to booting the openSUSE Gnome LiveCD from “1024x768” to VESA and don’t see this message, however, I still don’t get anything displayed on the X terminal. I can switch to the other 6 terminals via Ctrl-Alt-F1,…Ctrl-Alt-F6 and have a text mode login prompt available.

If I login to the shell and run sax2, I eventually get the following:

xc: sorry could not start configuration server
xc: for details refer to the log file:


The log states:

Section “Device”
BoardName “82810e CGC”
BusID “0:1:0”
Driver “intel”
Identifier “Device[0]”
VendorName “Intel”

There are many errors toward the end of the log file that indicate it is trying to deal with the onboard graphics instead of the GeForce video card, however, the monitor is connected to the GeForce output and is receiving the output for the LiveCD menu and the boot console.

Any assistance is much appreciated.

Best Regards,


A few more pieces of info…

The PC is running PhoenixBIOS Setup Utility Revision 3.06 12/15/01.

The “Onboard Video Memory” option of the Advanced menu in the BIOS only allows me to select 512KB or 1MB although the help information for this item states that you may select either of these values or “Disable Onboard Video” to disable the onboard video controller.

The HP web site indicates that not all BIOS revisions offer the disable option, however, if it is not available they say to select either PCI or AGP for the “Default Primary Video Adapter” item, which I have done. Note that the only options I have are “PCI” and “AGP”, no “Onboard” option is available. As such, even without an external graphics card, the “Default Primary Video Adapter” has to be set to either “PCI” or “AGP”.

I don’t know if this may be contributing to the issue, however, the GeForce 5200 FX PCI card has a DVI-I output. I have a Dynex DVI-I to VGA adapter connected to it and a VGA cable connecting it to the monitor.

Best Regards,


Do you not have a normal vga connector on the video card you can use instaed? Could be that it is getting confused between outputs.

Unfortunately no. The card only has DVI-I and S-Video outputs.

I will try to see if I can locate another PCI adapter with a VGA output and give that a try.

Best Regards,