OpenSuse 11.1 - KDE 4.2 -- Not sure if 3D working


I have a P4 with 750 Megs RAM and an Nvidia 7300 Card.

I installed OpenSuse 11.1 last week and it came with KDE 4.1.3. Though the desktop looked clean I was unable to run 3D on it…at least thats what I thought because I could not see the Desktop Cube (when I pressed ctrl-F11) and I should mention, I had uninstalled Compiz when I did that so the KDE’s composite effects were turned on.

Then I upgraded to KDE4.2 last night and I still don’t see the 3D effects. I have updated Nvidia drivers for my graphic card but it doesn’t seem to have helped. I think I am missing something here in OpenSuse because before this I had ubuntu and I was able to see the 3D effects there.

Can someone help please?

Thanks in advance!


compiz and compiz-kde4 need to be installed from the 4.2 desktop repo

enable cube in all effects
and under the main window for effects - General - Common settings - set desktop switching to cube

Thanks for the reply.

I have not tried this yet as I don’t have access to my system but isn’t it that if Compiz is enabled, one cannot enable the “KDE Desktop Effects”? When I was using KDE 4.1.3, I had compiz (for a few hours) and as far as I remember, the “Enable Desktop Effects” in KDE was greyed out. It was not available. Please correct me if I am wrong.

There is no need to install ‘Compiz’ as was the case in the past adding repo’s or OneClick installs.
Compiz packages are in the kde4 desktop repo and should be installed as I said earlier. You don’t set compiz as the window manager as was the case in the past - But rather use kwin, kde’s default window manager.

If desktop effects are greyed out. Post your /etc/X11/xorg.conf

Can we see the result of ‘glxgears’ command?

kistej: Here’s the output:
1716 frames in 5.0 seconds = 342.970 FPS
1666 frames in 5.0 seconds = 333.183 FPS
2061 frames in 5.0 seconds = 411.896 FPS
2072 frames in 5.0 seconds = 414.189 FPS
2068 frames in 5.0 seconds = 413.579 FPS
2060 frames in 5.0 seconds = 411.737 FPS
2069 frames in 5.0 seconds = 413.728 FPS

caf4926: I uninstalled Compiz when I was with KDE 4.1.3. I upgraded from that point to KDE 4.2 and I can tell you that I do not have Compiz right now. I don’t see it installed in the package manager. It would be handy to know how to install Compiz in KDE 4.2, I think…


Open Yast Software Management
filter by repo
look at kde4 factory 4.2 repo for compiz-kde and compiz-kde4, they should bring in any dependencies.

Okay, I think its working as it should now.

I didn’t do any change apart from choosing “OpenGL” in Compositing Type. I remember KDE 4.3.1 was not letting me choose this for whatever reason (Maybe the default Nvidia driver didn’t support it) but after an upgrade of the driver and after the upgrade to KDE 4.3.2 it let me choose OpenGL and it seems that has fixed this.

I should mention, though, that in Yast, I still see as Compiz not installed in my box. Is it supposed to be there? Is this KWin working for me now? I tried choosing Compiz and installing it through Yast but it asks for a downgrade to several KDE packages (downgrade to 4.3.1, which was the version which I upgraded from). Any ideas there? Or is this the best I could have? If I am to install Compiz how should I go about it, with all this downgrade thing?

give us the result of :

zypper lr

also - when you get an error in Yast with dependencies, save it to a file. The error box has an expert option to do that - then post it here.

Try typing glxgears in a terminal. You should get a window with some gear wheels and a framerate read out in the terminal window. This is the first thing you should try beacause if this doesn’t work you won’t get any further till it does.

OK, forget I wrote this, for some reason the rest of the thread hadn’t shown on my browser :slight_smile:

landdie: No problem!

caf4926: Here’s the result of zypper lr:

| Alias | Name | Enabled | Refresh

1 | 20090215-171028 | 20090215-171028 | Yes | Yes
2 | KDE:KDE4:Factory:Desktop | KDE:KDE4:Factory:Desktop | Yes | Yes
3 | KDE:Qt | KDE:Qt | Yes | Yes
4 | KDE_4_Qt_Packages_ | KDE 4 Qt Packages | Yes | Yes
5 | NVIDIA Repository | NVIDIA Repository | Yes | Yes
6 | X11:XGL | X11:XGL | Yes | Yes
7 | devel:tools:building | devel:tools:building | Yes | Yes
8 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No
9 | opensuse_11.1_kde | opensuse 11.1 kde | Yes | Yes
10 | repo-debug | openSUSE-11.1-Debug | No | Yes
11 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes
12 | repo-oss | openSUSE-11.1-Oss | Yes | Yes
13 | repo-source | openSUSE-11.1-Source | No | Yes
14 | repo-update | openSUSE-11.1-Update | Yes | Yes

Thanks for your replies!

All you should need is:

Index of /distribution/11.1/repo/oss

Index of /distribution/11.1/repo/non-oss

Index of /update/11.1

Index of /

Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1

Index of /repositories/KDE:/KDE4:/Factory:/Extra-Apps/openSUSE_11.1

Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_Factory_Desktop

Index of /repositories/KDE:/Qt44/openSUSE_11.1

Should I be changing my repos to these? the links you have posted there?


What I would suggest is disable all your repo’s and add the ones I gave you. That way you don’t loose your original list - Just in case you need to go back to it.

You may notice I added Packman - Which you will need if you want multi-media playback. I didn’t add VLC, but you may need it later for the libdvdcss package. But leave it for now.

Once you have the repo’s as I suggest. Go to Yast software management and filter by repo - Do update all in this list for the qt44 and kde4 desktop. See how it responds.
Post back with result or issues

he (she?) has already done. you can see the result above.
To me it seems the 3d is not working. The values are too low.
…but if it is working…:question:

hmm…something strange with the forum today or three of us have written almost in the same time… :sarcastic:

You don’t need compiz in KDE4.
KWin in kde4 has it own compositing/desktop effects.
I have desktop effects (desktop cube etc) and no compiz installed.

The glxinfo command should give tell you if the nvidia driver or mesa is being used for rendering.


I think if we all agree that Compiz is not required with KDE 4.2 we can consider this thread closed. Because now, my 3D is working surely. Just that Compiz is not there – but I guess it does not <i>need</i> to be there (on that note now, whats Compiz fusion then? something better?)

Kistej: Its a “he”.

caf4926: I will change the repos as you said. Umm…sorry for replying late here, too much work at office and my linux box is at home!

Thank you for ALL your messages!