OpenSuSE 11.1 KDE 3.5 vnc issues

Hi there, I am not awesome with SuSE yet, but know my way around google well enough, and have not been able to figure this one out… yet.

I understand there have been some issues with the newer releases of SuSE, however I have several 11.0 and 11.1 machines in which I have had no issues, but my latest installation is giving me fits.

I can connect to console 0, but there is one problem, it is not accepting inputs…
Now before everyone says check my xorg.conf file… here it is:

Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
EndSection

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”
EndSection

Section “Module”
Load “dri”
Load “dbe”
Load “freetype”
Load “extmod”
Load “glx”
Load “vnc”
EndSection

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
EndSection

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Name” “ImPS/2 Generic Wheel Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
DisplaySize 312 234
HorizSync 29-70
Identifier “Monitor[0]”
ModelName “76E77E”
Option “DPMS”
Option “PreferredMode” “1024x768”
VendorName “SAMTRON”
VertRefresh 50-160
UseModes “Modes[0]”
EndSection

Section “Modes”
Identifier “Modes[0]”
Modeline “1024x768” 93.16 1024 1088 1200 1376 768 769 772 806
Modeline “1024x768” 83.00 1024 1080 1192 1360 768 769 772 803
Modeline “1024x768” 73.89 1024 1080 1192 1360 768 769 772 799
Modeline “1024x768” 64.11 1024 1080 1184 1344 768 769 772 795
Modeline “1024x600” 77.36 1024 1080 1192 1360 600 601 604 632
Modeline “1024x600” 67.63 1024 1080 1184 1344 600 601 604 629
Modeline “1024x600” 58.10 1024 1072 1176 1328 600 601 604 625
Modeline “1024x600” 48.96 1024 1064 1168 1312 600 601 604 622
Modeline “800x600” 60.07 800 840 928 1056 600 601 604 632
Modeline “800x600” 53.14 800 840 928 1056 600 601 604 629
Modeline “800x600” 45.50 800 840 920 1040 600 601 604 625
Modeline “800x600” 38.22 800 832 912 1024 600 601 604 622
Modeline “768x576” 55.94 768 816 896 1024 576 577 580 607
Modeline “768x576” 48.71 768 808 888 1008 576 577 580 604
Modeline “768x576” 41.66 768 800 880 992 576 577 580 600
Modeline “768x576” 34.96 768 792 872 976 576 577 580 597
Modeline “640x480” 37.89 640 672 736 832 480 481 484 506
Modeline “640x480” 33.48 640 672 736 832 480 481 484 503
Modeline “640x480” 28.56 640 664 728 816 480 481 484 500
Modeline “640x480” 23.86 640 656 720 800 480 481 484 497
Modeline “1024x768” 94 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
EndSection

Section “Screen”
DefaultDepth 16
SubSection “Display”
Depth 15
Modes “1024x768” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 16
Modes “1024x768” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 24
Modes “1024x768” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes “1024x768” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”
Option “usevnc” “yes”
Option “rfbauth” “/root/.vnc/passwd”

EndSection

Section “InputDevice”
Identifier “Keyboard[2]”
Driver “rfbkeyb”
Option “InputFashion” “VNC”
EndSection

Section “InputDevice”
Identifier “Mouse[3]”
Driver “rfbmouse”
Option “InputFashion” “VNC”
EndSection

Section “Device”
BoardName “GD 5480”
Driver “cirrus”
Identifier “Device[0]”
VendorName “Cirrus Logic”
EndSection

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”
Option “VNC” “3 2”

EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Section “Extensions”
EndSection

However, whenever I connect to it, I cannot move the mouse, or type with the keybord and this is what I receive when I in my xorg.0.log file

(II) 18/02/2009 22:24:42
(II) 18/02/2009 22:24:42 Got VNC connection from client 192.168.1.102
(II) 18/02/2009 22:24:42 Using protocol version 3.3
(II) 18/02/2009 22:24:47 Full-control authentication passed by 192.168.1.102
(II) 18/02/2009 22:24:47 Pixel format for client 192.168.1.102:
(II) 18/02/2009 22:24:47 32 bpp, depth 24, little endian
(II) 18/02/2009 22:24:47 true colour: max r 255 g 255 b 255, shift r 16 g 8 b 0
(II) 18/02/2009 22:24:47 Using copyrect encoding for client 192.168.1.102
(II) 18/02/2009 22:24:47 rfbProcessClientNormalMessage: ignoring unknown encoding -238
(II) 18/02/2009 22:24:47 Enabling X-style cursor updates for client 192.168.1.102
(II) 18/02/2009 22:24:47 Enabling cursor position updates for client 192.168.1.102
(II) 18/02/2009 22:24:47 Using hextile encoding for client 192.168.1.102
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueMotion() ptrDev=NULL
VNC: In EnqueueButton() ptrDev=NULL
VNC: In EnqueueButton() ptrDev=NULL
VNC: In EnqueueButton() ptrDev=NULL
VNC: In EnqueueButton() ptrDev=NULL
VNC: In EnqueueButton() ptrDev=NULL
VNC: In EnqueueButton() ptrDev=NULL
VNC: In EnqueueButton() ptrDev=NULL
VNC: In EnqueueButton() ptrDev=NULL

Any Ideas?

I have the same problem

SOLVED!

These are the changes I made to my Xorg.conf file, and everything works fine.

The only packages I have installed for vnc is “tightvnc” and “xorg-x11-Xvnc” and “LibVNCServer”

This is the resulting xorg.conf file…


Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "dri"
  Load         "dbe"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
  Load         "vnc"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "us"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImPS/2 Generic Wheel Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection
Section "InputDevice"
  Driver       "rfbkeyb"
  Identifier   "Keyboard[2]"
  Option       "InputFashion" "VNC"
EndSection

Section "InputDevice"
  Driver       "rfbmouse"
  Identifier   "Mouse[3]"
  Option       "InputFashion" "VNC"
EndSection

Section "Monitor"
  DisplaySize  305 230
  HorizSync    29-48
  Identifier   "Monitor[0]"
  ModelName    "1024X768@60HZ"
  Option       "DPMS"
  Option       "PreferredMode" "1024x768"
  VendorName   "--> VESA"
  VertRefresh  50-60
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
  Modeline      "1024x768" 64.11 1024 1080 1184 1344 768 769 772 795
  Modeline      "1024x600" 48.96 1024 1064 1168 1312 600 601 604 622
  Modeline      "800x600" 38.22 800 832 912 1024 600 601 604 622
  Modeline      "768x576" 34.96 768 792 872 976 576 577 580 597
  Modeline      "640x480" 23.86 640 656 720 800 480 481 484 497
  Modeline      "1024x768" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
EndSection


Section "Screen"
  DefaultDepth 16
  SubSection "Display"
    Depth      15
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480"
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Section "Device"
  BoardName    "3D Rage IIC 215IIC"
  Driver       "ati"
  Identifier   "Device[0]"
  VendorName   "ATI"
  Option       "usevnc" "yes"
  Option       "rfbauth" "/root/.vnc/passwd"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
  InputDevice  "Keyboard[2]" "ExtraKeyboard"
  InputDevice  "Mouse[3]" "ExtraPointer"
  Option       "VNC" "3 2"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection

The only thing I can figure that made it work is the placement of the input for the rfbkeyboard and rfbmouse under the physical mouse and keyboard input sections…
-AND/OR-
The additional InputDevice lines in the ServerLayout Section
-AND/OR-
moving the lines


  Option       "usevnc" "yes"
  Option       "rfbauth" "/root/.vnc/passwd"

from the Screen section to the Device section.

So far this has solved two SuSE 11.1 box’s vnc no input issues.

Your mileage may vary.