OpenSuse 11.1 install on Sony VAIO Z laptops

After a successful install of OpenSuse 11.1 on Sony VAIO Z550N I’ve decided to write a detailed how-to and will update it with all new info I will able to find.

Installing OpenSUSE 11.1 on Sony VAIO Z550N

Install
The best way to start installation is to start it using STAMINA mode, the result will be fully working INTEL graphic card. Later you can make NVIDIA work.

What works «out of the box»:
1.Right screen resolution (if you have installed it in STAMINA mode)
2.Webcam
3.WiFi, bluetooth
4.All additional ports and connections(except HDMI, which you can use after installing NVIDIA drivers)
5.SD card reader
6.Standby and Hibernate
7.Adjusting of CPU frequency
8.«All beautiful things»
9.Sound
10.so on…

**
Adjust right after installation**
Please update, and if you like you may install KDE 4.3.1 and later. Everithing is working flawlessly, I have no problems with 3D support and so on stuff.

So let’s move on to the real adjustment

For the right acpi support^ in order to adjust screen brightness and also to switch between graphic cards you have to install kernel module “sony-laptop”. The one from reps is not made for Z series so you should download it from this site:
http://www.basyskom.org/~eva/sony-laptop-zseries-0.9.tar.bz2

After downloading it you have to unzip it and put it here
/usr/src/linux-obj/i386/pae/sony-laptop
where "sony-laptop in the final folder where all files from archive shold be copied, not folder, files)). I think it is clear that if you have anouther kernel or smth els the route names will differ.

After it we have to execute the following commands in terminal:
3 commands:
compiling
make -C /usr/src/linux-obj/i386/pae/sony-laptop M=sony-laptop
installing
make install -C /usr/src/linux-obj/i386/pae/sony-laptop M=sony-laptop
activating
modprobe sony-laptop

**Doing so **we will get the opportunity to turn on and off all wireless devices, adjust screen brightness and smth more)))
There is a perfect program called Killswitch applet, which can control rfkill devices from tray! =)
The best way to check if the new module works is to check /sys/class/rfkill/ after reboot. If there are several devices, it works if there is only one, you’ve missed smth

**
Implementing a graphic cards switch**

Check /etc/modprobe.d/sony-laptop.conf and if there is no such a file please create it and add the following:

options sony-laptop speed_stamina=3

To turn on NVIDIA card we have to make several steps:

1.in /usr/lib copy file libGL.so.1.2 and paste it here as libGL.so.INTEL
**2.in ** /usr/lib/xorg/modules/extensions copy libglx.so and paste as libglx.INTEL
3.We also have to create 2 copies of xorg.conf’а, in order to make our future script working.
in /etc/X11/ copy xorg.conf and paste as xorg.INTEL and as xorg.NVIDIA. (so generally you will got 2 copies made by you)

For xorg.INTEL plz check

Section "Device"
  BoardName	"Mobile Intel GM45 Express Chipset"
  BusID		"0:2:0"
  Driver	   "intel"
  Identifier   "Device[0]"
  Option	   "monitor-LVDS" "Monitor[0]"
  Screen	   0
  VendorName   "Intel"
EndSection

For xorg.NVIDIA plz check

Section "Device"
	Identifier	 "Device[0]"
	Driver		 "nvidia"
	VendorName	 "NVIDIA Corporation"
	BoardName	  "GeForce 9300M GS"
	BusID		  "1:0:0"
	Screen		  0
	Option		 "monitor-LVDS" "Monitor[0]"
EndSection

**4.Installing NVIDIA drivers via 1-click install. **
NVIDIA - openSUSE

5.Creating and activating a script

#!/bin/sh

lspci | grep "00:02.1"

if  $? -eq 0 ]; then
   cp /etc/X11/xorg.INTEL /etc/X11/xorg.conf
   ln -sf /usr/lib/libGL.so.INTEL /usr/lib/libGL.so.1
   ln -sf /usr/lib/libGL.so.INTEL /usr/X11R6/lib/libGL.so.1
   ln -sf /usr/lib/xorg/modules/extensions/libglx.so.INTEL /usr/lib/xorg/modules/updates/extensions/libglx.so
   ln -sf /usr/lib/xorg/modules/extensions/libglx.so.INTEL /usr/lib/xorg/modules/extensions/libglx.so
else
   cp /etc/X11/xorg.NVIDIA /etc/X11/xorg.conf
   ln -sf /usr/X11R6/lib/libGL.so.190.42 /usr/X11R6/lib/libGL.so.1
   ln -sf /usr/lib/xorg/modules/updates/extensions/libglx.so.190.42 /usr/lib/xorg/modules/updates/extensions/libglx.so
fi

(NVIDIA drivers version number (190.42), as well as all names of xorg are to be added as they are in your etc/X11 folder)

Set this file as an executable, copy it to /etc/init.d/ and execute the following command:

/sbin/insserv /etc/init.d/intel_nvidia.sh

That is all, our script is ready to use and will function during every load of the computer.

In order to have an opportunity to switch between cards you have to:
1.Before switching fully turn the computer off.
2.Add to a bootloader the following parameter: acpi_osi=«!Windows 2006» (there should be another quotes :slight_smile: )
If you made everything correct, after turning the computer off, switching the mode and turning it on again the green led have to indicate it to you.
Если Вы все сделали правильно, то при выключении, переключении режима и включении компа, должен загореться индикатор режима SPEED, а по окончании загрузки, должен промелькнуть сплешскрин нвидии и загрузиться иксы. Все прочие настройки уже на Ваше усмотрение)

С такими параметрами у меня работает все правильно, есть поддержка 3D, а также работают «красивости».

Screen brightness control and other adjustments

You can control screen brightness using the following commands:

setpci -s 00:02.0 F4.B=FF (max)
setpci -s 00:02.0 F4.B=01 (min)

Donload program zenity and create script for screen brightness adjustment:

value=$(zenity --scale --text "Screen brightness" --min-value=10 --max-value=100 --value=10)
if  $value = 100 ]
then sudo /sbin/setpci -s 00:02.0 F4.B=FF
else sudo /sbin/setpci -s 00:02.0 F4.B=$value
fi

After this, install keytouch and keytouch editor. In editor you can bind S1, S2, and a key for ejecting dvd-rom. Launch keytouch and load you pattern you have created in keytouch-editor. You now can set ouw script on S1 or other key. I have set it on S1 with command:
sh /…/Sony_brt.sh
(In order to have a permission to execute this script you have to go to sudo control and permit command “setpci” to be executed. So you will be able to use this script as a user, not root.

That’s all as for the main adjustments. You can also download “powertop” and add some command or create new powersave script.

**
Configuring microphone**
In YaST in “sound configuration” you have to set the model of your card as:
model=toshiba-s06
after it in kmix and alsamixer real mic will appear.

**
Known bugs**

  1. After booting windows the first boot of linux without X system, it’s ok, just reboot.
  2. In order to get the right resolution using NVIDIA card you have to set it in system configuration every time you boot.
  3. May be some other…
    But of course there is a solution of all these bugs. Just have to test for some more time.

I’ll be glad to answer you questions and correct my article if I made a mistake.

Since OpenSuse 11.2 will be available soon I will update this thread with new and adequate test results!

Sources, which I’ve used for writing this how-to:
http://www.basyskom.org/~eva/log_installat…aio_z21vnx.html
https://launchpad.net/~sony-vaio-z-series
as well as all sources mentioned in these articles.

I would like to express my gratitude to the authors of these articles!
Great friends, great!
:wink:

I’ve installed OpenSuse 11.2 and have several problems:

  1. I’ve managed to get two graphic cards working but without 3D (at least I can’t launch even openGL screensavers and Cube and so on…)
  2. can’t install sony-laptop, but here is no problems connected with it

My script now is:

#!/bin/sh

lspci | grep "00:02.1"

if  $? -eq 0 ]; then
   #cp /etc/X11/xorg.INTEL /etc/X11/xorg.conf
   ln -sf /usr/lib/libGL.so.INTEL /usr/lib/libGL.so.1
   ln -sf /usr/lib/libGL.so.INTEL /usr/X11R6/lib/libGL.so.1
   ln -sf /usr/lib/xorg/modules/extensions/libglx.so.INTEL /usr/lib/xorg/modules/updates/extensions/libglx.so
   ln -sf /usr/lib/xorg/modules/extensions/libglx.so.INTEL /usr/lib/xorg/modules/extensions/libglx.so
else
   #cp /etc/X11/xorg.NVIDIA /etc/X11/xorg.conf
   ln -sf /usr/X11R6/lib/libGL.so.190.42 /usr/X11R6/lib/libGL.so.1
   ln -sf /usr/lib/xorg/modules/updates/extensions/libglx.so.190.42 /usr/lib/xorg/modules/updates/extensions/libglx.so
fi

Since there is no necessity in xorg.conf I’ve eliminated it.
Although my script works, I can’t make Cube and so on works.

I think that after installation of NVIDIA drivers system simply can’t use opengl.

Maybe somebody know how to solve this problem?

I’ve made a mistake in my script which switches cards.


#Was
ln -sf /usr/lib/xorg/modules/updates/extensions/libglx.so.190.42 /usr/lib/xorg/modules/updates/extensions/libglx.so
#should be as written above
Was
ln -sf /usr/lib/xorg/modules/updates/extensions/libglx.so.190.42 /usr/lib/xorg/modules/updates/extensions/libglx.so

openGL didn’t work because there was no link to libglx.so.190.42 in /usr/lib/xorg/modules/updates/extensions/ but since all files it this directory has priority under files in /usr/lib/xorg/modules/extensions/ there should be a link to this file. I’ve created it properly and now NVIDIA work correctly with 3D support.

However there is still no 3D under INTEL. Have no idea what link I should add or rewrite…

Any suggestions? rotfl!

I have a vaio Z21 with BIOS R2140M3 + SUSE 11.1
Thanks to Eva’s page, I have been able to get a working laptop with more or less the same features as you, except for

  • The external microphone (the model=toshiba-s06 does not work for me).
  • Fn brightness keys in INTEL
  • Fn sound keys and special keys for both cards.
  • Many slide projectors not receiveing signal.
    Recently, KDE has become very unstable, specially after upgrading to 4.3. I am therefore considering updating to 11.2 or, most possibly, moving to Karmic, since almost everybody in the launchpad mailing list of vaio-z launchpad uses Ubuntu (~40), and very few SUSE (~1-2).
    Have you made any progress with your 11.2 ? How stable is it ?

The toshiba-s06 is for an ALC262 hardware audio codec. Are you certain that is the hardware codec that your laptop has? If it does have the ALC262, did you try any of the other model options for forcing an alsa configuration upon boot?

My model is 82801I (ICH9 Family) HD Audio Control.

Unfortunately that is not specific enough.

My experience is it can be difficult to find the EXACT hardware codec on one’s PC (if its not in the spec sheet) . Please can you remove the “model=toshiba-s06” from your openSUSE-11.1 /etc/modprobe.d/sound file, and set up your mixer exactly the way you believe it should be set up for your mic to work, and then post in this thread, providing in your post the following information:

/usr/sbin/alsa-info.sh

select the SHARE/UPLOAD option, and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update the script in the /usr/sbin directory, and the second time as a regular user to have the updated script run get the URL needed to pass on).
.

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.1 or earlier, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/sound #and post output here
  • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

Please also advise what desktop? KDE or Gnome? The Gnome pulse audio implementation is notorious for making the set up of audio/mics much more difficult.

Thanks for your prompt answer.
I’ve taken out the toshiba thing, and reconfigured the sound card with yast.

This is what I get:

  1. I run alsa-info first, and expected it told me it would upgrade.
    But after running it a second time (and several more times), I got no output.

  2. These are the outputs to the other queries:
    rpm -qa ‘alsa
    alsaplayer-0.99.80-1.pm.1
    alsa-tools-1.0.18-1.16
    alsamixergui-0.9.0rc1-584.91
    alsa-plugins-1.0.18-6.13
    alsa-oss-1.0.17-1.43
    alsa-oss-32bit-1.0.17-1.37
    alsa-firmware-1.0.19.git20090317-1.1
    alsa-1.0.19.git20090304-3.1
    alsa-utils-1.0.18-6.4
    alsa-plugins-pulse-1.0.18-6.13
    alsa-tools-gui-1.0.18-1.16
    linux-fw02:/usr/sbin # rpm -qa ‘pulse
    libpulse-mainloop-glib0-0.9.14-2.2.1
    libpulse0-32bit-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    pulseaudio-utils-0.9.14-2.2.1
    pulseaudio-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.13
    libpulse-browse0-0.9.14-2.2.1
    libxine1-pulse-1.1.16.3-0.pm.3
    pulseaudio-lang-0.9.14-2.2.1
    linux-fw02:/usr/sbin # rpm -q libasound2
    libasound2-1.0.19.git20090304-3.1
    linux-fw02:/usr/sbin # uname -a
    Linux linux-fw02 2.6.27.37-0.1-default #1 SMP 2009-10-15 14:56:58 +0200 x86_64 x86_64 x86_64 GNU/Linux
    linux-fw02:/usr/sbin # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.La2sVf2X+uF:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

I use KDE 4.2 - 4.3

Then please run the script again with the no-upload option, and then copy the output to a pastebin site. You can do that by typing as a regular user (with your PC connected to the internet):

/usr/sbin/alsa-info.sh --no-upload

that will create the file /tmp/alsa-info.txt. Please open the file alsa-info.txt with a text editor, and then copy and paste that file into a web site such as PasteBin.be and press the dump selection on the web site. That will give you a URL. Please post that URL here. Just the URL.

This is it:
http://www.alsa-project.org/db/?f=021214cc9f86bdf442473b9a0fabb8c0b5953957

Please, can you run it without the model options? ie remove the model options and reboot.

The script tells me you have applied 3 model options at the same time (which is a “no no” ) :

snd-hda-intel: model=auto
snd-hda-intel: model=toshiba-s06
snd-hda-intel: model=auto

Note, in openSUSE-11.1, do NOT keep ANY backup files in /etc/modprobe.d directory, as they WILL be treated as config files and an attempt will be made to load them.

This was fixed in openSUSE-11.2 (with the different naming convention of config files).

this is it:
http://www.alsa-project.org/db/?f=b10c83b612cd59af93004998f6c9ec2aa7d0cea5

It appears your PC is STILL specifying a model option.

!!Modprobe options (Sound related)
!!--------------------------------

snd-hda-intel: model=auto
snd-hda-intel: model=auto

… were you hacking at some config files to cause this ? …

Did you remove any backup files from your /etc/modprobe.d directory?

There was a time when there was an automatic assignment of model options (that showed up in the script) but to the best of my knowledge that does not happen any more.

I want to recommend some model options to try, but there is no point as long as you have that model=auto.

You need to find out what you have done to cause that. Its basically BLOCKING your ability to custom tune anything else.

Note you have the volume switched OFF:

Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 0 [0%] -51.00dB]
  Front Right: Playback 0 [0%] -51.00dB]

PCM should NOT be at 0%.

I tried several option with the sound configuration tool in yast in the past. But that happened one month ago and before.

This time: I think I deleted all spurious sound files form /etc/modprobe.d and run the sound configuration tool from yast. Afterwards, I came back and deleted a backup file. Then I rebooted the machine.

Yes, I know that the sound level is at zero. For some reason everytime I boot, the sound level goes to zero automatically. That doesn’t bother me really. What bothers me is that when I try to use skype, I need to plug an external microphone, and send down to zero one of the switches of the intel card to avoid the speakers go screaching.

So the external mic does work ?

I was working under the assumption from a previous post that it does not work where it was stated:

  • The external microphone (the model=toshiba-s06 does not work for me).

… so am I correct that it works, but you are simply not satisfied with the quality ?

I apologize: I messed it. It is the INTERNAL microphone that doesn’t work. The external microphone DOES work.

So to use SKYPE I need to plug in an external microphone