Opensuse 11.1: Install hangs on "starting udev"


today I want to try the new 11.1. When I start the installation (x86_64 DVD), the startup is hanging. The last message is “Starting udev…”. Keyboard is completely frozen, only reset button is working :frowning:
Mobo is an Intel DG965WH with 4GB RAM and ATI Graphic card (ASUS1950pro)

My opensuse 11.0 runs without any problems.

Any Ideas?


Is that with a live filesystem? I could not get any of the livecds to work. You could try the network install. Takes longer but the installed system works with no problems.

Thank you very much.
But I solved the problem now by disabling HPET ( high precision timer) in MoBo- BIOS.



I got the same error while trying to install openSuSE 11.1 on my computer. Fortunately, my keyboard was not frozen but after “string udev…” was shown nothing happened. I checked my BIOS settings but I couldn’t find a HPET option which could be disabled…

I am running openSuSE 10.2 successfully on a FSC celsus 400 computer (1 GB RAM, GeForce 3 GC).

Does anybody know what can be done to fix this problem?
Your help is very appreciated!! Thanks in advance!!


After reading my post I found a mistake:
“string udev…” must be “starting udev…” :wink:

Same problem over here. openSuse 10.2 installed without problem. Both versions 11.1 and 11.0 hang on ‘Starting udev’ on initial install boot. Tried all install options (including failsafe option), disabled HPET timer. So far nothing works. Sometimes udev times out in about 5 to 6 minutes. Then the next message (something like) ‘Loading basic files …’ is shown. But that is the last I ever have seen. Waited for up to an hour or so.
Anybody any ideas on how to proceed to debug the problem? Initial info: MoBo is Asus N2M32 ws pro, 4GB ram. Adaptec 2120 scsi raid (boot device). IDE DVD, sata disks and Blu-Ray. nVidia GeForce 7950 GT graphics card.

We have seen this situation as well with udev…

We have been somewhat successful after removing our adaptec SCSI cards… not sure why as we have been using these since SuSE 9.0…

If you have a Highpoint controller like hpt366, then you see this to. There you can either install without a disk powered on that controller, or add this to Net CD or DVD install boot line :


The likely reason is a broken driver, but for IDE/ATA often the older driver works.

So if you have 11.0 working, then please file something in Bugzilla, to show the likely regression with lsmod output in the report.

Adaptec SCSI cards might be “important” enough to get updated installation disks, which would help other kit that has patches developed but didn’t make the deadline for inclusion to GM.

Frankly though, you’ld be best working with 11.0 and just try 11.1 for test purposes until it’s shaken down.

But please submit bug report to Bugzilla! There isn’t one for Adaptec, so a driver patch is unlikely to be forthcoming in SuSE kernel without that.


I have the same problem. On install it hangs at “starting udev …” and then a few more places it sticks. Hit the enter key and it starts back up. It also sticks in the middle of a game and all sorts of other times. I had 11.0 and had no problems. I put in 11.1 and I am about to go back to 11.0 as I could find no solution to this problem.

the machine is an Asus M3N78-pro with Phenom 9750, 8 GB of PC 8500 and 2 seagate SATA drives. Also 3 Pioneer DVD R/W.

I do some heavy duty math, and just sticking when it wants to is not acceptable. Kind of makes one lose faith in SUSE. Maybe it is that secret contract that they signed with Microsoft a few years ago, a trojan horse to get us to go to windoze.

Since we remove the wlan-card our installation works!

I had the same hang on udev during installation, but now I have it solved.

This is what I did:
1 Removed all cards: no change, still hangs.
2 Tried safe install, no change, still hangs.
3 Played around with AGP or PCI graphic cards, no change.

In desperate state of mind, I switched the BIOS to:“fail safe defaults”. To my surprise, the installation started up without problems, no more hangs…

The machine had a 10.3 installation on a small disc, I replaced the disc with a virgin new larger one, added memory, other graphics card etc. Then started the new installation, with the hang as a result.
Machine is a Gigabyte 8PE667U 82845PE Pentium 4 2.4 Ghz, 1 Gb mem, WD HD

So, try this BIOS mode…

this worked for me, thanks for the post!