openSUSE 11.1 install from Hard disk fails

I’m installing openSUSE 11.1 x86_64 on my laptop.

  1. Copied the ISO image to my Seagate External USB Hard drive (NTFS).
  2. Extracted the initrd and linux images from the ISO and copied into my C: \Boot
  3. Using EasyBCD added entries in NeoGRUB to load the kernel and initrd images.
  4. When I boot my laptop, choose NeoGRUB option and then the entry I added, it boots up fine and gives me the message asking to insert the CD-1.
  5. I choose back, then Install, then choose the source as hard disk, then choose the partition corresponding to my USB HDD (/dev/sdb1), it loads the 6 images
  6. Then I get into the GUI, I choose Next and it does few initializations.
  7. It asks me whether the usb-storage module should be loaded since it has detected a USB storage device. I choose OK and then after few seconds gives me the error in “Initialize Package Manager”. The following is the error message:

Unable to create repository
from URL ‘iso:/?iso=openSUSE_11_1_x86_64.iso&url=hd:///Softiez/opensuse/?device=/dev/sdb1&filesystem=auto’
Details: failed to mount /dev/sdb1 on /var/adm/mount/AP_0x00000001:
Mounting media failed (mount:/dev/sdb1 already mounted or /var/adm/mount/AP_0x00000001

Then when I choose Try again, it gives me a dialog box asking to specify the Repository name, Partition (I get only the partitions on my main drive and not the USB one :(), the location, filesystem, and few other options.

I also tried putting the ISO on my laptop’s main drive but no help there as well, same error - just /dev/sda6 instead of /dev/sdb1.

One more thing I tried is mentioning the USB HDD ISO image the first time as source and then trying to give the repository source as the ISO file on my laptop hard disk, but I get invalid metadata error when I do that.

I installed using the same ISO on my VMWare virtual machine which went smooth without any issues and have also verified the MD5 sum of my ISO which matches the one mentioned during download. So my ISO is clean and good.

Some pointers so far:

  1. When I check the output of the mount command I do not see any /dev/sda /dev/sdb listed in it.
  2. I see there is a mounted directory /mounts/mp_0001 where my entire USB hard disk is mounted and I can see the contents. Could this be the reason ? I tried umount /mounts/mp_0001 -f but it says resource is busy.

Any suggestions - what could be the reason or what else I could try ?



Have a look at this page:
Installation using images - openSUSE
It looks like the install doesn’t like ntfs partitions, so try formatting it fat32.

But it says for 10.3, is it still the case for 11.1 as well ?

4.3 GB image wont fit on a FAT32 partition and neither do I have one one my system… :frowning: Probably should extract the ISO image on a FAT32 partition and try…

Is this some bug with the install system, I can post it bugzilla ?

OK then, make it a linux partition then. I know the link is still for 10.3, but I should imagine it’s still true for 11.x. Try the correct link for the hard drive first and then do the ext3 disc if it doesn’t work.

Ok first tried with extracting the ISO onto a FAT32 partition on my USB HDD and gave it as the source. It picked up initially but didnt get into the GUI portion of the setup, just gave an error and came out.

I then made the FAT32 partition into ext3 on my USB HDD and copied my ISO into it, gave that as the source. This worked though quite clean.

So there is some issue with the ntfs-3g (I believe that is the module which handles NTFS filesystem support) with unmounting of drives which is why it fails during repo setup ?

One more pointer I’ve found while I was playing around in one of the CLIs when I was stuck with the error. When I gave ps -ef, it listed one process mount.ntfs-3fg /dev/sdb1 /mounts/mp_0001 as still running. I killed it and tried, but it didnt make much of difference.

I’m filing a bugzilla on the same.

Thanks whych for your suggestions.

Glad you solved it.
NTfs has always been a problem since it’s all been reverse engineered. Since you are running linux, either use a linux filesystem or ftp/http to the source on a lodal server. The net install has always worked well.

Hmm yes that is a valid point…

If I had another linux box, I could very well use net-install…

I got a brand new 320GB HDD which I thought I could make good use of, thats why initially tried with NTFS…

I created the ext3 partition using Acronis and then I copied the ISO from my NTFS to the new ext3 partition after booting up only, Ctrl+Alt+Fx is always helpful :smiley:

If you can do set a windows box up with a basic ftp or webserver, you can put the installation media on the windows box and do an ftp or http install. Just point the install at the correct ipaddress for the windows box.