opensuse 11.1 instalation - black screen problem

hello,

I have downloaded dvd iso from two different servers, burned it to two different dvds, checked md5 sums…

when I lounch installation, kernel is loading to memory, when it get to 100% my screen becomes black, and nothing more appears.

help?

my laptop is :
compal ifl90
nvidia gt 8600m
Santa Rosa with centrino duo 1,7

oh, and there was no problem with opensuse 11.0 and 10.3

hi friends,
i have the same problem of niematunikogo
I have tried with 11 and 11.1 version and both don’t work.
Now i have tried with 10.3 live cd (KDE) version and it works.
Can somebody help me installing 11 or 11.1 version?

I have samsung R710 series notebook.

hello again,

I still cannot solve this problem.

Now I can see that :

  • when trying to install opensuse 11.1 , after kernel is loaded -> black screen appears in ALL modes (safe, text, etc.)
  • once for every 10-15 times the installation process continous and I was able to instal opensuse11.1 with kde 4.1

BUT

the problem with black screen appears when I boot my system, after choosing opensuse 11.1 in GRUB - black screen apears…

it’s the same problem like with instalation, once for every 10-15 tries I can load system succesfully - every other time I can see only black screen.

same thing happends after installing opensuse11.1/kde3.5

If I You cannot help me I will be forced to install opensuse 11.0 again, becouse I cannot waste 10-15 minutes for just turning my computer on.

ofcource I have all nvidia drivers in place.

I read that there where some intel chipset (965) problems with kernel >2.6.25
maybe there is the problem ?
(e.g. FIX: Intel 965P based motherboards — Fedora Unity Project )

My laptop is:
Compal IFL90
platform Santa Rosa
centrino duo 1,7ghz
nVIDIA GeForce 8600M GT 512MB GDDR2
Intel® 965PM chipset + ICH8M

please do help me, this is quite critical issue for me.

Hello & welcome!

I’m afraid there is no exact fix for this at the moment (not that I’ve seen anyway). I’m suspecting a kernel update should address this issue - but I don’t expect that being any time soon (as in this week).
I’ve been running openSUSE 11.1 without too much issues on my laptop for some time now, but it uses the 945 chipset.

It might be best to stick to 11.0 for another month or so… I would think many issues should be fixed by then.

Wishing you luck,
Wj

I’m experiencing the same issues, too.

I am Linux newb, currently using Ubuntu (Intrepid) and decided to download OpenSUSE to evaluate.

I downloaded the KDE4 Live CD (verified) and when I attempt to boot up, it goes through the boot sequence and promptly sends my LCD into an unsuable frequency after it loads KDE.

My LCD supports a Vsync of 60Hz but the Live CD sets it to 81.3Hz, causing my LCD to go out of range and turn blank.

I’ve searched for a solution and think I’ve found one at this website, Lazy Tech Guy: OpenSUSE 11 Beta 3.

Like him, I have an nVidia card (8800GT which is listed as auto-detected) but frankly, I haven’t the foggiest how to go about doing the things he did.

Help at this point would be invaluable :slight_smile:

OK, I managed to get it working by doing what Lazy Tech Guy did, through following the instructions in another similar thread.

Hi & welcome!

I was just reading the blog you pointed to… good to see you have sorted it. As I get it he was having a problem after installing from the LiveCD and then when booting the installed system.

I understood from your post that you initially didn’t even get the LiveCD started?

Thanks for the feedback btw! :wink:

Cheers,
Wj

just a little news :
Opensuse 11.1 x86 works on my notebook.
i can install it and use.

i have just one problem with GRUB but i’ll report it with another post if i’ll not find a solution with search :wink:

Yup, didn’t even get to the see the loading screen once X-server fires up. LazyTechGuy also never got a boot screen from the LiveCD, so his issue was identical to mine.

For future reference, these are the steps I took:

  1. Under ‘Boot Options’, type in ‘3’ to boot at Init Lv.3
  2. Once kernel is loaded, log in as ‘root’
  3. Launch SaX with the command ‘sax2 -r -m 0=vesa’, I presume this is a safe mode that gives you a GUI to alter X-server’s configuration.
  4. Change your settings as required. Test and Save. Exit SaX (automatic)
  5. At the prompt, type ‘startx’.
  6. Heave a sigh of relief.

Good info and recap! :slight_smile:

my temp solution is to make a working copy of /etc/X11/xorg.conf (let it be /etc/X11/xorg.conf.working4me),

in grub write: “init 3”
login as root,
copy our working xorg:
cp /etc/X11/xorg.conf.working4me /etc/X11/xorg.conf
and type “init 5” to lounch X

works and it is much faster that lounching sax2 each time. (plus: sax2 not always works! sometimes it results in black screen too!)

update:

it seems that it is still not working … sometimes…