openSUSE 11.1 / gnome and no window decorations

… and apart from missing window decorations,
I cannot select windows, and I can’t type into them and so forth.

I also don’t see “metacity” on the process list any more.

What’s going on?

Obviously you resp. I can’t work like that.
Luckily enough I got used to do experiments like that on machines, that are not my main desktop machines.

Try alt+f2 and enter metacity --replace
If you installed compiz-fusion recently… that’s most likely the cause, and if you got emerald installed you might want to use emerald --replace instead (in the same dialog)

this happened with me… when i upgraded the system. so… i did a fresh install … and it’s perfect now.

Oh, how bad!
F2 is on the keyboard,
and the keyboard is inactive wrt. this.

The window manager actually does allow me
to type into yast’s search field though.
So it’s not that the keyboard is completely unfunctional.

So I am a little stuck.

Well, right now a complete fresh install is not an option regarding this box.

I had the same issue when upgrading from 11.0 to 11.1. As a workaround I disbabled Desktop Effects, which immediately brought the window decorations back.

Please go to Yast or “yast2” in the konsole, or use zypper and search for “gtk-qt” packages and install the packages or upgrade them.

Sorry, but i found a stupid way of fixing.

Enter gnome and disable “Desktop Effects”.

Fixes Gnome missing decoration and KDE 4.2 too…

For all who is having nVidia card, please follow below:

  1. Backup your /etc/X11/xorg.conf
  2. Edit your xorg.conf
    A. In the Screen0 section add the following:
    Option “AddARGBGLXVisuals” “True”
    B. Save new xorg.conf
  3. Restart X (Logout and Login)