Opensuse 11.1 does not see samba shares

Hi everybody!

Just installed Opensuse 11.1 on my vostro 1700, everything’s working very fine but when I click on the network icon I see all the computers on my network (xp, server2008, vista) I click on any and it won’t display any shared folder.

on vista computer I have a shared folder called “downloads” which I don’t see as I said before, but if I go to “location” and complete the address smb://vista/ adding “downloads” and pressing enter key , it will ask for the password allowing me to browse my files.

Any ideas about this? thanks!

I have a similar problem some time ago. I changed firewall rules as the image below:

samba-cliente.jpg (image)

(I’m spanish, so image is spanish also,Im sorry)

For security reason you should change “0/0” (“red” or network in the image) for yor own subnet (usually

I have this too. Adding the firewall rule only made the PC show up on the network but the shares on the PC still don’t show up.

you may try this “howto”:

Samba and Suse: HowTo Set up an openSUSE-Windows Home Office LAN/Network. Versions 10, 11

Well if you get far enough for the system to ask for a password, then it clearly sees the machine and the shares - it’s a case of the Windows system not allowing the Linux client to authenticate.

Enable simple file sharing or guest account.

Es raro porque tengo desactivado totalmente el firewall …

nahhhhhh it’s Opensuse 11.1 , I had installed Fedora Core 11 Preview and It was working perfectly, I had the same issue with Ubuntu 9.04 alpha, but then it corrected on the way they sent updates to me, my firewall is disabled totally, but between these two distros I like Opensuse more because the look and the control panel that is superb.


Also watch out cuz the firewall opened the samba port for the External Zone (it comes defaulted to this zone) you should open for the internal zone, so noone from the internet will browse your files.

I think I did not explain good enough, I said that I can see all the computer names ,but when I click on “pc” It won’t display any shared folder to me, so I have to go to the “location” on the menu and complete smb://pc/the_name_of_the_folder , which is a total hassle cuz I don’t remember my 40 shared folders

welllllllll while someone answers me I will give a try to another distro…waiting to reinstall opensuse back!

On Mon May 25 2009 09:16 pm, gabriel2007 wrote:

> welllllllll while someone answers me I will give a try to another
> distro…waiting to reinstall opensuse back!

  1. What are you using to browse your Window’s shares?

  2. What is the result of:

smbclient -L <netbios name> -Uguest%

Replace <netbios name> by the name of your Windows machine. If smbclient
shows the shares then your problem is with the browser.
3. If smbclient fails also you might want to read/reread the HowTos on
Swerdna’s site:

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

This is exactly what happens with me too. Strange you cannot browse the share just by clicking on the server icon. I’d like to know if this is a bug in which case I’ll have to accept it or if I have a configuration problem.

I assume the FW and SAMBA is set up OK as I can access the shares but typing in the locations manually.

Hi hi

Go look at the resetting smbpasswd command in this ubuntu link… ubuntu 9.04 networking is stupid easy! - Ubuntu Forums

I did this and my samba sharing is working now, havent added the firewall though…

hope it helps :slight_smile:

Just to update this. I only experienced the problem when I was using GNOME. Under KDE and Dolphin it all works as expected. I think the file manager under GNOME is the problem not samba.