opensuse 11.1 DNS requests question

I have a question as to why my DNS requests are made every minute. stuff that I had browsed in firefox hours ago, or from other Applications, are being resolved again, A records, AAAA and CNAME.running wireshark for 3 minutes shows over 20 requests.
Other linux distros I have tried out do not have this behavior, and only resolve when requested on demand. (ie: opening a website, or other app)

How can I stop this behavior?

Go into Yast -> Software Management and search for “nscd” (name server cache daemon). If it’s not installed, install it. You might also need to tweak the settings in /etc/nscd.conf (“man nscd” for more info). (Edited) You might also want to use Yast -> System -> Services (Runlevel) to ensure that it’s running.

Be warned, though, that any good DNS cache is going to respect the “TTL” (time to live) spec on the returned value. Google, just to name one, sets this very short. They accept repeated DNS requests so that they can assign IPs in a round-robin fashion to distribute the load.

Try it with this forum; the IP doesn’t change very often here. See if you can browse right back to it. That’ll give you an idea.

Thanks for the help, thats the cache service I was looking for! :slight_smile:

I too have been playing with wireshark on openSUSE 11.1, and have noticed the same behaviour as kal26 observed.

There are DNS queries being made that reflect my browsing history, long after I shut down the browser.

I am running nscd, and it’s properly enabled by YaST, so I don’t understand how smpoole7’s explanation applies.

I know the cache can be flushed by restarting nscd, but that’s not the issue,

I’m just curious as to why nscd is doing DNS lookups when nothing is prompting it to do so.

The symptoms seem to have gone away after I restarted nscd, used the browser to look here and only here, then shut it down. A few DNS queries then nothing.

I notice reload-count defaults to 5 because it’s commented out in nscd.conf, so maybe that’s what I was seeing, 5 retries before removing the entry from the cache?