OpenSUSE 11.1 Compiz and QT4

It seem that there is a problem with compiz on OS 11.1.
When you launch a qt4 app it crash compiz (with or without emerald) on GNOME.

If someone can help … I try original pckage and update ones form XGL repo …

Stéphane

Same problem here
Each time a kde application is stopped (okular), compiz crashes.

If I disable the “fade” effect in ccsm, compiz process does not crash but all windows disappear. I’m left with a rotating cube !

Same here, I think.

I didn’t see the qt4 link but I did see that it happens with certain apps (qt4?) in combination with effects like ctrl+alt or a window that becomes the focussed window.

The whole screen freezes. Seen it on ATI and on NVidia.

Only QT4 application,I can not use vlc and skype.

Yes QT4 apps (googlearth), I can run some QT3 apps (kooka).

I have found a workaround: install Cybergorg compiz !

CyberOrg » Compiz on openSUSE 11.1

I have blindly followed the steps and I can run any applications under compiz.

Thank you, olivn, your solution solved my problems with Ktorrent and Amarok 2.0 killing Compiz when I closed them. I would like to add that in addition to the instructions you linked, I also had to go into software manager in Yast and make sure I was using the X11:XGL versions of all Compiz-related packages because Compiz window decoration would either refuse to load, or certain plugins wouldn’t load until I had all matching packages. Do not mix X11:XGL and normal OSS Compiz packages.

This problem definitely seems specific to QT4 programs, since I can run Amarok 1.4 just fine without this problem, but Amarok 2.0 killed my Compiz.

I have try same problem and I will try this resolve…

Can someone tell us if the problem exist in 64 bits or just in 32 bits edition ?

It happens to me in 64-bit.

On 64bit system, I didn’t try on 32bit

Compiz crashes on 2 32-bits here.

Is there anything going on on this issue? I understand it is/was holiday time but this is a big problem. Friends of mine that upgraded to 11.1 are reporting the same issue now. Every 11.1 installation I know of is crashing on compiz effects. Since a lot of people I know are using SUSE I had to email them to not upgrade.

Bugger, I am upgrading because I was one of the unlucky ones that got the dodgy compiz update in 11.0 and it has not recovered even with the compiz guys help.

I really need the zoom/follow mouse zoom feature, the others I don’t care much about.

Committed now so I’ll try make it work if I encounter the same problems.

Today I received Compiz 0.7.8-19.1.

Compiz now only crashes when using the Shift Switcher, Ring Switcher and Application Switcher. It will crash at least half of the time when you release ALT+TAB and it tries to come out of the animation.

I am now using the Static Application Switcher and so far it didn’t crash yet. I also tried a new test user with new settings and it behaves the same. Hope someone can find a fix for that.

Other then the above this update fixed some glitches I had with certain animations. So that’s back to normal now :slight_smile:

I have the same problem here …32 bits

Switcher is crashing compiz and I changed it to static and it is not crashing.

Al

/update

Received 0.7.8-20.1

Still crashes

32-bit/IBM thinkpad sl500

Sorry to say, I’m going back to 11.0. It crashes even on turning the cube now.

I removed settings, compiz, installed it again using the suse repo and X11. The fun is gone now. OpenSUSE 11.1 and Compiz aren’t friends.

Five pc’s, ATI, nVidia and Intel. All with exactly the same issue’s. I find it hard to understand why so few people seem to have the same problem.

Too bad :frowning:

Same here:

OS: openSUSE 11.1 32bit
Qt apps used: VLC, SystemSettings

If I close vlc with exit button on metacity or by going to File > Exit compiz stops, if I use “Force Quit” button on my panel nothing happens.

p.s. I can use force quit button but it’s just stupid

I added the following two repositories and updated, I don’t have the problem any more, lol…

Index of /repositories/X11:/Compiz/openSUSE_11.1
Index of /repositories/X11:/XGL/openSUSE_11.1