OpenSUSE 11.1 - can't connect to the internet with KInternet

Hello everybody,

first of all, please apologize for my bad english since it’s not my native language.

I got my internet over the german provider Alice and it requires a pppoe-connection with verifying username and password. On my XP desktop system it works fine (I’m online just right now with my XP system) but connection with KInternet on my SUSE 11.1 - system doesn’t work fine for weeks.

Connection itself perform well, i get this double plug as symbol, but either displaying a website on browser nor ping something on console works. I can only connect to skype and successfully talk to people or chat with them.

KInternet protocols look although good, I can’t figure out any mistakes.

I would be glad if anyone could give me a hint how to solve that problem.

If you need some specifications of my system, please tell me, I’m not that pro on Linux and chose it only for comfortable C-programming and compiling which I need to do while my study.

With best regards
-Schnibba

Select “show protocoll” in kinternet, try to connect again,and post the result. Also, open a teminal and enter dmesg and post result.

No worries about the English, es ist nahezu perfekt;)

Thank you for your fast answer and für die Blumen :slight_smile:

Here we go: (protocol)

SuSE Meta pppd (smpppd-ifcfg), Version 1.59_SVN31 on linux-kvya.
Status is: disconnected
trying to connect to smpppd
connect to smpppd
Status is: disconnected
Status is: connecting
pppd[0]: Plugin rp-pppoe.so loaded.
pppd[0]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
pppd[0]: Plugin passwordfd.so loaded.
pppd[0]: PPP session is 617
pppd[0]: Connected to 00:30:88:03:62:ef via interface eth0
pppd[0]: Renamed interface ppp0 to dsl0
pppd[0]: Using interface dsl0
Status is: connecting
pppd[0]: Connect: dsl0 <–> eth0
pppd[0]: PAP authentication succeeded
pppd[0]: peer from calling number 00:30:88:03:62:EF authorized
pppd[0]: replacing old default route to eth0 [192.168.1.1]
pppd[0]: local IP address 85.179.88.9
pppd[0]: remote IP address 213.191.64.152
pppd[0]: primary DNS address 213.191.74.11
pppd[0]: secondary DNS address 213.191.92.82
pppd[0]: Script /etc/ppp/ip-up finished (pid 4126), status = 0x0
Status is: connected

When typing “dmesg” I get a really huge list of data. I don’t want to overload this forum, so here is a link to console output:
http://schnibba.alpha.webspace24.de/dmesg
Maybe you need some specific detail from this dmesg command?

If I’m not mistaken, the dmesg post shows both the network card and the wireless devices are found.

iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ks
iwl3945: Copyright(c) 2003-2008 Intel Corporation
iwl3945 0000:05:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
iwl394iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
phy0: Selected rate control algorithm ‘iwl-3945-rs’
vendor=8086 device=27d4
iwl3945 0000:05:00.0: PCI INT A disabled
5 0000:05:00.0: setting latency timer to 64
iwl3945: Detected Intel Wireless WiFi Link 3945ABG
iwl3945 0000:05:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
iwl3945 0000:05:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex
iwl3945 0000:05:00.0: restoring config space at offset 0x1 (was 0x100002, writing 0x100006)
firmware: requesting iwlwifi-3945-1.ucode
Registered led device: iwl-phy0:radio
Registered led device: iwl-phy0:assoc
Registered led device: iwl-phy0:RX
Registered led device: iwl-phy0:TX
ADDRCONF(NETDEV_UP): wlan0: link is not ready
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
NET: Registered protocol family 17
bootsplash: status on console 0 changed to on
wlan0: authenticate with AP 00:16:38:3d:53:ed
wlan0: authenticated
wlan0: associate with AP 00:16:38:3d:53:ed
wlan0: RX AssocResp from 00:16:38:3d:53:ed (capab=0x401 status=12 aid=0)
wlan0: AP denied association (code=12)
wlan0: associate with AP 00:16:38:3d:53:ed
wlan0: RX AssocResp from 00:16:38:3d:53:ed (capab=0x401 status=12 aid=0)
wlan0: AP denied association (code=12)
wlan0: associate with AP 00:16:38:3d:53:ed
wlan0: RX AssocResp from 00:16:38:3d:53:ed (capab=0x401 status=12 aid=0)
wlan0: AP denied association (code=12)
wlan0: association with AP 00:16:38:3d:53:ed timed out

The kinternet protocoll shows that the dsl device is connected, Are you using alice DSL? That’s what I use. I connect both wired and wlan using knetworkmanager. Have you tried using it?

I do use Alice DSL but I don’t understand what you mean by “connecting both”. I mean, I need at least a wlan-spot to be able to connect with something.

Here is a screenshot how it looks like right now when I connect.

http://schnibba.alpha.webspace24.de/linux_desktop.JPG

Info is shown by the symbol to the right of plug symbol.

You are running kinternet and knetworkmanager. I’m not sure what happens when 2 applications are running trying to access the same hardware at the same time. Close one of them down.

but I don’t understand what you mean by “connecting both”]

I use knetworkmanager to connect my wired and wireless connections. Right click on the knetworkmanager icon (the icon to the left of the plug;)) and try to configure your connection.

Check your firewall settings. As I wrote before, Kinternet is connecting to the internet, so it must be something else.

Hello again :slight_smile:

I tried all of your advices, but nothing works :frowning:
As you can see on screenshot, I completely shut my firewall down, but without any results.

Clickme

Maybe backup all data and reinstall the system will help to solve it?

i am new to linux OpenSuse 11.1 >>>>
and i m using wireless device of BSNL named ZTE-EVDO

and i don’t know how to configure it so i am can’t use linux…

Anyone can please tell me that how to connect to the internet…???