openSUSE 11.1 Boot Screen

I’ve just installed openSUSE 11.1 and it looks great so far. However, the only thing I don’t like is that I get a regular “Unix-like” console during the boot process, showing me what’s being started. Is there a graphical boot screen instead of this? Could you tell me how to enable it?


Post your /boot/grub/menu.lst

also check in Yast - System - etc/sysconfeditor
System - Boot - Splash=Yes

To add to this:

In version 11.0 right at the initial boot before you got to the suse splash screen we got a nice green and black background when it was starting all the services, daemons, etc. In 11.1 I just get a black background with the lines scrolling by. Did we loose this in 11.1? I kinda liked it in 11.0.

The graphical boot screen has certainly not been removed in opensuse 11.1. What you might find is that if during boot something unusual happens the system may switch back to the console instead. If nothing untoward is happening then you may need just to tweak a setting to get your graphical boot screen back.

The easiest way to fix this without changing any config files is to reinstall the kernel.
Go to yast > software search for kernel you will see your version most likely
kernel-default right click on and choose update.
Reboot when done and your graphical boot will be restored


Well, I had that same problem of not having a bootsplash on 11.1.
Setting a vga= parameter for opensuse’s grub entry fixed it. That and making another initrd. I don’t remember right now which vga parameter I’m using but it anyways highly depends on your PC. I remember that I had to pick a 16 bit one instead of 24 bit for it to work properly.
Bootsplash theme itself can be selected in yast’s sysconfig.

Thanks for all your help guys! I’ll try it out once I get home. :slight_smile:

You can also go to yast > system > boot loader select openSUSE click edit and add 0x31A in vga (this is my setting)


Would this work for a 1024x768 LCD laptop panel? Thx.

vga=0x317 should do for 1024x768 and 16 bit.

Hi no use 0x317


Hey guys. Unfortunately, none of your suggestions worked. However, when I tried to shutdown the “slash” service in Yast->System->System Runlevels, I got a message saying:

/etc/init.d/splash could not be stopped because the program is not installed.

Any clues on how to install the splash screen? Thanks again. :slight_smile: