openSUSE 11.1: bluetooth not working (worked on 11.0)

Hi, my bluetooth dongle is not being detected in openSUSE 11.1 (tried kdebluetooth, both version 3 & 4) whereas it was working perfectly in 11.0. Here is the output of hwinfo --bluetooth for you. Any ideas…

linux-6kst:/home/yogesh # hwinfo --bluetooth
04: USB 00.0: 11500 Bluetooth Device
  [Created at usb.122]
  UDI: /org/freedesktop/Hal/devices/usb_device_e5e_6622_noserial_if0
  Unique ID: FKGF.umJ35_L6pC7
  Parent ID: pBe4.v+N+B0xY+P6
  SysFS ID: /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0
  SysFS BusID: 2-1:1.0
  Hardware Class: bluetooth
  Model: "Conwise USB demo board"
  Hotplug: USB
  Vendor: usb 0x0e5e "Conwise Technology"
  Device: usb 0x6622 "USB demo board"
  Revision: "0.4e"
  Driver: "btusb"
  Driver Modules: "btusb"
  Speed: 12 Mbps
  Module Alias: "usb:v0E5Ep6622d004EdcE0dsc01dp01icE0isc01ip01"
  Driver Info #0:
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"
  Driver Info #1:
    Driver Status: hci_usb is active
    Driver Activation Cmd: "modprobe hci_usb"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #2 (Hub)

Does bluetooth work from the command line?
For example, does
**hcitool scan **
command lists available devices (MAC-adresses and names)?

If it does, please, read this thread
openSUSE 11.1 KDE3 Bluetooth solution - openSUSE Forums

No device is listed thus.:frowning:

Maybe this a little bit silly hint,
but are you shure, that some bluetooth device is around,
when you you run hcitool scan?

This command returns

hcitool scan
Scanning …

and lists nothing if it hasn’t found any bluetooth device.

And if your bluetooth-adapter is disabled (via switch),
bluetooth module is not loaded, etc it lists:

hcitool scan
Device is not available: No such device

So how does this command output look like?

yogesh@linux-6kst:~> hcitool scan
Scanning ...

It seems to me, that bluetooth works,
but you have no bluetooth device in range of your bluetooth adapter.

I get exactly the same output,
when there are no bluetooth devices around or if phone’s visibility option is OFF.

Have you checked bluetooth visibility settings of the device you want to connect to?

Unfortunately I don’t know any other way,
to check whether your bluetooth works or not,
as I’m not an expert in this field either.

Sorry for following up so late…

When I try bluetooth/KDE3, it fails to load showing a message that no bluetooth device could be found. When I try bluetooth/KDE4 it simply does not show up, i.e. it keeps running in the background but no systray icon is shown (I recall this behaviour with openSUSE 11.0 when I detached my bluetooth adapter and the icon come back when I attached it).

Can some guy from openSUSE help here?

I can also try another bluetooth software if you suggest one.


Yes I understand, what do you mean,
I had the same problem: bluetooth worked in 11.0
and ‘stoped’ in 11.1.
Atcually it worked from command line in 11.1 only KDE3/4 didn’t see it.

I just wanted to make sure your bluetooth
adapter works from command line.

If you have troubles with checking that, just
go straight to this thread and follow
instructions in the first post:

openSUSE 11.1 KDE3 Bluetooth solution - openSUSE Forums
I think that’s basically all you need.

I’m sorry if my instructions and intentions were somewhat obscure.

Visited kde-apps and noticed that Kdebluetooth4 is still not ported to bluez4. Downloaded bluez3 from openSUSE build service and now bluetooth works but not all supported features (by KDE4) are working. HID is working though, which is enough for me for now.

Thanks for you valuable support :slight_smile: