OpenSUSE 11.1 beta 5, Qt static or dynamic?

Hello!

I am the author of FET (lalescu.ro/liviu/fet/).

I used until 1 week ago OpenSUSE 11.0. I compiled FET and the size was little (the executable had ~12 MB). It is a Qt4 project.

Now, I installed OpenSUSE 11.1 beta5. I am compiling FET and the size of object files (.o) is very large. Also, the executable is very large, ~100 MB.

Is OpenSUSE 11.1 beta5 having a static version of Qt4? Or am I doing anything wrong?

How can I check that my Qt is static or dynamic?

Under Windows, it seems that compilation of FET is just as before, even if I switched from Qt-4.4.0 to Qt-4.4.3, to follow the update under OpenSUSE.

I saw that my object files (.o) and the executable are not stripped (I see that in the midnight commander). How can I make them stripped, from the qt project files?

Did the openSuse developers change the default non-stripped to stripped?

I have seen that the Makefiles contain the “-g” attribute. If I remove it, the size of the files is small.

Why the Qt generates this “-g” parameter? In older openSuse, I had not this parameter. Also, other users of Qt 4.4.3 told me that compilation of my program generates a small file.

I think I found the problem:

See file /usr/share/qt4/mkspecs/common/g++.conf

It has for release the attribute -g. This attribute is not in the official Qt release.

Probably, it is because I am using a beta version of OpenSuse. so I think I need to wait for the official release of OpenSuse 11.1, which hopefully will have solved this problem.

I saw that my object files (.o) and the executable are not stripped (I
see that in the midnight commander). How can I make them stripped, from
the qt project files?

Did the openSuse developers change the default non-stripped to
stripped?


lalesculiviu

lalesculiviu’s Profile: http://forums.opensuse.org/member.php?userid=15863
View this thread: http://forums.opensuse.org/showthread.php?t=400252

I have seen that the Makefiles contain the “-g” attribute. If I remove
it, the size of the files is small.

Why the Qt generates this “-g” parameter? In older openSuse, I had not
this parameter. Also, other users of Qt 4.4.3 told me that compilation
of my program generates a small file.


lalesculiviu

lalesculiviu’s Profile: http://forums.opensuse.org/member.php?userid=15863
View this thread: http://forums.opensuse.org/showthread.php?t=400252

I think I found the problem:

See file /usr/share/qt4/mkspecs/common/g++.conf

It has for release the attribute -g. This attribute is not in the
official Qt release.

Probably, it is because I am using a beta version of OpenSuse. so I
think I need to wait for the official release of OpenSuse 11.1, which
hopefully will have solved this problem.


lalesculiviu

lalesculiviu’s Profile: http://forums.opensuse.org/member.php?userid=15863
View this thread: http://forums.opensuse.org/showthread.php?t=400252