OpenSUSE 11.1 Beta 5 in VirtualBOX, issues

I’m new to OpenSUSE 11. I did test a very old version of Suse many years ago but this is my first encounter with Suse in many years. Seems like it has grown to one of the best distributions out there.

Right now I’m testing OpenSUSE 11.1 Beta 5 in VirtualBOX after testing beta 4 fore 2 days. The odd thing is that Beta 5 gives me more problems then beta 4. This is the third re-install of beta 5 and I still can’t get things to work that worked fine in beta 4.

Firs install.
The install goes well, everything boots up nicely but when KDE 4 had loaded I could not clock on anything. I could not close the Welcome Windows that pops up when KDE boots. I could not click on the “Start Menu”. The little box with the description pops up if I hold the mouse over the “Start menu” but I can’t click it. Since I can’t do anything I decide to shut the machine down by force. After doing so and booting the system again I just get a login prompt. Nothing else. Ohh crap. So I decide to re-install the system.

Second install.
After reinstalling the system for a second time. The system boots up but no KDE. Only a login prompt. Ohh crap I was thinking. I decide to re-install it again. Maybe it was just some random glitch.

Third install.
This time after the installation is complete. The system does not even boot up. Things seems to get worse and worse. I decide to close VirtualBOX and restart it. The application crashes. So it seems that Virtual Box has some issues too.

Fourth Install.
This time everything works well after restarting VirtualBOX. Installation flows smoothly and KDE loads on start up. But again. I can’t click on anything. Just like the first time. I don’t know if this is OpenSUSE with the new version of KDE that make me haveing these issues or something with VirtualBOX but the fact of the matter is that I did not have these issues when testing Beta 4 just 2 days ago.

Anyone else testing in VirtualBOX that has any clue what this is all about?

So if someone else is testing beta 5 out in VirtualBOX it would be nice if you could share your experience so far. I will try to re-install it, again, tomorrow. I just ran out of time tonight… And again. I didn’t have these problems in beta4. And the Virtual machines are configured the same way.

Yes similar problems with 11.1 beta5 live kDE using VirtualBox.
I get the initial boot screen with the various options failsafe, check media etc, but attempting to boot normally or failsafe It sometimes boots into the KDE desktop other times it fails to boot it just hangs on a completly blank black screen. Mouse is completly dead in all cases.

I just got it to boot up in KDE.
But I had to terminate the system after install because it was just hanging with a black screen. Now the system is running but the issues with the mouse remains. Right click and Left click does not work. I can mouse the mouse around but not click. The Keyboard works though.

I am having the same problem. Mouse buttons don’t work. Mouseover is ok, but when clicking nothing happens.

I hope it is just a vbox problem because it is the first time that mouse is integrated (MI) and not captured.

What version of VBox are you guys running? The latest 2.0.4? Are you using the OSE or full?

I have not tried Beta5, I will wait for RC1 cuz I want to test 3D acceleration and it’s usually not in betas, only RCs.

I can tell some other distros have similar problems when virtualizing pre-release versions, due to some config values in the /boot/config* file. But that might not be the problem here.

Is the system slow or just glitches like you experienced?

I am using Virtualbox 2.0.4-9.1 OSE.
This beta should have been RC1.

Are you aware of this entry in the Most Annoying Bug List for Beta 5?

Bug #444747: Mouse doesn’t work in VirtualBox, Workaround: sed “s/vboxmouse/mouse/” -i /etc/X11/xorg.conf

Yes, I just installed and everything is up; more to config though.
(that is not the OSE version)

I just followed the guide here: 11.0, VirtualBox-1.6.2 non-OSE and USB Success - Page 3 - openSUSE Forums post #1 which gets me my usb devices up (especially my printer/scanner).

Did you add yourself to vboxusers group in Yast? Do that 1st thing – get to Yast > Users > highlight your username & click the details tab & tick “vboxusers”; save out of all that.

Then don’t forget to add “Install Guest Additions” once you have an OS installed;)

I’m using VirtualBox 2.0.4 on Mac OS X host and openSUSE beta 5 as the guest. I haven’t had any problems with the mouse, but I have gotten the black screen after the grub screen. Strangely, after getting the black screen several times in a row, I turned off my wireless and then beta 5 booted normally. Go figure.

Sometimes it works normally. I also have a problem with my resolution changing from 1024x768 to 800x600 when I reboot openSUSE. Changing to runlevel 3 and then back to runlevel 5 fixes the res. Strange.

I had the same mouse problem in VBOX 2.0.4 and ramlight’s fix is working like a charm! I will keep that in my notes for sure.

I wonder why they replaced RC1 with Beta5.

I try the KDE4 version, as I am sold to KDE.
I hope people will create more icon sets for KDE4 (, there is pretty much nothing fully working yet (could not find how to change default oxygen folder icon for all folders) and I like using different icons, but that has nothing to do with this beta version. :slight_smile: Off topic opinion. :slight_smile: I noticed though that KDE seems not to be working well when you install new themes (icons) from the KDE installer. You click install, but nothing installs. This is not related to openSUSE cuz I tried other distros and they all do the same.

KDE4.1 is a good improvement over KDE4.0. I wonder if Gnome might lose any “market share” and popularity due to the improvements of KDE4 over KDE3? Any comments on this?

Or another question, what makes Gnome different from KDE? Looks only? Sorry this is also off topic if I read the thread’s subject. :slight_smile: I will scan internet for a thread on this, then. :slight_smile:

Are you aware of this entry in the Most Annoying Bug List for Beta 5?

Bug #444747: Mouse doesn’t work in VirtualBox, Workaround: sed “s/vboxmouse/mouse/” -i /etc/X11/xorg.conf

Thanks, that did it for me!