opensuse 11.1 audio problem

I am having a problem with the audio on my Toshiba Satellite 2410 laptop. I cannot hear anything when playing an audio file using Totem or playing a video on youtube. I think this problem started when I performed the latest online updates from opensuse. Note that when I startup linux, I can hear the startup tune. Could someone help out

-The kernel I’m using is…

$ uname -a
Linux wt-maui #1 SMP 2009-02-25 15:40:44 +0100 i686 i686 i386 GNU/Linux

$ rpm -qa | grep alsa

$ rpm -qa | grep pulse

$ rpm -qa | grep libasound2

$ cat /etc/modprobe.d/sound

options snd slots=snd-intel8x0

W60f.D2X3JBvzCb1:82801CA/CAM AC’97 Audio Controller

alias snd-card-0 snd-intel8x0

$ rpm -qa | grep flash

-The following command worked ok. I can hear audio from both left and right speakers

$ speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.18

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 8 to 16384
Period size range from 8 to 16384
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
0 - Front Left
1 - Front Right
Time per period = 2.736919
0 - Front Left
1 - Front Right
Time per period = 3.069962
0 - Front Left
1 - Front Right
Time per period = 2.901598
0 - Front Left
1 - Front Right
Time per period = 3.071745
0 - Front Left
1 - Front Right
Time per period = 3.071071

-I have the following audio configuration

Control Center>Sound
Sound Events>Sound Playback=Autodetect
Music and Movies>Sound Playback=Autodetect
Audio Conferencing>Sound Playback=Autodetect
Audio Conferencing>Sound Capture=ALSA
Default Mixer Tracks>Device="Playback:Intel 82801CA-ICH3-Intel 82801CA-ICH3(PulseAudio Mixer)

-everything seem to check out ok when the test buttons have been pressed in Control Center>Sound

Pulse Audio Applet>Volume Control
-all the meters(Playback,OutputDevices,) are moving when an audio file is played by Totem. But I’m hearing no sound.

-I followed the instruction on a previous thread, No sound in 11.1 x86_64 - openSUSE Forums and Alsa-update - openSUSE and it still does not work.

If you are going to update your alsa, which you have by installing alsa-driver-kmp-default, then you need to be consistent and install the correct version of all your alsa apps. I highlighted in red every version of alsa that is wrong on your PC, in terms of a lack of consistency with the alsa-driver-kmp-default update

. In particular I high lighted in bold the alsa-driver-kmp-pae which should not be installed at the same time as alsa-driver-kmp-default.

So, remove alsa-driver-kmp-pae. Then update those alsa applications, using the alsa-update page as a guide: alsa update page for 11.1 - openSUSE

Reference your following some other guides. … well I wrote one of them, and I know it does not say to install both alsa-driver-kmp-default and alsa-driver-kmp-pae. Instead it says to install the version consistent with your kernel and your kernel is a default kernel. Its not a pae kernel. So that was NOT understood and hence not followed. I also know the alsa update page says to update various alsa applications, which clearly was not understood and not done.

I’m tired tonight. In need of a vacation (fortunately I’m off on vacation tomorrow), but I do NOT know what more I can do, without overly complicating that guide, to make it more clear. < sigh > … Maybe I should just go on sebatical for month or two :idea: and all of this will be solved and clear to everyone when I come back. :expressionless:

Good luck! If you hear nothing from me for a bit less than a week, its 'cause I’m on holiday, … not because I’ve given up. … apologies for the guide being so impossible to follow.


Thanks for the assist. I should have read your document more closely. I have since updated all the required applications. The problem still persist.

I noticed that although I cannot hear audio from Totem or while watching videos. Banshee does work ok with the audio and video files. This is strange.

$ rpm -qa|grep alsa

$ rpm -qa|grep libasound

Apologies for the tone in my last post. … I guess I am fatigued … which is no excuse. I DO need to find a way to improve the guide, and I think I just need some quiet time to ponder it.

Anyway, the fact Bashee works is a good sign.

It suggests Totem is using an inappropriate audio input module or Totem is looking in the wrong place for the codecs (perhaps a build incompatibility). Since I use neither banshee nor totem, I can’t help re: their settings, but look for the input audio module control. It may be set to ‘auto’ or ‘pulse’ or ‘alsa’ . Try a different setting.

Reference youtube, I have installed flash-player and also smplayer and mplayerplug-in. That allows me to play youtube.
One thing to be careful of is too many repositories in your Software Package Manager. Unless one is an expert, this is a case where more is NOT better. I try to keep my repositories to a minimal list, and I recommend only 4 and not others. Those 4 being OSS, Non-OSS, Update and Packman. Others can be added only after one learns. to identify the problems that can happen, and learns how to solve the problems that can occur. There is guidance for setting up those here: Repositories/11.1 - openSUSE-Community
Again, just those 4.

If you selected videolan repository, then I recommend you remove videolan repository and replace any videolan packaged apps with packman packaged versions. Note you can search and install new software (once those 4 repos are setup) by going to YaST > Software > Software Management and change “filter” to “search” and search for new apps, such as smplayer, mplayerplug-in. I also recommend libffmpeg0 (from packman, NOT videolan) and w32codec-all, and xvidcore. You can tell packman packaged apps by the “pm” in the file name.

In addition to smplayer, I also like xine (ie packman libxine1 and xine-ui, replacing Novell/SuSE versions) and vlc.

Good luck.

Further testing shows…

youtube video -> cannot hear audio
google video -> cannot hear audio
Totem audio file playback -> cannot hear audio
Banshee audio file playback -> works ok
blogtv video -> works ok video -> cannot hear audio

Interesting thing with is that the video also uses embedded flashplayer plugin.

IMHO this is a mix of non-optimized settings in some applications, and application incompatibilities in other areas. Try working your way through this:
Check your multimedia problem in ten steps - openSUSE Forums

Again, note for youtube and google video I use flash-player and mplayerplug-in. Also note I am a 32-bit user, and that many 64-bit users struggle in trying to get their flashplayer setup. Are you a 64-bit user? If so your problems with some apps could be because you don’t have your 64-bit apps setup/installed appropriately (that is speculation on my part). And if this is 64-bit related, then I can’t help as I have no experience there.

OK, I note again from your kernel its 32-bit , so you are a 32-bit user. … Bad memory on my part, … and possible a sign of the fatigue I’m feeling.

Good luck with your efforts.