openSuse 11.1 and Brother HL-5150D

I recently upgraded from 10.3 to 11.1. With 10.3 my Brother HL-5150D worked perfectly but 11.1, despite appearing to load the drivers during install, my printer doesn’t work.

Any suggestions?

All printer drivers do not work properly with Brother HL-5150D and all programs.

BR-Script3 (ex Brother) and Foomatic/Postscript do not work with Gimp 2.6 The printer prints : ERROR NAME : ioerror
COMMAND ; fill
OPERAND STACK
Same drivers do not work properly with OpenOffice 3 Writer : if you print twice the same page, the second time it prints non comprehensible things.

The Foomatic drivers work ok, except pxlmono.