OpenSUSE 11.1 Adibe Flash Not Woring!


I am pretty new to OpenSUSE 11.1 I have fire fox 3.0.4 and I am running on a Thinkpad R52 , 32 bit PC. I cant not seem to get Adobe Flash player working at all. I have tried downloading it and used Yast. It says that adobe flash version 10 is installed on my system in Yast but it still will not work in firefox and says to install. Any help would be great!

Are you using the 64-bit version or the 32-bit version of openSUSE 11.1?

I am using the 32 bit version.

from a terminal post result of:

rpm -qi flash-player
uname -a

We need more info that it’s not working - Details:)

In the below order:

Ryan@linux-ikqx:~> rpm -qi flash-player
package flash-player is not installed

Linux linux-ikqx #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

become su in terminal and do

zypper in flash-player

Ryan@linux-ikqx:~> zypper in flash-player
Root privileges are required for installing or uninstalling packages.

How Do I become SU? I am a pretty huge noob to linux and Open Suse

type su
then the root password (which does not display as you type)

then the zypper command I gave

You simply type su - and it will ask for your root password.

Remember to type exit after running the zypper command and installation.

Ryan@linux-ikqx:~> su
linux-ikqx:/home/Ryan # zypper in flash-player
Loading repository data…
Reading installed packages…
‘flash-player’ not found.
Resolving package dependencies…
Nothing to do.
linux-ikqx:/home/Ryan #

It seems that for some reason you’re missing the repositories that should have been setup for you during the installation (automatically), please copy paste the results of this command here;

zypper lr -d

Agreed - post this as Heidi requests

Ryan@linux-ikqx:~> zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | GNOME:STABLE:2.24 | GNOME:STABLE:2.24 | Yes | Yes | 99 | rpm-md | Index of /repositories/GNOME:/STABLE:/2.24/openSUSE_11.1 |
2 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
3 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
4 | repo-non-oss | repo-non-oss | No | Yes | 100 | NONE | Index of /distribution/11.1/repo/non-oss |
5 | repo-oss | repo-oss | No | Yes | 100 | NONE | Index of /distribution/11.1/repo/oss |
6 | repo-source | repo-source | No | Yes | 100 | NONE | Index of /source/distribution/11.1/repo/oss |
7 | repo-update | repo-update | No | Yes | 20 | NONE | Index of /update/11.1 |

Change them like this.
This will help you
Repository Management - openSUSE Forums

Well there’s the reason - the update and non-oss repositories are disabled!

You can use the YAST / Software Repositories to enable them and then you can install flash-player!

Or you can type these (as root) in the command line to get the same result;
**zypper mr -e 4
**zypper mr -e 5
zypper mr -e 7

Then you can install flash-player from YAST / Software Management or with the zypper command we gave you earlier.

Or you can type these (as root) in the command line to get the same result;
zypper mr -e 4
zypper mr -e 7

Nice and simple. I like Heidi’s way better.

It worked! Thanks to you both for helping me with this!

As a sidenote, because you’ve had the update repository disabled you will have LOTS of updates coming that you might want to install, Firefox updates - Kernel updates. lots and lots of stuff that have been updated and fixed since the release went out.

Well done
+1 to Heidi’s comment

zypper up

will update the system