opensuse 11.1 64bit: problem installing Sun Java EE SDK

I’m trying to install Sun’s Java EE SDK on my opensuse 11.1 64bit system. The file I got from Sun’s site (Developer Resources for Java Technology) is java_app_platform_sdk-5_07-linux.bin

I gave it execute permission and ran it. The following is the result.


./java_app_platform_sdk-5_07-linux.bin: error while loading shared libraries: cannot open shared object file: No such file or directory

I tried to find using Yast but with no success. There doesnt seem to be a version 5 of this library.

Could someone help out?

Hi, I have Java JDK 1.6 and NetBeans6.5.1 installed on my openSuSE since I need it for school, and I don’t have the libstdc++ library as well. I’m not sure if it’s needed after all. Where’d you get java_app_platform_sdk-5_07-linux.bin from ?

Ok, I tried it, it I got some silly error, We’re together on this. Let’s get on it.

Get the


Here’s what happens

When I try to upgrade, which should the be default option since all we’re doing is just upgrading the platform →

rpm -Uvh libstdc++5-3.3.6-3mdk.x86_64.rpm

I get the output of:

warning: libstdc++5-3.3.6-3mdk.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 70771ff3
Preparing...                ########################################### [100%]
	file /usr/lib/ from install of libstdc++5-3.3.6-3mdk.x86_64 conflicts with file from package libstdc++33-32bit-3.3.3-7.10.x86_64

Which makes no sense at all! Of course it’s going to conflict the 3.3 package, since I’m upgrading it.

I tried installing it.

rpm -ivh libstdc++5-3.3.6-3mdk.x86_64.rpm

Got the same output. I posted in couple of places. I’ll try to get my friend to help me out, too.

Good luck until then.


whereis /usr/lib/ /usr/lib64/ **/usr/lib64/**
rpm -qf /usr/lib64/

And please ignore the above post, hammering Madriva packages into an openSUSE is completely stupid, especially because it conflicts with an already installed package.

DON`T do that!


Yes, after a couple of minutes, I figured out, it’s a mandriva package :smiley:

Anyways …

I got another package, it’s says it’s for openSUSE 11.0, it’s an src.rmp then when archived it becomes .rmp I try installing it, but it reads.

invalid rmp package…

It says its a x-rpm package. What would that possibly mean ?

You can download it from Developer Resources for Java Technology
Just look for the Java EE 5 SDK and download it.

  1. I already showed you which package contains

  2. Why don’t you use the java-Packages provided by openSUSE? (java-1_6_0-sun)?

Java Standard Edition (SE) is already in the repositories. Just use the Yast tool to install it.

Enterprise Edition (EE) is required only if you want to run server based applications (such as webservices etc.). For running normal Java programs, you don’t need Java EE.

I need to do Java EE developments. That’s why I’m looking to install the Java EE SDK from Sun.

Ok. I’ve installed java-1_6_0-sun-devel from the opensuse repository hoping that would be installed by that package.
Still no luck when trying to install Sun EE SDK afterwards


./java_app_platform_sdk-5_07-linux.bin: error while loading shared libraries: cannot open shared object file: No such file or directory

zypper update libstdc++33-32bit

I did that and this is what I got.

zypper update libstdc++33-32bit

Retrieving repository ‘openSUSE-11.1-Update’ metadata [done]
Building repository ‘openSUSE-11.1-Update’ cache [done]
Retrieving repository ‘Packman Repository’ metadata [done]
Building repository ‘Packman Repository’ cache [done]
Loading repository data…
Reading installed packages…
Package ‘libstdc++33-32bit’ is not installed.
Resolving package dependencies…
Nothing to do.

This is the problem: you’re running a 64bit system, and the SDK is 32bit. So the SDK is looking in /usr/lib instead of /usr/lib64. If you would get the installer to look there, you’d get ELF errors.
This is what you do to get it working, mind that you typed ‘update’:
zypper in libstdc++33-32bit

As you can see from the output below, it puts the library where the SDK wants it:
LapTop:/home/glosscomputer # uname -a
Linux LapTop 2.6.29-6-default #1 SMP 2009-03-24 15:38:18 +0100 x86_64 x86_64 x86_64 GNU/Linux
LapTop:/home/glosscomputer # whereis /usr/lib/ /usr/lib/ /usr/lib64/

Thanks, the solution posted by Knurpht solved the problem.