OpenSuse 11.0 won't boot

Hi all,

I’ve been running OpenSuse 11.0 for a few months now and it’s decided to not boot. I tried booting in safemode but it hangs at the following point

Starting SSH Daemon (Done)
/etc/init.d/AVGd: line 21: ID: command not found
/etc/init.d/AVGd: line 21: :-ne: unary operator expected

Can Anyone help me out pls?

Are you running the Linux version of AVG anti-virus? If so, why?

To get started, boot any live CD. When it gets booted, open a terminal
and issue the following commands:

sudo mkdir /fix
sudo mount /dev/sdaX /fix
sudo rm /fix/etc/init.d/avgd
sudo umount /fix

You need to substitute the partition number of / on your machine for X.



Thanks for the reply. I’m running a dual boot Suse/XP machine and use the AVG to scan my window folders. It’s been working fine until now…kinda bizarre that it just stops one day.

Your instructions above will be deleting the /etc/init.d/avgd folder so that it is not accessed on boot, am I correct?


I tried sudo mount /dev/sdc /fix

(Substituting the correct drive letter as you suggested)

I get the following message:

*mount: you must specify the filesystem type

I’m trying to mount the linux partition on the drive. This is a dual boot machine so the drive also has a windows partion.

I then tried

sudo mount -t ext3 /dev/sdc /fix

But I get the following message:

mount: wrong fs type, bad option, bad superblock on /dev/sdc,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Any suggestions?

First, let’s be clear on the terminology. You tried to mount the entire drive, rather than the partition file system. (Windows continues a bad old habit of using “drive” as synonymous with “volume” or “partition”; the latter are correct - so, e.g., Windows “C drive” is incorrect terminology.)

Also, as you determined, the syntax posted above was incorrect; it omitted the file system type. Try this:

sudo mount -t ext3 /dev/sdc<x> /mnt
sudo rm /mnt/etc/init.d/avgd
sudo umount /dev/sdc<x>

Where is the openSUSE root partition number that resides on /dev/sdc. Important: The boot error message used “AVGd” rather than “avgd”. If in fact the file name is “AVGd”, then the second line above needs to be changed to exactly that. Linux is case-sensitive (Windows is not). You can double-check the name by, after doing the mount but before the rm command, doing this and looking for the file name:

ls /mnt/etc/init.d

As far as why AVG is now having a problem, I can’t say. It looks like it is trying to start a daemon, and perhaps cannot find a dependency. Was the AVG installation from an 11.0 repository? Sometimes packages from outside the mainstream repositories can run into issues. Let me suggest you consider using clamav instead, in the main repo; it is very mature and widely used including on commercial email servers. There is a KDE and a Gnome gui front-end; the former (klamav) is in the openSUSE repo and the latter (clamtk) is in the Packman repo. I’ve used Klamav and found it to be quite good. If you decide to go this route, you will want to run AVG’s uninstall to clean out that code.

Good luck.

How do I determine my partition number now that Linux won’t boot? Sorry to be such a PITA about this…

Thanks for the info about KlamAV…I’ll give it a go!

No problem at all. :wink:

If you installed from DVD, boot from it into Rescue System, login as root. If you used the LiveCD, boot from it, open a terminal, and switch to root (the “su” command, no quotes). Then do:

fdisk -lu

This will list the partition table for all hard disks in your machine. There will be an “id” column and a “system” column. The Linux partitions will be obvious (“Linux” under system), the mountable partitions will be type 83 (swap will be 82). The most typical setup is 3 partitions, swap plus root plus /home, usually in that order.

In your earlier post you used “/dev/sdc” - I’m not sure where you got that from, but the “c” means the 3rd disk. If openSUSE is on, say, the 1st disk and the root is o, say, partition #6, then you would use “/dev/sda6”.

You can proceed from where you did the fdisk to execute the commands I provided earlier - except, since you are logged in/switched to root, do not use “sudo” in front of the commands.

If you are still unsure, post back the fdisk output here and we’ll probably be able to quickly figure it out for you. If per chance you don’t have the linux boot media any longer, we can probably figure it out from a Windows listing/graphic of the drive(s); you can find that in the Disk Management section of Computer Management.

Right…I managed to do all that…but…

It starts to boot up and then prints:

Failed services in Runlevel 5: SuSEfirewall2_init avgd SuSEfirewall2_setup :frowning:

Skipped services in runlevel 5

and then it starts command prompt linux…

which allows me to log in but obviously doesn’t have a user interface…lol

Any suggestions?

You can start the X server after logging in as your user at that prompt with:


What is happening is that a service - in this case firewall related - is failing to start and so the system drops you to the prompt so you can fix it before starting X. From the error message, it appears there is some sort of conflict between the SuSE firewall and AVG - or perhaps AVG included its own custom firewall startup, like the other AVG init script that you have removed. The back-end of the firewall is “iptables”. It does seem as though there are issues with that AVG software. My suggestion would be to start X and once in the gui work on getting AVG entirely removed. If it came in an .rpm package, you can uninstall that with YaST Software Management or from the command line with the rpm program (as root; do “man rpm” for instructions). If AVG was installed by running a script from the command line, there may be another script that came with it for uninstall, or sometimes there is a switch on the install script (e.g., something link an “-r” parameter) - look for a README or INSTALL file that came with it, or check the AVG website. Another possibility that comes to mind is that at installation you turned on the SuSE firewall and AVG conflicts with that (this is a common problem with Windows, i.e., installing a 3rd-party security product and not disabling Windows own firewall, creating deadlocks). It might be a good idea for the time being at least to turn off the SuSE firewall; there is a YaST module for that in the Security section.