openSUSE 11.0 When k3b verify fails (a workaround HowTo)

I like k3b very much.

However, each time I’ve upgraded in the past, it’s been a lottery whether or not k3b will verify a burned CD or DVD. Sometimes it fails to begin verify, sometimes it completes but fails.

One trick is to try both settings for “do not eject medium after write process”

With openSUSE 11.0, on two machines I’ve tried, k3b verify completes, but fails.

It isn’t dodgy media or a dodgy burner.

Using e.g, one of the openSUSE distro ISO images, md5sum the ISO then burn the CD/DVD. Using “sudo dd if=/devsr0 of=md5sum.iso” to create an ISO of the burned CD/DVD, md5sum the resulting ISO.

On two machines I’ve tried this on, the ISO of the burned CD/DVD gives exactly the same value as the original ISO, even though k3b verify complains.

In other words, k3b verify is broken, k3b burning is OK

For example:

> md5sum openSUSE-11.0-NET-x86_64.iso
65cf4856cf60720edaf9cad6b4bb8cd4 openSUSE-11.0-NET-x86_64.iso
> sudo dd if=/dev/sr0 of=md5sum.iso

152172+0 records in
152172+0 records out
77912064 bytes (78 MB) copied, 26.1319 s, 3.0 MB/s
> md5sum md5sum.iso
65cf4856cf60720edaf9cad6b4bb8cd4 md5sum.iso

For data CD/DVDs, write the ISO image before burning and proceed as above.

So you can still burn CD/DVDs reliably with k3b, it just takes longer to verify.

As I said, I like k3b and I understand that this issue is hard to get right on all machines and all burners all of the time.

PS I’m using the packman version of k3b installed via YaST.

I have given up relying on K3b verify because it appears to be affected by, for example, Beagle continuing to run during the write operation and often gives a false positive. Instead, I simply open the CD in a window and make sure I can open a sample of files.

It depends on how vital your files are but I wasted many hours rewriting CDs which I’m reasonably sure were OK before resorting to this alternative.

So far I’ve had no problems.

^^^ I agree John, if your system is solid and you use good media, verify isn’t essential …

… except when burning an install CD/DVD, it’s better safe than sorry. and then my painful workaround procedure is good insurance.

I just experienced this problem and resolved it by telling k3b not to eject the media after it finishes burning.
Did you already file a bug for this?

I didn’t :o - but see below

I suspect the maintainer is well aware of the problem. The fact that it works for you but not for me, and that what works in one version fails in another, strongly indicates that k3b is having to handle different hardware dependencies. When I last rummaged around on Google about the problem, this seemed to be the case.

In which case, the k3b guy likely doesn’t have lots of hardware to do testing on, which is why I’m sympathetic to the problem and why I suspect it isn’t just a bug that can be fixed easily - it needs extensive testing resources and time to get right.

PS It’s nice to know that toggling the “eject after burning” flag still works for someone.

more on this:
i found on the developer’s page referring to k3b 1.1

K3b News - K3b
In the meantime enjoy this very small bugfix release which fixes three annoyances:

* Fixed CD Copy device selection when starting from the KDE "run" dialog (Bug 151924)
* Fixed HAL mounting (thanks to Ken Milmore)
* Always wait for the drive to become ready before starting verification (this should fix some of the problems with failed verification where K3b claims that no medium is in the drive.)

i think the next version will fix the issue.