openSUSE 11.0 w/desktop effects and Groupwise 7

Anyone able to get Groupwise working correctly on openSUSE 11 with Desktop Effects enabled?

I have not tried this combination yet - will probably do when the final comes out, but I am curious to what issues are you having with it? Visibility of certain items or other?


Screenshot here. Ends up blank, but when Desktop Effects are disabled, it works. But of course, we don’t want to have to disable them. :slight_smile:](

I’ll give this a try on Friday as I have some spare time to test :slight_smile:

Will let you know my results with and without Desktop effects


Just tried openSUSE 11 RC2 and the same issue exits :mad:

It could also be a combination with your video/xorg driver?

Which video card are you using? Have you also tried it on a different system?

Just had a chance to test this and I have the same issue…

I found some nice info in Googles cache that seems to fix the grey screen to normal display ;

If you have compiz fusion active then groupwise starts but displays only a grey screen. To fix it, change the groupwise startup script to (or run this from the console to test);

/opt/novell/groupwise/client/bin/ -jvm=-Dawt.toolkit=sun.awt.motif.MToolkit

Seems to work fine but it’s to soon to tell if this has side effects. This should also fix the issue on openSUSE 10.3 as well as 11.

Seems this changes some used java modules & would be good to know if this fixes it for you to without creating other issues?


Although this worked, it seems to be a temp fix as GW becomes very sluggish - but that might just be Desktop Effects. Clicking between emails is slow, as are the menus. In addition, the QuickViewer pane at the bottom doesn’t stay up after exiting - and seems to have problems atm.

GW has always operated slowly with Desktop Effects on, so not sure if this will get any better. Anyone else have any luck?

I seem to be digging myself into a deeper hole with Groupwise. Now it just doesn’t work - please see the screenshot below…](

Looks like a Java issue, but no idea what do do with it. I end up with part of the GW interface loaded but can’t click or interact anywhere. I’m using Java 1.6 per default install. Tried 1.5 instead but that didn’t change anything.

I haven’t seen that error before, but with the first bit:
Are you maybe having multiple sessions open? Check with the system monitor to see if groupwise-bin is loaded more than once for your account…

No multiple sessions that I could see.

Looks like a similar issue here: HOWTO: Install GroupWise 7 Cross-Platform Client - Ubuntu Forums

Should I try pointing it to Java 1.6 instead of 1.5 or whatever it default points to? Tips on how to do that would be great. :slight_smile:

Are you using actual java, or opensource+icedtea ?

Tried the simlink to Java 1.6 JRE - didn’t work either. I’m going to re-install opensuse 11, leave it as is, then install GW again to see if it happens. I’m wondering if I downloaded an update that further caused issues.

Whatever is default on the DVD - not using 1.7.

Quick update. I reinstalled the OS, installed GW, and it launched correctly - slower than it should be, but it works. I noticed the app wasn’t killing itself correctly after closing. Based on the link above, I noticed “gtk” needed to be installed which I did. That seems to have solved the issue about the app not closing out correctly.

It also works with Compiz Fusion enabled by using the temp launcher code mentioned earlier in the thread. I have not messed with any simlinks to Java 1.6 or anything since something I did last time broke GW.

Please post here if there are any further tweaks to get GW running more smoothly in openSUSE 11.0.

Thanks again for everyone’s input and assistance.

Hi toharris,

I would think your efforts here would help others, so thanks to you as well :slight_smile:

As for speeding up the Groupwise client when using GNOME there was another startup parameter, i think in the lines of ‘-ui=gtk’, but it’s been ages ago when I last used it, will need to look it up.

Good info about your findings though!

Not to shove the gw client aside… but as an alternate option, have you tried using Evolution? You will miss the advanced features like proxy to another mailbox.


I was having the same issue… Found the change at the GroupWise script:

export AWT_TOOLKIT=MToolkit

At My News » Unix Howto » Steven Harms: Novell Groupwise 7 SP3 on Ubuntu Gutsy / Hardy

It seems to solve the problem. My GroupWise client is a little sloppy, specially at windows resizing, but at least it’s showing window content…

this solve works fine for me too :slight_smile:
have tried it on the safe side in console 1st
after that i’ve edited the definitions of the startup @ gwclient.desktop file

[Desktop Entry]
Comment=Novell GroupWise Client
Exec=/opt/novell/groupwise/client/bin/ -jvm=-Dawt.toolkit=sun.awt.motif.MToolkit

I found that the java fix " -jvm=-Dawt.toolkit=sun.awt.motif.MToolkit" worked, the only issue I had is to read emails in the preview window with html viewing enabled. I had to disable html viewing and then everything worked very well.