OpenSuSE 11.0 - Upgrade or Clean Install?

you should have /home on it’s own partition, separate from /, it’s
considered good Linux practice

But the home partition is exactly that - a partition. So, how does this differ from preserving an existing home partition when you do a clean install?

chyrania wrote:

>> you should have /home on it’s own partition, separate from /, it’s
>> considered good Linux practice
> But the home partition is exactly that - a partition. So, how does this
> differ from preserving an existing home partition when you do a clean
> install?
Linux partitions don’t neccesarily equate to physical disk partitons

Linux can have all it’s standard “partitions” such as / /temp /var /opt
etc … on one physical disk partition so that everything was in /dev/sda1
or the linux “partitions” could actually reside in separate physical
partition such as / mounted on /dev/sda1 and /home mounted on /dev/sda2
and /temp mounted on /dev/sda3

Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly

New install is better in most cases, i had some problems upgrading in the past and i find doing a fresh install like cleaning up my bedroom.

This is an “I r dumb” question. Does 10.2 create a home partition by default? I checked fstab and it shows ‘/home’ along with ‘/swap’ and ‘/’. I’m thinking this means I already have a home partition. Is this correct? If so, when YaST makes it’s partition recommendations I should have it overwrite ‘/swap’ and ‘/’ and preserve ‘/home’, correct? Thanks much in advance.

Correct - by default

I would suggest to go with the clean installation, just take the backup of your work.

How to upgrade openSuSE 10.3 to 11.0 version?

Hi, I would suggest that u just download the iso and do a fresh install, it will save u loads of pain rather upgrading.

Clean install, always, IMHO.

I just attempted a 10.3 -> 11.0 upgrade on a plain-vanilla 10.3 install. Just reboots-loops when it hits GRUB.

I like openSUSE, but it’s the worst upgrading Linux distribution I’ve used thus far (compared to say, Fedora). Even between minor 10.x revisions. It almost ALWAYS fumbles the ball on the bootloader. That all being said, I’m primarily a Solaris administrator for a living … so my exposure to Linux is somewhat limited in that nature.

Re-installing from scratch isn’t always a great option for some people.

Here’s what I don’t get…

Everyone who says not to try an upgrade, has never apparently even tried it! How am I supposed to take advice from someone who claims NO experience in the area that they are giving advice for?

I did se ONE person who had actual experience with upgrading. He said it worked with NO PROBLEM.

So even though I do clean installs because it didn’t work in 9.1 or something, I would recommend new users try this:

  1. Back up your partition, so you can restore stuff exactly as you would have if you only did a “clean” install.

  2. Try an upgrade instead, and let us know if you see problems.

  3. If you’re not satisfied with the results, do a clean install.

Wow, why so much FUD, when you have nothing to lose by trying? If you were going to do a fresh install anyway, then you were planning to erase everything anyway, and THAT would be the more risky thing to do, from my experience.

I stand adjusted… yours is a good example of real experience.

Interrestingly, I get a reboot problem on 10.3 except mine only has to boot twice then it works. Thing is, I did a full install (from 10.0). Actually the problem started in 10.0, at least a week before I gave up and installed 10.3.

I think it happened with some yast update but can’t really say because I don’t know how long it was doing this “reboot once” thing since I either left it starting on it’s own or didn’t think about it when I saw the next screen was the grub menu again. Obviously my problem has nothing to do with whether I upgrade or fresh-install.

What you need it probably different boot parameters (wish I knew what).

I am having some major headaches either way…

First I tried a clean install (preserving /home) - and when it went to format / it said it was in use, so it wouldn’t create the file system there…

So, I tried an upgrade; which appeared to have worked (preserving /home for sure). But now I’m getting an error to manually run fsck - which i am not 100% sure how to do without being able to get into a command line.

I did try a repair; and it repaired some file system errors, but upon bootup it did the exact same thing - manually run fsck – after i get past GRUB and it wants to load a ton of the system files.

Can someone PLEASE help me?! I am having lots of problems with this, and am becomming very frustrated - I was highly anticipating version 11; but at this point was wishing i had stayed with 10.3.

Any help is MUCH appreciated!

Maybe your hard drive is failing? I had my test PCs 80GB hard drive fail, and although I nursed it for sometime, in the end it was not worthwhile. I replaced it last night with a 40GB very old back up drive, and tonight I’m going to the local PC shop to pickup a 300GB drive.

But before you do anything drastic with your hard drive, check and compare the md5sums on:
a. the openSUSE web site, with
b. the iso file you downloaded, with
c. the md5sum of the data on your installation cd/dvd

Also, an older (starting to fail) cd/dvd reader will cause the sort of problems you describe.

the checksums check out fine; and I highly doubt its a failing hard drive; the drives i’m using are not even a year old; and have not shown signs of problems before this install - I know linux is excellent for determining bad hard drives (i’ve had it happen in the past). The DVD drive I am using is also about the same age as the hard drives; perhaps a little older.

Would it help to know that I am using a RAID setup? I have 2 arrays; both setup for mirroring - (my controller doesn’t support setting up for mirroring and striping in the same array). This setup has been very good to me in the past year or so that I’ve been using openSUSE 10.3 (I had tried Kubuntu, Ubuntu, and Fedora as well - all of which were okay with this too).

In my opinion the worst thing about upgrades are that you can never be sure. Sometimes there remnants of the old system causing inconsistencies that happen only with one application. So i always opt for a backup and a fresh install - because if it causes a problem it is sometimes hard to identify as an upgrade problem but it works perfectly after an clean install.

One thought I had on getting my issue resolved was formatting / outside of the install… however, I am not sure how to do this at this point.

Actually, I think you will find the opposite is true. Most of us have tried it, and found either a dependency nightmare, or some configuration file left over from the previous version that did not work well. We are just trying to pass on our experience. … But by all means try for your self. It it doesn’t work, then abort and do a clean install.

My view is if one has a stock 10.x install, and has installed no 3rd party packages, and has done no custom compilations, then an upgrade to a 11.0 may indeed work well (ie for KDE-3.5.7 > 3.5.9, or from the old Gnome to the newer Gnome). Otherwise, I don’t think it worth the bother.

By keeping a separate /home partition, one gets the best of both worlds, … ie one gets to keep their hand tuned settings for desktop and stuff, and one gets the benefit of a clean install of all applications (with their newer versions).

So I guess a clean install is always better but it’s a waste of time when you spent lot’s of time configuring you computer (and no, not everything is kept in the /home directories - just your personal preferences).

Here’s my experience of upgrading a 10.3 box to 11 :

-Launched the dvd and choose install-upgrade : some problems were found by Yast so I choose to reboot in 10.3 and remove the problematic packages.
-Launched again the dvd, and started the upgrade : took about an hour and a half (I have an old laptop).
-Rebooted and guess what? The box booted in Windows as I had dual boot on this machine and for some obscure reason, this was chosen as the new default OS. Ironic isn’t it?
-Rebooted choosing OpenSUSE 11 and fixed the boot loading.went on to get the latest updates and after 3 hours of hard work my upgraded system flies.

So yes it’s possible to upgrade and because of Linux architecture, this is safer than upgrading a Windows box.

So if you choose to upgrade, please take a backup before.

So i figured out what i was doing wrong… i was using what the install recognized as the partitions (on the individual disks), rather than using mount points and formatting on the actual RAID array’s… its now installing, so we shall see.