openSuSE 11.0 on iBook G4 does not connect to WLAN


I have a iBook G4 with built-in WLAN and installed openSuSE 11.0 on it. I managed the configuration so far, but it does not connect to my WPA secured WLAN.
lspci says: 0001:10:12.0 Network controller: Broadcom Corporation BCM4305 802.11b/g Wireless LAN Controller (rev 03)
I installed the firmware and everything seems to work fine. I see the SSID and signal strenght in the KDE-networkmanager. I entered the WPA-Key but I can not connect. When I try, the following appears in /var/log/messages:
wlan0: authenticated
wlan0: associate with AP <MAC of AP>
wlan0: RX ReassocResp from <MAC of AP> (capab=0x411 status=0 aid=2)
wlan0: associated
wlan0: RX deauthentication from <MAC of AP> (reason=15)
wlan0: deauthenticated
wlan0: authenticate with AP <MAC of AP>
wlan0: RX authentication from <MAC of AP> (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP <MAC of AP>
wlan0: RX ReassocResp from <MAC of AP> (capab=0x411 status=0 aid=2)
wlan0: associated
wlan0: disassociate(reason=3)

The AP is a Linksys WRT54GL with Tomato-firmware. In the device-List of the AP I can see the MAC of the iBook flashing up while trying to connect, but there ist no IP-Adress reserved.

Has anyone an idea what’s going wrong here?


I do not think you have configured the NetworkManager configuration
correctly. Recheck that YaST thinks that NM is controlling your
network devices and that your connection is accurately described in NM.


Yast is configured to use NetworkManager. The WLAN-Card is “not configured” in yast.
In NetworkManager the SSID is set correctly. Security is set to “WPA Personal” It makes no difference if “Use specific WPA Version” and “Use specific cipher” are set to WPA1 and TKIP or not.
The WPA-Password I entered in “Shared Key” is changed to a long string which seems to represent an hexadecimal number to me.
“Use manual IP configuration” is not set
“Autoconnect” is set.
My WLAN-Settings in Tomato:
Wireless Mode: Access Point
Broadcast: yes
Channel: 1
Security: WPA Personal
Encryption: TKIP / AES
Group Key Renewal: 3600 seconds

Advanced Settings:
Afterburner: Disable
AP Isolation: Disable
Basic Rate: Default
Beacon Interval: 100
CTS Protection Mode: Disable
Distance / ACK Timing: 0 (= use default)
DTIM Interval: 1 (= default)
Fragmentation Threshold: 2346
Maximum Clients: 128
Multicast Rate: Auto
Preamble: Long
RTS Threshold: 2347
Transmit Power: 42 mW
Transmission Rate: Auto
WMN: Disable

The network works fine with MacOS X, Ubuntu and Windows XP Clients.

Has anyone more Ideas?


Doesn’t anyone have an Idea what I could do next to find the error in my configuration?
Especially, is it normal that the WPA-Passphrase is changed in network-manager?


reading your post i see this

The WLAN-Card is “not configured” in yast.

have you tried configuring it ?


That was ist, thank you!
I disabled network-manager and now use the “classic ifup” way to connect to the wlan. And now it works!


Excellent, glad you got it working,now enjoy :slight_smile:


I’d been with suse sice v5. Well I haven’t been since suse is Novell.
Anyway, I installed 11.1 looks for me it is less ergonomic and
has more tiny problems. Network-manager - why Yast was just very clean.

Nevertheless I try to adjust myself to new suse
Would you tel mi plese how to disable this network-manger.
my wlan0 is disconnected all the time and I have problem with navigation in network-manager, maybe the traditional UNIX way will be simpler than network-manager provide?


YaST - network devices - network settings.Click on the Global tab & change to traditional ifup.Also,whilst you are there ensure ipv6 is off