openSUSE 11.0, Netgear WG111T not working

Hello, I’m hoping that someone can help me get my internet connection working for my new installation of openSUSE 11.0 on an AMD Athlon 64 3200+ PC (from openSUSE-11.0-KDE4-LiveCD-x86_64.iso). I have a Netgear WG111T USB dongle installed which I believe is an Atheros device. It works in XP (I dual boot), but there is no sign of life in Linux (no blue light). The device is plugged in & looking at the Hardware Information as saved out to a file gives this section:-
udi = ‘/org/freedesktop/Hal/devices/usb_device_1385_4251_1_0_if0’
info.subsystem = ‘usb’
usb.num_interfaces = 1 (0x1)
usb.can_wake_up = false
linux.subsystem = ‘usb’
usb.linux.device_number = 2 (0x2)
usb.interface.number = 0 (0x0)
info.product = ‘USB Vendor Specific Interface’
usb.vendor = ‘Atheros Communications Inc’
usb.device_class = 255 (0xff)
usb.interface.class = 255 (0xff)
info.udi = ‘/org/freedesktop/Hal/devices/usb_device_1385_4251_1_0_if0’
usb.bus_number = 1 (0x1)
usb.serial = ‘1.0’
usb.interface.subclass = 0 (0x0)
usb.product = ‘USB Vendor Specific Interface’
usb.device_subclass = 0 (0x0)
usb.interface.protocol = 0 (0x0)
usb.linux.sysfs_path = ‘/sys/devices/pci0000:00/0000:00:0b.1/usb1/1-2/1-2:1.0’
usb.speed = 480.000
usb.device_revision_bcd = 1 (0x1)
usb.device_protocol = 0 (0x0)
linux.sysfs_path = ‘/sys/devices/pci0000:00/0000:00:0b.1/usb1/1-2/1-2:1.0’
usb.configuration_value = 1 (0x1)
usb.version = 2.00000
info.parent = ‘/org/freedesktop/Hal/devices/usb_device_1385_4251_1_0’
usb.max_power = 500 (0x1f4)
usb.vendor_id = 4997 (0x1385)
usb.num_configurations = 1 (0x1)
usb.is_self_powered = false
usb.num_ports = 0 (0x0)
usb.product_id = 16977 (0x4251)
linux.hotplug_type = 2 (0x2)
From what I have read, I believe that this device should work using madwifi. I did uname -r & got, so I installed madwifi 0.9.4-1-x86_64 & madwifi-kmp-default 0.9.4_2.6.25.5_2.1-x86_64, both from madwifi. I have rebooted.

Where am I going wrong? Can anyone provide a step-by-step ‘idiots guide’? Thank you in advance for any help you can give. Please remember that I am brand new to Linux & forums, this being my first ever post, so be patient with me!


Hi familytyler – welcome to the forums.

bad luck on this one – madwifi doesn’t support usb dongles.

But I’ve looked on the ndiswarpper site and that supports your device. Looks like you need to use the XP drivers. There are two inf drivers – looks like you need to use both of those too. For a HowTo just Google with keywords: andrewd18 ndiswrapper 10.3

Thank you swerdna. It’s disappointing news about madwifi. I will look at ndiswrapper - I have heard of it. Thank you again.


Did you ever get your WG111T to work? I’ve got the same adapter and I can’t get it to enable… :frowning:


I reinstalled openSUSE yesterday and figured out how to get my WG111T working. Here’s how:

  1. Open up GNOME Terminal or Konsole and type: sudo zypper install kernel-default. This will install a default kernel other than the regular PAE kernel.

  2. Reboot and you should have an extra kernel entry like "openSUSE 11.1 – kernel_version (default). Highlight it and press enter. Login and open up a terminal again.

  3. Type sudo zypper install kernel-source gcc. This will get the necessary tools to build ndiswrapper against your new kernel.

  4. After the installation is complete, get the ndiswrapper tarball from it’s sourceforge website. I recommend getting 1.54 (the latest version) because it works flawlessly while compiling. Extract the tarball to a temporary location.

  5. Open a terminal again and go to the ndiswrapper directory where you extracted the tarball. Type make. This will compile ndiswrapper. After you get dropped back to “username@hostname:-”, type “make install”. This will install ndiswrapper.

  6. Login as root by typing “su -”. Enter your password. Type ndiswrapper. If you get the program’s options list, ndiswrapper has been successfully installed.

  7. Get your wireless card’s drivers from a CD or online. You need the files that end in .inf.

  8. Plug in your wireless card and type: “ndiswrapper -i drivername.inf”. This instals the driver for your wireless card. Check to make sure that it has really been installed by typing: “ndiswrapper -l”. It should show up with something like:

driver netwg11t.inf installed
<device present 123:344>

  1. Type: “ndiswrapper -m”.

  2. Type: “modprobe ndiswrapper”. This should activate your wireless card. You will see it’s light come on (if any). You can now configure your wireless card the normal way with YaST or with NetworkManager.

I share your pain. I did get mine to work, but did have a lot of trouble connecting to a wireless network.
Since I am a total nube, I’m still in the learning phase. I used ndiswrapper downloaded from Suse, and the .inf file from the Windows install CD, but during the driver install using “nsdiswrapper -i netwg11t.inf”, it prompted me for the WG11TND5.sys, ar5523.bin files, so I had to delete the /etc/ndiswrapper/netwg11t directory to get it to reinstall again with ndiswrapper. At that point I could ping localhost, but could not connect. I tried one more time and it magically worked after powering off and restarting. That being said, it does work.


I’m new to these’s forums and I would like to post my findings if it helps anybody

I too been trying to get Netgear WG111T USB V2 working on Fujitsu L7300, I followed the example on this thread and yes got a light on “but not really working”.

Tried Netgear Routers DG834G V3 & DG834GT

Tested loopback OK
Tested interfaces OK

PC side no encryption set
iwconfig & ifconfig
Mac address’s wlan0 & eth0 OK
IP addressing wlan0 & eth0 OK

Router side no encryption set
IP address, wlan0 & eth0 OK
Mac address eth0 OK

Mac address wlan0 same as eth0

It would seems that the ndiswrapper is some how spoofing eth0 mac address into wlan0 frame, this would explain why frames are being dropped and wireless communication fails. MAC addressing is layer 2 issue and I dont think there much chance of sorting this out with the YaST settings unless anybody knows better.

Best Regards