OpenSUSE 11.0 KDE4 Just died out of the blue


I just finished installing OpenSuse 11.0 and everything seemed to be OK.

All of a sudden the desktop got frozen, and the system would not respond to any keys or mouse click. I hit Alt + Ctrl + Backspace and manage to get out of the mess. now KDE4 will not run anymore.

Thankfully I did install KDE3 when doing the installation so I can get into KDE3 desktop.

where should I start troubleshooting this? is there a log for KDE4? I’m not really familiar with KDE4 at all and I don’t know what might have gone wrong.

I have installed nVidia Drivers from Yast, W32Codecs using the one-click install from community site, and I can’t think if anything else at this time.

PS. I am using dual monitors, and it seems like KDE4 is not very multi-monitor friendly. The K-menu and right click menus show up on the second monitor (the one on the left in my case). It doesn’t like dual monitor setting at all. I also think Compbiz effects are enabled in KDE4 since I noticed the windows got transparent as I drag them.

Yes, there are still lots of glitches and bugs.

To get it back working again, from KDE3, try this:
rm -R .kde4
which will blow away your entire config-file dir-tree for KDE4.
[This puts you back as a first-time-user logging-in to the KDE4-desktop.]
Then, logout of KDE3 and login to KDE4.
[You will have to re-customize your desktop again, but that’s
only a few mins work.]

Someone else also mentioned, in another thread, about problems using
dual-monitor…(e.g. missing title-bars on windows on 2nd display, etc)

Clearly, they have alot of work left to do before 4.1 is ready for

Thanks for the reply. I tried deleting the .kde4 folder, now I get this message when I try getting into the KDE4 desktop:

Could not start kdeinit4. Check your installation.

and there is an Okay button, I hit that, xserver restarts and back to the login page. Now at least I see something.

Looks like KDE4 just corrupted itself???
I love trying new things, but I guess it is really too early for KDE4 to be usable if that is as far as they have got with it.

On the other hand is there a way of looking into this to see where the problem is. I’m an OpenSource fan and know bugs and things like this get fixed one at a time aand it takes time to get them all straighten out. If this is a bug it’s big giant one! :smiley:
I’m just an end user (not a programmer, not even good with Linux), but is there anything I can do that can help to get things fixed?

login to ked3
go to your /home/username*
from the top select view hidden files

find .kde4
delete or re-name .kde4old


login kde4 see how you go
it will be like the very first login

Done that already, no dice. I still get this:

Could not start kdeinit4. Check your installation.

kdeinit4 is part of kdelibs4 package.
I guess kdelibs4 was corrupted on your system.
reinstalling kdelibs4 maybe will help.
i personally dont like kde4 now. it’s not stable for everyday use.
i’ll wait for 4.3.

Yep, what wicaksono said. Kde4-libs may not have been corrupted - it could just be that your kde4-libs package is different from kde4-base and co. If you’re updating kde packages, make sure you update them all together, otherwise you’ll run into problems like this. You can do either zypper up -t package or Packages > All Packages > Update if newer version available in yast.