opensuse 11.0 headphones

My current install of suse 11.0 is working wonderfully, and i love this distro, however using headphones had proved to be quite a task.

Not entirely certain how to get information you may be after, but at this point my front side microphone port has very tin sounding output, instead of my headphone output. Weird…

Let me know what info you will need, as im a sound (linux)rotfl! noob

I’m off to catch a plane to go on vacation for 2.5 weeks (leaving in less than an hour). But to help, as you surmised, more information is needed.

To provide more information, with your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget -O && bash 

When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following one line at a time into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Are you using KDE-4.0.4 ? KDE-3.5.9 ? Gnome ?

Since it may be days (or longer) before I can reply, you could also check out the openSUSE audio troubleshooting guide, to see if it helps: SDB:AudioTroubleshooting - openSUSE

Thanks for the fast reply, Have a safe trip!
** Alsa output url**:

rpm -qa | grep alsa

rpm -qa | grep pulse

rpm -q libasound2

uname -a
Linux linux-815l #1 SMP 2008-10-21 16:30:26 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

Im on KDE 4.

Taxi to take me to airport shows up in 15 minutes :slight_smile:

The script tells me your PC hardware has an ALC880 hardware audio codec.

You could try an edit to your /etc/modprobe.d/sound file. For 1.0.16 of alsa, this is the list from the ALSA-Configuration.txt file of the various model options that can be applied, ONE at a time.

	  Model name	Description
	  ----------    -----------
	  3stack	3-jack in back and a headphone out
	  3stack-digout	3-jack in back, a HP out and a SPDIF out
	  5stack	5-jack in back, 2-jack in front
	  5stack-digout	5-jack in back, 2-jack in front, a SPDIF out
	  6stack	6-jack in back, 2-jack in front
	  6stack-digout	6-jack with a SPDIF out
	  w810		3-jack
	  z71v		3-jack (HP shared SPDIF)
	  asus		3-jack (ASUS Mobo)
	  asus-w1v	ASUS W1V
	  asus-dig	ASUS with SPDIF out
	  asus-dig2	ASUS with SPDIF out (using GPIO2)
	  uniwill	3-jack
	  fujitsu	Fujitsu Laptops (Pi1536)
	  F1734		2-jack
	  lg		LG laptop (m1 express dual)
	  lg-lw		LG LW20/LW25 laptop
	  tcl		TCL S700
	  clevo		Clevo laptops (m520G, m665n)
	  test		for testing/debugging purpose, almost all controls can be
			adjusted.  Appearing only when compiled with
	  auto		auto-config reading BIOS (default)

To apply one (for example, lets apply “auto” ), change your /etc/modprobe.d/sound file to:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=auto
save the change, and restart your alsa sound driver with: su -c ‘rcalsasound restart’ enter root password, and restart your mixer, and test your sound.

I think in KDE4 the mixer can be adjusted by having different control options added via a menu selection in the mixer.

If “auto” does not work, try something else, such as “3stack” and restart your alsa as described above, restart your mixer, and test … etc …

Try each model to see if one works.

I could provide other suggestions (ie how to update alsa) but I’m out of time … taxi is here soon.

Good luck !