Opensuse 11.0 hangs....

Hello, I work already for several years with Suse, and now I tried the new 11.0.
After installation and set-up everything seems well, but then the strange things starts to happen:
After starting up for example yast or firefox or just a game, and closing it again, my Suse button (“start-button”) is disappeared, and I have to add it again.
That’s not the worst thing:

My computer is an Intell dual core, I have nvidia geforce 7500 LE card with Opengl, and this card is correct set in the nvidia x-server settings and in sax recognized also with 3d acceleration.
But when I start for example an opengl game like frozen-bubbles, it works for several minutes and then the whole system hangs completely. No ctrl-alt-backspace or ctrl-alt-delete, or even no alt-sysrq-r (or b) is working. The only thing I can do is turn the power off and reboot. In the log-files I can’t find anything logged on the time (or just before the time) the system freeze.

This exactly same problem I encountered with slackware 12.1. I have also slackware 12.0 running without any problems. Slackware 12.1 works with the kernel 2.6.24.5 (Suse 11.0 with 2.6.25.5) and with both kernels I have the same problem: when using opengl, after a while (several minutes till half an hour) the complete system freeze. Only power off is possible.

On suse 10.3 I don’t have any problems, everything is working well, no system hangs or whatever.

Till now I can’t find out what is happening here. When I look to the memory statistics while running, there is more than enough memory (2 gb swap free and app. 1 gb ram free), the video card has 512 Mb memory.
I suspect that there is somehow a memory overflow on the card if that is possible, i have no idea. Maybe someone can help? :confused:

What do you use KDe or GNOME ?
Whas it a clean install or upgrade ?
The CPU mine is Intel dual core too mine works good with 10.3 and 11 ,so it can not be the CPU
RAM 2 GB more than enough
Nvidia drivers for 3D can gives problems, mostly I use it for let say a week before installing the real NVIDIA driver.
Last but not least a install some times seems ok but is not.
So my suggestion go back to generic driver or consider a reinstall

regards
dobby9

Thanks for the reply!

It’s a fresh install and I use kde 4 on suse 11.0;
I tried a reinstall, also checked the checksum from de iso-image.
I also tried older nvidia drivers, with the same result: after minimum 5 minutes till maximum a half hour the system hangs completely… :frowning:

But I’ll take your advice and wait for a while till better drivers are developed or other bugs are solved. :smiley:
I stay by Suse 10.3 for so long, because it works perfect for me, what I can’t say from 11.0.

Not sure if this is the same problem, but I was getting random hangs as well after doing a clean install of 11.0 (had been using factory prior to that without issues). The freezes have disappeared ever since I updated to the version of kde4 in factory. My laptop has an ati card, not nvidia.

It looks like we have the same problem - Xserver dies when some programs are launched - openSUSE Forums

Do you have the same error in the log file?
Launch opengl game, see it dying, and take a look at /var/log/Xorg.99.log

^^
I was never able to capture anything in the log files I checked while I was having the issue. I don’t recall whether I looked in Xorg.99.log, but definitely checked Xorg.0.log and Xorg.1.log.

Your issue seems similar to mine; laptop suddenly starts working much slower, less than a minute later, screen blinks off then comes back on and everything freezes. I was able to move my cursor after the freeze happened, but couldn’t use the keyboard or select anything on the screen.

Check 99.log, as far as i know it is the latest one.

By me is in the log 99 file also nothing special, other log files doesn’t mention anything at all. (I mean the last 5 or 10 minutes before the system freeze completely, there’s nothing logged at all)

I suspect that this has something to do with a memory overflow on the card itself, because it takes a while before the system freeze. (just before the freeze, there’s still more than 1 gb ram and 2 gb swap free, but I can’t check the memory usage of the card itself. Maybe buffers or caches are not cleared on the card, I don’t know, it’s just a guess. :confused:

As I said before: I stay by 10.3, this works perfect. Maybe 11.1 will be better :smiley:
( and, beside this, I don’t like the new kde 4. With kde 3, I have much more possibilities for arranging my desktop etc… and I don’t like the lay-out of kde 4 - but that’s a matter of taste :wink: )

By the way, i tried the last nvidia driver, and still the same problem:
Suse hangs after 5 - 10 minutes…

Still no solution…

Same Problem.
After starting KDE-Session (3.5.9) with a “regular user” the system hangs completely, no debug informatio in /var/log/messages or /var/log Xorg.0.log

Starting KDE-Session with user “root” … no problems
Starting no KDE-Session, working with F1-console … no problems
Deleting ~/.kde directory of “regular user” and then starting KDE-Session with “regular user” … no problems.
Reboot Laptop, starting KDE-Session with “regular user” again … system hangs

grrrrrrr…

Struggling with this issue myself right now. Somethings that seemed to help me and I will continue to test this way.

Disable and uninstalled Kerry Beagle. I also noticed that whenever it would freeze I had Firefox open. I am using Konqueror right now to type this and have been working peacefully now for 15 minutes. It might not be Firefox but Beagle and Firefox working together. My system is as follows.

AMD Athlon 64 X2
NVIDIA 8600 GT
OpenSuSE 11.0 x86 (64 bit had other problems like loosing my dvd drives)
2 Gigs RAM equal SWAP
KDE 3 and 4 as well as gnome

Still working without a freeze after a little while. After downloading my favorite game (Savage 2) using Konqueror I will go back and see if firefox will freeze the system for me again and let you all know.

I tried OpenSuSE 11.0 now with kde 3, and -as I expected- again total system freeze.

More details: Intel dual core (64 bits) with Nvidia gforce 7600 card.

I tried several Nvidia drivers, from the newest till older ones, all with the same result: after 5 till max. 30 minutes total system freeze. No keyboard, mouse reacts, whatever I try.
When I start a game like frozen-bubbles, after app. 10 minutes the system will freeze. In the log-files there is nothing written in the last minutes before the freeze. :mad:
Is there a solution, or do I have to wait till Suse 11.1 ? :confused:

i’ve just read thought this whole thread for the first time, and suggest
to henkees:

  • disable (some folks say put in the dog pound, or KILL) beagle…it is
    a system killer…

  • if you are using reiser file system: there is a KNOWN problem with it
    in SuSE 11 (find that in the readme or release notes, if i remember
    correctly…or, it is talked about in these fora, somewhere…)

if, you keep having system freezes after getting BOTH of those out of
your system at the same time, then post again…

oh, and are you running 64 or 32 bit? i ask because (imo) the 32 is more
stable…and, just as fast unless you use some REALLY big files and
have about 4 GB of memory or more…

hmmmmm…you mentioned that sometimes the hang comes while using
firefox…is that Firefox 2.x or 3?

btw, good luck…come back…have fun…keep smiling
!


DenverD (Linux Counter 282315)
A Texan in Denmark

Ah…when you say ‘(64 bits)’, you mean you are running the 64-bit version
of openSUSE? If so, for your next test, I’d recommend that you
try the 32-bit edition.

[IMHO, 64-bit OS is an ‘advanced’ exercise…any time there are serious
problems, fallback and see if same problem exists on 32-bit.]

Also, if your freeze/hang symptom seems to track the running of ‘openGL’ stuff, then odds
are about 100:1 that the graphics-driver is to blame. So, try switching to the
‘vesa’ driver and see if the freeze/hang symptom disappears.

Lastly, if you’ve never tried any other Linux-distro than SUSE, consider a quick test with
Kubuntu (if your a KDE-person) or Ubuntu (if Gnome), and see if problem persists.
*

My 2-cents…
Dave*

I also have a problem with Suse 11.0 hanging, but with one difference – it doesn’t hang when I run as root. I tried safe mode which was no better, and disabling Beagle search which did gain me some extra time but still hangs within about ten minutes.
Panasonic Toughbook CF30, Intel core duo @ 1.66 GHz, 1Gb ram, Intel mobileG945 integrated graphics, Suse 11.0 - 32 bit, KDE 3.5, ext3 filesystem (21% used), home partition also ext3, 2% used.

Thanks for your replies.

DenverD, I did already “kill” beagle and I use ext3 file system, but thanks anyway.

Cookdav, I use indeed 64 bits Suse, with the Nvidia driver. The vesa driver works indeed without any problem, but the graphics & colors are much better with the nvidia driver. I don’t want to go “back” when it is working on 10.3.

With Suse 10.3 (what I still use, also 64 bit) I don’t have these problems. The nvidia driver is working well, also with 3D. No freeze at all.

I work also with Slack 12.0 (slack is 32 bit), with nvidia driver; no freezing.
—> BUT: I tried slack 12.1 (with kernel 2.6.24.5) and there I have exactly the same problem as with Suse 11.0 (kernel 2.6.25.5).
(Slack 12.0 is using kernel 2.6.21.5)

  • The drivers for the nvidia card (7600), are working well with kernels 2.6.21 AND 2.6.22, no matter if I run 32 bits (Slack) or 64 bits (Suse).

  • The drivers are causing freezes with kernel 2.6.24 AND 2.6.25; no matter if I run 32 bits Slack 12.1 or 64 bits Suse.
    So the drivers doesn’t work so well with the newer kernels, I can say…
    I think I can only wait and hope for a better driver. :frowning:

I posted this problem on the Nvidia forum with all the details.
(because I have the same problem with Suse and Slack, I think this goes deeper…)

When I find out more, I will tell!

Problem solved, my home partition had been preserved from a previous install of 10.3 and was reiser not ext3. A full re-install fixed the problem

This happened to me when I installed the 32 bit system and not the 64 bit system. As soon as I went back to the 64 bit system freezing stopped. Might have something to do with running a 32 bit system on a 64 bit processor. I have an Athlon X2 64.

I also have had the hanging issue - and whereas I thought it to be video driver, I suspect reiserfs. Here is my setup:

ThinkPad T60p, Intel Centrino Duo, 3GB RAM
ATI video, proprietarty driver from the ATI repo
openSUSE 11, x86_64
/ ext3
/home reiserfs

Running compiz fusion, using Xgl (vs AIGLX)

Primarily GNOME, but KDE4 updated to factory as well.

Has been hanging for me unpredictably - but consistently if I log out, then log in.

Like others on the list, 10.3 works perfectly with this hardware and similar software and interface setup.

:frowning: