opensuse 11.0 don't finalyze boot


I am new to OpenSuse, and after installing the system, I cannot finalyze the boot.

Grub works fine. It shows all options (OpenSuse, Failsafe, Windows XP,…)

If I select opensuse, it starts to bring the system’s up.

When I have half of the load bar filled (which means middle os the initialisation), the system is automatically rebooted…

And this happens over and over…

My machine:
Laptop, 720 Mb Ram, 32 Mb shared video, DVD rewirter, I also use a Acer 22’ screen attched to the laptop.

Any advise in how to solve this?

Before I installed I also check the integrity of the DVD, which is ok…



And, what happens if you boot ‘failsafe’ instead?

I have pretty much the same problem.

Fresh “net” install with no errors, but spontaneous reboot, over and over.

No change when choosing “failsafe”.

To isolate X as a cause I changed initdefault to 3 (with annother Linux distro).

Now the system freezes at various points during the init scripts.

Used “nofb” at the grub command line, still hanging during boot.

So, it’s most likely not the X system and not the framebuffer …


failsafe doesn’t solve the problem…

I reinstalled the system 2 and problem still exists…

Thanks, Marcos…

Oh, and it’s a Pentium M in a Desktop. The first post was about a laptop. Maybe an issue with power/frequency control?

my laptop has intel celeron, 1,4 Ghz…

What do you mean by power/frequency control?

How can I check/change that?

That is some mechanism to control the powersave features of the CPU. It’s just a wild guess because there is a thing our machines have in common. I suppose you have a Celeron M, right?

Boot up the standalone memory test and check that.

I’ll do that at once I’m at that machine (around 1700 UTC).

Read some bug reports regarding hangs and might try annother kernel in addition. I could install stuff via chroot.


how should I do that???

Boot up the LiveCD/installDVD and you’ll see it there in the list
of bootables.

I have solved my problem.

I was able to use an Ubuntu kernel with the openSUSE installation. Some warnings and errors (of course) but no hang or reboot.

Then I disabled all possible services and was able to boot with the original openSUSE kernel.

After that I started the services manually, one after annother. And sure enough, one of them actually froze the system. It was … (bummer) … “microcode.ctl”!

Since disabling this service in all runlevels I had no more trouble.

If you want to try this, start the rescue system, mount your main install partition on - say - “/mnt”; then do a
“rm /mnt/etc/rc.d/rc.5/microcode

Don’t worry, you are just deleting symbolic links, not the script itself.

All in all, this seems to be a (Intel-) processor-specific, SUSE-kernel-specific problem. Anyone else using mobile CPUs from Intel here (Pentium/Celeron M)? Should I post a bug if my solution works for marcoshac?


I amvery new to Linux and OpenSusue…

would be glad if you could send me a link or tell me how do I do those things.

I tried the memory check, which is ok…

I am not sure hwat else shoudl I do…

Since not being able to boot OpenSuse, i think I am not able to change the kernell, right??

Any help appreciated…


No, you don’t have to change the kernel. If your problems have the same cause as mine, it is only necessary to remove the files that I talked about. And if not, this will not make the problems worse.

So, first you need to boot from your install CD/DVD and start the “rescue” system (this runs usually from the CD/DVD and from memory). You should end up on a command line prompt. When I give commands starting with “#” don’t type it, it’s the usual character to show the beginning of the command line.

Then you have to mount your main disk partition (the one used as “root” or top of your installed Linux system) if that is not done automatically.

If you let the installer set up the partitions this is most likely /dev/hda1 or /dev/sda1. Try this first in case you mount manually:

mount /dev/hda1 -t ext3 /mnt

Try the other partition if there are errors. If you don’t get any, and "# ls /mnt " shows you several directories like “sys” and “etc”, you are set.

Now enter "# cd / " to make sure you are on the top level. Then enter the line I posted before. Here it is again:

rm /mnt/etc/rc.d/rc.5/microcode

You may be asked to confirm the deletes. Afterwards, just reboot without the CD/DVD and see if there is any change.