openSUSE 11.0 does not detect my DVD drives

openSUSE appears not to recognize my 2 DVD recorder drives, I have one Samsung and one Nec but they are not discovered even though previous versions of Suse and other distributions never had problems with it.

If I put in a disk, but nothing happens… there is no pop-up and no mount point in /media.

Explanation for this strange behavior?

Maybe a stupid remark when I put a audio CD nothing happens too ,until I use kaffeine than it play the cd
But not just like in the past that start automatic


Nope, Kaffeine does not detect any audio CD’s… K3B also does not detect and CD/DVD drives.

Here is output of lsmod, lspci and /etc/fstab:


linux-mn4t:/home # lsmod
Module                  Size  Used by
ip6t_LOG               11140  7
xt_tcpudp               7296  2
xt_pkttype              6016  3
ipt_LOG                10500  8
xt_limit                6788  15
af_packet              26368  2
ip6t_REJECT             9088  3
nf_conntrack_ipv6      20984  4
ipt_REJECT              8064  3
xt_state                6656  8
iptable_mangle          7424  0
iptable_nat            11400  0
nf_nat                 23448  1 iptable_nat
iptable_filter          7552  1
ip6table_mangle         7296  0
nf_conntrack_netbios_ns     6912  0
nf_conntrack_ipv4      15364  7 iptable_nat,nf_nat
nf_conntrack           66900  6 nf_conntrack_ipv6,xt_state,iptable_nat,nf_nat,nf_conntrack_netbios_ns,nf_conntrack_ipv4
ip_tables              17936  3 iptable_mangle,iptable_nat,iptable_filter
ip6table_filter         7424  1
ip6_tables             19088  3 ip6t_LOG,ip6table_mangle,ip6table_filter
x_tables               21380  11 ip6t_LOG,xt_tcpudp,xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,ipt_REJECT,xt_state,iptable_nat,ip_tables,ip6_tables
ipv6                  269160  13 ip6t_REJECT,nf_conntrack_ipv6,ip6table_mangle
snd_pcm_oss            51968  0
snd_mixer_oss          21120  1 snd_pcm_oss
snd_seq                61376  0
snd_seq_device         12812  1 snd_seq
binfmt_misc            15752  1
microcode              15888  0
firmware_class         13696  1 microcode
cpufreq_conservative    12168  0
cpufreq_userspace       8452  0
cpufreq_powersave       5888  0
acpi_cpufreq           13324  1
speedstep_lib           9220  0
fuse                   54044  3
loop                   23044  0
dm_mod                 66388  0
ide_pci_generic         8196  0 [permanent]
ide_core              118560  1 ide_pci_generic
pata_acpi              11264  0
pata_marvell           10880  0
ata_generic            12036  0
rtc_cmos               14752  0
iTCO_wdt               16164  0
nvidia               7134532  34
ohci1394               35760  0
i2c_i801               13840  0
ieee1394               94728  1 ohci1394
iTCO_vendor_support     7940  1 iTCO_wdt
rtc_core               24860  1 rtc_cmos
rtc_lib                 7040  1 rtc_core
r8169                  35332  0
i2c_core               28820  2 nvidia,i2c_i801
ahci                   33544  0
intel_agp              31036  0
snd_hda_intel         374172  5
snd_pcm                87812  2 snd_pcm_oss,snd_hda_intel
snd_timer              28424  2 snd_seq,snd_pcm
snd_page_alloc         14984  2 snd_hda_intel,snd_pcm
snd_hwdep              14084  1 snd_hda_intel
snd                    67256  18 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
button                 13072  0
soundcore              11976  1 snd
agpgart                38580  2 nvidia,intel_agp
sg                     39732  0
sd_mod                 32920  5
ehci_hcd               39436  0
uhci_hcd               28432  0
usbcore               152012  3 ehci_hcd,uhci_hcd
edd                    14152  0
ata_piix               26116  4
libata                163804  5 pata_acpi,pata_marvell,ata_generic,ahci,ata_piix
scsi_mod              156020  3 sg,sd_mod,libata
dock                   15248  1 libata
ext3                  143496  2
mbcache                13060  1 ext3
jbd                    61088  1 ext3
fan                    10372  0
thermal                27164  0
processor              53552  2 acpi_cpufreq,thermal
linux-mn4t:/home #


linux-mn4t:/home # lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)
03:00.0 IDE interface: Marvell Technology Group Ltd. 88SE6121 SATA II Controller (rev b1)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
05:02.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev c0)

  1. FSTAB

/dev/disk/by-id/scsi-SATA_SAMSUNG_HD321KJS0MQJ1KP607687-part5 swap                 swap       defaults              0 0
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD321KJS0MQJ1KP607687-part6 /                    ext3       acl,user_xattr        1 1
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD321KJS0MQJ1KP607687-part7 /home                ext3       acl,user_xattr        1 2
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD321KJS0MQJ1KP607687-part1 /windows/C           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

So is there anything else I can do to try and fix this? Has anyone got a clue what the problem might be?

i do hope someone can help you, unfortunately i can’t…


Is this happening on kde 4?

Is this happening on kde 4?

Yup it is.

One additional note: I messed around with some BIOS settings to try and get this right. Seems like the 2 DVD writer drives are not actually detected in the BIOS… instead they seem to be controlled by something else… some kind of weird/special configuration? (For example I can boot from the drives but there is not actual option to pick one of the drives except one option ‘Boot from other’). I could pick IDE, SATA or AHCI options here). Might have something to do with it, might not (since OpenSUSE 10.3 width kde 3.5.7 worked fine). Although; I have XFCE installed on 11.0 and there as well, no DVD drives come up.

This seems promising though:
CD/DVD drives not detected - Ubuntu Forums

I might try the suggestion to boot with “generic.all_generic_ide” this evening… and keep my fingers crossed :-x

Seems near my issuse with the suse 11.0 rc1
When I load a cd it doesn’t mount
I don’t know exactly what the real solution because what I did was I run the system-settings and in advance, when I opened audiocd it was pointing to /dev/cdrom but with dragon player it is pointing to /dev/sr0 I change it to /dev/sr0 and dragon player works. I changed amarok also to point to /dev/sr0 and it played the audio cd. For my dvd it is /dev/sr1. Also in yast user & group management (can’t exactly recall if thats the right name) I added audio
and video to my user “conram”


except in my case it seems it does not detect it at all. I searched for mount points on /dev/ but found nothing of interest.

Yep same here when that issue happened. There was no mount point also.
You mentioned also that even your xfce can’t detect your dvd. Have you installed the thunar-volfman packages. I think you need it in xfce4.
Here is a good howto for xfce you might be able to pull it through from that side.
Using Removable Media

I tried everything I found… (grub boot parameters, changing Bios settings, using XFCE instead of KDE), but
to no avail. Frustrating thing is, WinXP detects them and so did 10.3…

Same obnoxious problem. I had posted earlier at

CD/DVD Media not Automouting - openSUSE Forums

It appears that your setup is nearly identical, sata harddrive, ide dvd’s and the dvd’s stop working after awhile. Doesn’t matter what desktop environment I am in. The most frustrating thing is it works with Windows. It would be nice if someone knew how to fix it or if developers could fix it at a deeper level.

> It would be nice if someone knew how to fix it or if
> developers could fix it at a deeper level.

is there already, or have either of you filed a bug report?


As for filing the bug report. I would love to but something is wrong with my account in bugzilla. For some reason when I tried to update my email address from hotmail to gmail it got stuck and now I can’t log in. No verification came to my gmail so it tells me it is unregistered. That is a different subject.

jonrwads wrote:
> it got stuck

as far as i know, bugzilla accounts are not limited to one per breathing
user…that is, you may open a new account (from your gmail address) and
just let the other one stay stuck…

or, you can contact a bugzilla guru and see if you can get the old
account un-stuck…

I have solved mine. I posted the solution on the thread I started here:

CD/DVD Media not Automouting - openSUSE Forums

Quickly, it was install 32 bit OS rather than 64.

Okay, progress!

I found a solution on the Fedoraforums (installed F9 to test if it had the same problem; which it had).

In Fedora 9, I had to use:

mkinitrd -v --preload pata_marvell initrd-2.6.25-14.fc9.i686.img 2.6.25-14.fc9.i686

Can I use the same (similar) command in OpenSUSE 11.0? And how can I make OpenSUSE ‘permanently’ apply that rule?