OpenSuse 11.0 Destroyed my Boot Sector

OK, I have all weekend. I’ll take out the card, I assume that it’ll boot up in KDE. Then, how do I go about “fix[ing] the bootloader and fix[ing] the kernel-source bug.”?

The last time I was impatient and I tried just random things (from my hunting through the forums), I wound up having to reinstall XP and reinstalling OpenSuse. So, I think I’ll be patient this time and await the CORRECT way from you. Thanks.

All this is kind of a mess. There should be no need to take out the graphics card. There is no given solution exactly as your issue is individual to you.

You could try this:
Yast - Software Management
Turn off the auto dependency check (Top menu - Dependencies)
Filter by Repository and select Nvidia repo and from the top menu ‘Packages’ choose all in this list ‘Delete’

Now change the filter to ‘Search’ and look for: kernel
Check to delete any/all kernel entries except kernel-default, kernel-base, kernel-extra, kernel-source.
Accept
When done, do not reboot. But go back to the nvidia repo in Yast and check to install the nvidia driver
accept

when done reboot

OK, I’m going to try this right now… thanks.

oops
I should have said turn the dependency check back on after making the deletions in nvidia and checking the kernel. Then accept. It should check all ok

Now you tell me! Well, when I did what you suggested, there were so many dependencies that needed to be resolved I decided to pull out the video card and try that. I set up Sax2, then Xterm, and I’m inside OpenSuse 11.0. Wahoo! As I write this, the Updater is working on updating the system, then I’ll use Yast to update the Kernel and see what happens. However, I’m not convinced that I’ll get the video card to work when I get it in unless I get a lot of help from everyone.

Thanks again.

Thing is, the graphics card should just work. But at least you are getting somewhere.?
And of course the graphics card has nothing to do with the bootloader you lost. From your initial post it sounds like you installed suse but never actually re-booted Proper. (The installer re-boots but not to the bootloader) then it finishes with settings and you are in. IF you had then re-booted I suspect it might not have worked. But if you altered any settings in the bootloader or grub this too may be the cause.

All we need to help you setup the bootloader properly is a terminal output: As su do:

fdisk -l

and

the contents of:

/boot/grub/menu.lst

/etc/fstab
(this may be useful)

OK, here’s the fdisk -l:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x9ce89ce8

Device Boot Start End Blocks Id System
/dev/sda1 1 25067 201342645 c W95 FAT32 (LBA)
/dev/sda2 59948 60801 6859755 f W95 Ext’d (LBA)
/dev/sda3 * 25067 27678 20972826+ 83 Linux
/dev/sda4 27678 59947 259208774+ 83 Linux
/dev/sda5 59948 60209 2104483+ 82 Linux swap / Solaris

Partition table entries are not in disk order

/boot/grub/menu.lst is a blank file as far as I can see. I opened it in Kate and KWrite - both showed an empty file. There was a backup file also - which also was a blank file.

Here is /etc/fstab:

/dev/disk/by-id/scsi-SATA_ST3500630AS_6QG13FF5-part5 swap swap defaults 0 0
/dev/disk/by-id/scsi-SATA_ST3500630AS_6QG13FF5-part3 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_ST3500630AS_6QG13FF5-part4 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_ST3500630AS_6QG13FF5-part1 /windows/C vfat users,gid=users,umask=0002,utf8=true 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0

Thanks, hope you can help.

And, one more thing just surfaced. This project is just a “barrel of monkeys”. Now I’m getting this error message on the OpenSuse Updater : “Backend plugin is not properly configured. Please use the configuration dialog to choose the correct one.” So, I found this thread, followed the advice, still get the same problem. "Re: OpenSUSE-Updater backend?

  1. Open YaST and walk through the “Online Update Config” module.
  2. Re-install zypper and PackageKit
  3. Restart zypper and update applet

What is the name of the “backend” I need to install?

Thanks.

So don’t you get a grub at at the moment? Earlier you said you were updating the system?

Just check again from a su terminal do

kwrite /boot/grub/menu.lst

Here it is…

Modified by YaST2. Last modification on Fri Apr 10 17:34:16 EDT 2009

default 2
timeout 8
gfxmenu (hd0,2)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.0 - 2.6.25.20-0.1
root (hd0,2)
kernel /boot/vmlinuz-2.6.25.20-0.1-pae root=/dev/disk/by-id/scsi-SATA_ST3500630AS_6QG13FF5-part3 resume=/dev/sda5 splash=silent showopts
initrd /boot/initrd-2.6.25.20-0.1-pae

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.0 - 2.6.25.20-0.1
root (hd0,2)
kernel /boot/vmlinuz-2.6.25.20-0.1-pae root=/dev/disk/by-id/scsi-SATA_ST3500630AS_6QG13FF5-part3 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe
initrd /boot/initrd-2.6.25.20-0.1-pae

###Don’t change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,2)
chainloader (hd0,0)+1

###Don’t change this comment - YaST2 identifier: Original name: floppy###
title Floppy
rootnoverify (hd0,2)
chainloader (fd0)+1

I’ve been watching since caf4926 took over.

All I want to say at this stage is: don’t forget that the original problem of the package “kernel-source” breaking the “kpm” RPMs needs to be solved to allow installing the drivers for Nvidia. So if you delete the RPM “kernel-source”, you can install Nvidia.

Now I don’t know for sure that the “kernel-source” bug is responsible for the Nvidia+kpm problem, but google says it’s highly likely, so it’s worth keeping this in mind, and perhaps trying it out.

Let’s see if we can make sense of this:
The bootable flag (*) is on the SUSE root, which is correct.
But there is no eg: (vga=0x367) in the default boot line, I’ll put it in to show you. But vga= numbers vary according to your hardware, another possibly more likely example might be vga=0x31a

Device Boot Start End Blocks Id System
/dev/sda1 1 25067 201342645 c W95 FAT32 (LBA)
/dev/sda2 59948 60801 6859755 f W95 Ext’d (LBA)
/dev/sda3 * 25067 27678 20972826+ 83 Linux
/dev/sda4 27678 59947 259208774+ 83 Linux
/dev/sda5 59948 60209 2104483+ 82 Linux swap / Solaris

Modified by YaST2. Last modification on Fri Apr 10 17:34:16 EDT 2009

default 2
timeout 8
gfxmenu (hd0,2)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.0 - 2.6.25.20-0.1
root (hd0,2)
kernel /boot/vmlinuz-2.6.25.20-0.1-pae root=/dev/disk/by-id/scsi-SATA_ST3500630AS_6QG13FF5-part3 resume=/dev/sda5 splash=silent showopts vga=0x31a
initrd /boot/initrd-2.6.25.20-0.1-pae

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.0 - 2.6.25.20-0.1
root (hd0,2)
kernel /boot/vmlinuz-2.6.25.20-0.1-pae root=/dev/disk/by-id/scsi-SATA_ST3500630AS_6QG13FF5-part3 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe
initrd /boot/initrd-2.6.25.20-0.1-pae

###Don’t change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,0)
chainloader (hd0,0)+1

###Don’t change this comment - YaST2 identifier: Original name: floppy###
title Floppy
rootnoverify (hd0,2)
chainloader (fd0)+1
I am fairly certain the adjustment to your windows boot menu is correct. @swerdna please feel free to correct me.

The install of Grub would in my opinion be best done to the MBR, look at the following sequence of shots:

This is the opening screen of the bootloader
http://files.myopera.com/carl4926/albums/671478/17.png

We need the tab, Bootloader Installation:
http://files.myopera.com/carl4926/albums/671478/19.png
Notice here it is set to MBR

If you get all that correct you should be set. This assumes the windows boot code is undamaged - but we’ll see.

This business with the video card?
Assuming you have the latest kernel (default) from Updates
Delete all packages in the Nvidia repo
Now go back there and just check the x11-video-nvidiaG02-180…
It should automatically bring in the nvidia-gfxG02-kmp-default-180…
That’s it.

I’m not aware of this kernel-source issue, but I’m sure you need kernel-source and it must be updated too, to match the kernel.

Good luck.
John. Please add to this if necessary.

Regarding the video Carl: If it works as you say, that’s great. If not, OP should re-read posts 15 re the bug, 20 re the diagnostic “rpm -qa | grep kernel” and 31 re what to do about it.

Regarding the bootloader: Once again, if it works, great, if not, then I’ll have some thoughts.

At the moment, the #1 issue I need to address is the boot loader issue, as I can boot into XP only by using a boot CDRom which works, but I think its probably playing with fire.

Under Yast2, Boot loader settings, my boot loader is GRUB, and Boot Loader Location is “Boot from Master Boot Record”.

From what I gather, this is the correct sequence.

I can live with using the default video settings for now, using a standard VGA, but I am really concerned about losing my Windows partition. I know, I know, there’s nothing to worry about, but last time I dabbled with OpenSuse 10.2 I lost it and had to recreate it. This computer I use in the office and I am much more sensitive to this – I need to bring it back in tomorrow and work at 9:00 a.m.

So, it appears that XP is working fine, but will only boot from the CD. I have bios set up to boot first from CD so that’s working. If I set it to boot from the HD, I get the Suse boot menu, but if I click on Windows, it just goes in a loop and doesn’t boot to XP.

Thanks
Alan
:frowning:

The XP bootloader in Yast2 is as follows:

blockoffset=1,chainloader=/dev/sda1,noverifyroot=true,root=

@ostrowlaw
I gave some advice here:
OpenSuse 11.0 Destroyed my Boot Sector - Page 4 - openSUSE Forums

But you have not offered any comments regarding if you followed any of it?

Edit the menu.lst as suggested and try windows.
Earlier you just say when you boot windows it goes in a loop. What does that mean because usually there is some kind of error report.

It’s always possible the windows boot sector needs to be restored. But lets try editing the menu.lst in suse first.

Don’t mean to diverge from the other posters, but since you mentioned about bootloader:

What helped in my case (after first install of openSUSE 11.0, I could boot into Windows XP, but not into openSUSE) was SuperGrubDisk - http://www.supergrubdisk.org/. This can repair the Windows bootloader as well as fix GRUB. If you do decide to use it after going through the website, then be sure to read the wiki (Boot Problems - Super Grub Disk Wiki) for your specific situation.

Well, I put the card back in the machine when I brought it back into the office and its more fun fun fun. Yes, obviously the problem is with the Nvidia card. As soon as I put it back in I lost the GUI.

I tried adding vga= [configurations] in the boot loader, using both numbers you suggested – that did not work. So, I guess I need to remove this video card, get everything else working, then try putting it in later. I at least got the GUI working when I removed it.

By the way, when I put it back in, I was able to load the nvidia drivers, through Yast, without all the fuss, but they didn’t work anyway. Yast installed a new kernel, lots of stuff happened, but the result was the same.

Tomorrow is a heavy work day so I don’t have much time to experiment.

Thanks for your help.

Well, I’ve been busy trying all kinds of things. I finally got frustrated and decided to remove the Linux partition, reinstall my original mbr, then, when WinXP was OK, I would reinstall Linux using the standard VESA. In the interim, I had tried using a Win98SE disk (fdisk /mbr), the Windows XP disk console (fixmbr), and Yast (restore MBR). All for naught. Nothing worked, I still needed to boot from a boot disk (ATW_Windows_XP_SP2_Boot_CD.ISO).

So, last night, I took the step of wiping out the Linux partitions (boo, took lots of time to get where I had wanted it), and then tried to restore the MBR. Still nothing, still need to boot from the boot CD.

Its more interesting. My original setup was an old IDE drive which I had on the IDE cable, which I used to backup the main drive, and the main C: drive (which also ultimately had my Linux partition) was a SATA Drive. The SATA drive was set up as a Master, but came in as #2 (the IDE was #0 slave, the CD/DVD was #1 slave, the SATA was #2 master). When I reinstalled the IDE drive, it would no longer be recognized.

I think that somewhere along the way, Yast reinstalled the original MBR on the old IDE drive, just a guess.

All I want to do is get my SATA drive to, once again, boot up as the master with WinXP so I can then retry to install Linux (I guess I’ll try 11.1 now!). I’ll then start again, perhaps diddling with the Nvidia drivers…

Thanks.
>:(

The sata will always be master, there are no jumper settings on them. It’s boot order is defined in BIOS.
The IDE/PATA cable drive should be set to master too. I have the same scenario in my box.