Opensuse 11.0, 11.1 won't recognize my hard drive

I tried (unsuccessfully) to install Opensuse 11.0 and 11.1 on my pc. I have Asus 8V-X mobo with 1.25 GB of ram and Maxtor SATA hard drive. I can boot up the CD and it will go through the installation process till it gets to partition the hard drive it says that no hard drive is detected. I ran the media check on both cd’s and that turned out fine. I tried the using a boot option that works with ubuntu and it derivatives all_generic_ide floppy= off irqpoll but it doesn’t recognize the hard drive. I would really like to install Opensuse. Are there any other workarounds available?

I’ll break the ice. How are you tryig to install it?? As the Main System or a Dual Boot or through a Virtual machine?? IF you are trying to install openSuSE via VMware you have to change from LSIlogic drives to Buslogic drives. The “hack” for LSI is gone and exactly what you are complaining about happens. You can read about my experiences at:
SuSE 11.0 - 11.1
Take care and have fun,

I’m trying to install as a main system

Have a look at
it’s about problems with SATA HDDs.

First, try typing this in the Boot Options below on the DVD menu:


Your board (which, btw, is either a K8V-X or A8V-X) uses a via chipset, which is known to have a problem with MSI (Message Signal Interrupts) which could be getting in the way.

If that does not work, then the next thing to do is to make sure the via sata driver is being loaded. Do this in the Boot Options:


Failing that, reply back with which of the above two Asus mobo’s you actually have, since they use a different chipset Southbridge. The K version is a Socket AM2 and the A version is a Socket 939.

By the way, I wrote the posts linked above. The above is basically doing for you what I wrote there, so don’t bother with that for now.

It’s the a8V-x socket 939. Thanks i will try them out.

Mingus thank you for help. pci=nomsi worked i can install it now. thanks again

Glad to have been of help :slight_smile: