OpenSuse 10.3 - vanished network icon (bottom right)

I just installed openSUSE 10.3. Unfortunately after updates and reboot the system and disappeared from the taskbar network icon.

Does anyone know how can I restore? Thanks.

Am assuming you really mean the tray icon for Knetworkmanager.

If so,
Run… Knetworkmanager to manually start the applet.
Click on the applet
Select “Manage Connections” to launch the KDE Control Module populated with “Configure”
From the KDE Control Module’s left column click on the “Other” icon
Click the box for “Show tray icon”


Thanks Tony, but I use Gnome! :slight_smile:

Yes, he should have asked first maybe, but should should have told earlier imho.

And 10.3 is not supported anymore (you realy had to look thouroughly to find the repos you say you found for updating), thus you will not find many people having it, with what version of KDE? Now nevertheless people will try to help you, but as you say you just installed, the question is of course: why did you not install 11.3?


My bad, jumping to conclusions.

Still, although I don’t use Gnome from what I understand Gnome probably uses a different version of the same network manager so your solution might be similar.

Can you launch Gnome’s network manager manually, eg in KDE you can launch specifying only “networkmanager”

From there, if the tray icon appears you can investigate further where you can configure for autoload.

Yes, I also agree with hcvv about upgrading but keep in mind we’re only about a month away from the 11.4 launch.


I am very sorry. For many years, SUSE’s GNOME is my favorite desktop! Simple, clean, fast, usable :slight_smile:
May I know why GNOME on openSUSE 10.3 is not supported?

You are jumping to conclusions also. It is openSUSE 10.3 that is not supported.

Gnome is supported on supported openSUSE levels (11.1, 11.2 and 11.3 atm iirc) and of course in the coming 11.4.

Support for 10.3 finished October 31st 2009

Lifetime - openSUSE

@hcvv support for 11.1 ended January 14th 2011 :wink: but the evergreen project should extend that…

Sorry, sorry, sorry. Because of my distraction. I meant that I installed 11.3 and not 10.3. :frowning:

Restart the network then :wink: From a terminal run;

sudo /sbin/rcnetwork restart

Done. But it did not do anything. I also rebooted the machine, but nothing. The icon is gone and the wifi does not work anymore!

Ok, start YaST and check under Network Devices that your still using the NetworkManager. If so then try this from a terminal;

nm-applet --sm-disable

If that works, then check in the Control Center -> Startup applications and scroll through the list, do you see an entry called ‘Network Manager’ and it’s unchecked? If not the add it;

Name: Network Manager
Command: nm-applet --sm-disable
Comment: Control your network connections

enrico@linux-portatile:~> nm-applet --sm-disable

** (nm-applet:32275): WARNING **: <WARN> request_name(): Could not acquire the NetworkManagerUserSettings service.
Error: (9) Connection “:1.76” is not allowed to own the service “org.freedesktop.NetworkManagerUserSettings” due to security policies in the configuration file


What happens if you create a test user and login using the test user, same issue?

YES, same issue ! seems that the package is installed wrong. can you update it?

Force the re-install

sudo zypper in -f NetworkManager NetworkManager-gnome

The network icon is back after reboot. Thanks for your support. :slight_smile: