openSUSE-10.3 - new kernel - any issues?

I just had pointed out to me in a thread that there is a kernel available in the 10.3 update repositories. From what I can see, it has been there for a while (file is dated 10-June-2008)?

I started this thread to track issues associated with this new kernel. Please note installing this new kernel could possibly:
a. break your alsa
b. break your graphics (ati/nvidia)
c. break your web cam
d. break your wireless device
e. break your virtual box
I believe there are fixes/workarounds available in all cases.

In particular, wireless users pay close attention to item-d, that it could break your wireless device. Before installing the new kernel, you may wish to give consideration to first installing updated wireless driver rpm to your PC, that you can install after the kernel update.

As opposed to installing the new kernel with a package manager, the alternative is to download the updated kernel rpm to one’s PC, and install it with “rpm -ivh your-kernel-package-rpm” such that one has both the old and the new kernel installed in parallel. And then edit one’s /boot/grub/menu.lst file to ensure one can boot to both old and new kernel. There is a SF TIPS-And-Tricks on this someone where, and we just migrated an SLS Howto also on this subject.

Please post in this thread any issues you may have with the new kernel, and your solutions, so our user base can benefit.

Looks like I will have to update to the new kernel on my 10.3 PC, and update the Alsa-update - openSUSE wiki.

As indicated here,

No sound after installing KDE 4 - openSUSE Forums ,

I also updated to the new kernel as it was offered as a security update by openSUSE updater.

The update broke my alsa as it installed alsa 1.0.17-rc1 from a development repository, which overwrote my modpeobe.d/sound file. The alsa driver also screwed up Kmix, as many of the sound control channels were no longer available. Reverting to alsa 1.0.16, editing my sound file and waiting for the next update to alsa-driver-kmp-default (half a day) fixed the sound problems. Sound/sound functionality is now restored to what it was before the update.

It also affected my graphics, KDE would sometimes hang for no apparent reason when I opened my /home/user folder, this problem now appears to have gone away coincidentally at the same time my sound was fixed.

No problems with webcam.

No problems with wireless.

Over writing your /etc/modprobe.d/sound file is not a problem. … it can be easily fixed/installed.

Now that I see there are alsa 1.0.17 RC2 rpms available for the kernel, if someone else has a problem with that setup, I think I can help. … In the thread you quoted, I was not up to date and hence I mistakenly did not realize a new official kernel had been released.

hi oldcpu
i only saw the new kernel update available today through opensuse updater in my opensuse 10.3. However alsa and my graphics card (nvidia 8600, dri enabled) work flawlessly. I don’t have any of the others to test!

No Problems at all! Everything seems good! :smiley:


Yep - got this through the 10.3 updater. Totalled the nVidia driver (not installed via YAST/YOU) but - hey. Kind of expecting that. Also, Avogadro appears to be working again (strange things happening before) but this may be a driver issue.

Looking forward to oS11 - at the weekend.



PS As this is my first post; nice site everyone …

I also got through the standard update channel.

I run an Inspiron 9400 and I’ve purchased the Linuxant HSF modem code.

The kernel update broke audio, and my modem.

I was able to get audio back by installing alsa-driver-kmp-default-, but that doesn’t play nice with linuxant, so I have no modem.

I’ll probably update to 11.0 this weekend.

Only read this now, to late but for intrest…

Have an Intel P4 D915gux motherboard.
Loaded kernel via smart (thanx oldcpu! smart is great) and now my external realtek pci network says not configured and won`t allow me to.

I plan to update the PCs in our house this weekend to But I am getting more cautious the more I learn about Linux. My 11.0 alpha/beta/RC1 experience (where I installed over 30 rpm kernels) has me familiar and quick enough with the kernel install process, that I think I will

  • first backup the /boot/grub/menu.lst file, then
  • download the kernel-default- rpm to the hard drive of each PC, and then
  • install with: "rpm -ivh kernel-default-…etc … " and then
  • before rebooting (after the kernel install), go into the /boot/grub/menu.lst file, and ensure I can dual boot to both the old and new kernels.

Once I am happy with the new kernel, I will remove the old kernel.

I updated both my PC (an athlon-2800 (see my sig) and my wife’s PC (a semprom-2600, ati graphics) to this weekend.

The update of my PC was pretty much a non-event. Only VirtualBox was broke (as expected) and that was easy fix, as the Virtual Box software tells one exactly what to run to fix the break.

My wife’s PC had both Vitual Box and madwifi break. I was expecting the madwifi break, and rather than using someone else’s pre-compiled madwifi, I simply rebuilt the existing madwifi src rpm for her kernel. To do this, in addition to updating the kernel, I updated her PC’s kernel-source, and kernel-syms. She already had linux-kernel-headers installed, and she had the nominal openSUSE development package installed. Also before installing the updated kernel, I downloaded to my wife’s hard drive the madwifi- So after rebooting with the new kernel, and broken madwifi, I simply rebuilt the madwifi driver for her, with:
rpmbuild --rebuild madwifi-

That created a bunch of rpms in /usr/src/packages/RPMS/i586. I picked out the madwifi and madwifi-kmp-default and installed those two packages, rebooted, and her pc’s madwifi worked.

I just updated the kernel and now can not compile madwifi anymore, I ran:

rpm -qa |grep kernel*

and got:

Notice the mismatch between the headers and the kernel … I am now reinstalling the source and header and hope it will give me the correct version again.

Thats typical, and should be fine IMHO. Note, I also required:
in order to rebuild madwifi

Thanks, did not know that. Installing it now, will report in about 90 minutes. Right now I have to go and watch Germany vs Spain playing the real football (soccer)…

now I feel really stupid … it was a space in the directory tree which caused the make error /home/user/file dir/madwifi-svn
moved it to ~/ and it is compiling now, I ALWAYS use _ instead of spaces, except this time :slight_smile:

Ahh just finished, have compiled from source now!

For the record, if you get this error:

Checking requirements… ok.
Checking kernel configuration… ok.
make -C /lib/modules/ SUBDIRS=/home/USER/temp/Net Software/madwifi-svn modules
make[1]: Entering directory /usr/src/linux-' make -C ../../../linux- O=../linux- Software/madwifi-svn make[3]: *** No rule to make target Software/madwifi-svn’. Stop.
make[2]: *** [Software/madwifi-svn] Error 2
make[1]: *** [Software/madwifi-svn] Error 2
make[1]: Leaving directory `/usr/src/linux-’
make: *** [modules] Error 2

Move the source to a location without a space and try again…