OpenSuse 10.3 network connection

I have the following problem.
I use Suse 10.3. If I download larger files (sometimes after 30 MB, sometimes after 100 MB) the download stalls and the network connection closes. I have to restart my computer to have the network connection again. This also happens if I copy some files with the scp protocoll. Also the network connection is closed until restart.
I tried some things to solve it:
New cable
I tried all six network-sockets in my room, even the one, which works without problems with my windows PC, the same thing.
I tried the advises from these link:

Even my admin has no idea, but for my work it is absolutely necessary to copy large files to a cluster, let calculate something, and copy the results back.

Has anybody a good advice??

Thank You

Are you using Samba or trying to download from the internet? I think problem lies with your NIC card.

Are you using DHCP to get your IP address? I have seen some cases where DHCP leases expiring does this, in this case it would indicate an extremely short lease lifetime.


Check this first.

Well until you get the network connection sorted out, at least use rsync over ssh so that you can resume the transfer where you left off.