openSUSE 10.3- Need help on rpm package

Folks, somehow, I accidentally removed the rpm package in yast> online update>pattern>base system. Right away, I realized the mistake and tried to re-install it. Although, it was downloaded, but I got an error message saying its installation failed. I tried a few times to re-install it back to no avail. Now my system updating/upgrading is totally broken and I have no access to online update/repositories at all. I even tried zypper, it fails due to the lack of rpm package.
please help!
Thanks in advance!

Here is the error message I get when I open yast and click on “online update”:

Error loading language plugin /usr/lib/YaST2/plugin/ cannot open shared object file: No such file or directory. No such client module online_update

Run yast2 -h for help on usage

I did read thru yast2 -h but this was not of much help.

I normally don’t tell people this … but unless someone else here has a better idea, you might find it quicker to just reinstall. While you’re at it, unless there’s something in 10.3 that you’ve just got to have, why not upgrade to 11.1? It should leave your /home director(ies)y intact.

Another possibility is to boot into the recovery system, but if you’ve hosed everything that badly, that probably won’t work either.

Thanks for your reply!
I do have 11.1 with kde 4.3.1 already installed on a separate partition. However. 10.3 was such a clasic and stable version on this box that I used it as my main OS while playing with the kde 4 system on other partition.
I will try to see that I somehow manage to resolve this issue. If not, then I may try to reinstall the same version, since I liked it so much.

You read about the panned power outage this weekend?

Yes, I did. whether that has been the cause of problem, I am not sure. Right now, the damage is done. I can neither use yast or zypper to have access to online updateing. This of course, is due to the removal of rpm package, as was described in my openning post above.