openSUSE 10.2: nForce2 A97 Audio Controller (MCP): no Sound

Hardware:
Motherboard: Asus A7N8X-E Deluxe
. Chipset: Southbridge: NVIDIA nForce2 MCP-T
. Audio: MCP-T southbridge integrated Audio Processor Unit (APU) + Realtek ALC650 6-channel audio CODEC

Software:
OS: openSUSE 10.2 (i586) live CD (32 Bit PC)
. YaST > Hardware > Hardware-Information > PCI/Sound > nForce2 A97 Audio Controller (MCP) > Driver
- Module (-active: Yes; -modprobe: Yes; -modules: modprobe snd_intel8x0)
- Module (-active: No; -modprobe: Yes; -modules modprobe i810_audio)

Symptoms:
Volume Levels:
. Audio In: vumeter -r ; glow on Mic input, in normal and 2ch 4ch Channel Mode
. Audio Out: vumeter ; dark on playing, neither in normal nor in Channel Mode

Trials:

  1. BIOS > PnP/PCI Configurations > Resources Controlled By [Auto (ESCD); Manual]
  2. OS: Boot Option: [none] ; pci=noacpi; oldboot; off; force
    . YaST > Sound > Edit > Normal Setup > [Test]
    These changings and their combinations seem to be useless or just the beginning. Which way to go?

I have an Asus A7N8X Deluxe (not an A7N8X-E) and basic sound works, but not 5.1 sound. Its long been known that 5.1 sound is not supported on this motherboard (its in the Linux incompatibility list). Audio incompatibility list for Linux

… but basic sound works, out of the box on this PC since before openSUSE-9.3. Still your 10.2 is no longer supported, and you should give consideration to updating to 11.1. I find 11.1 runs superior to 10.x version on this motherboard.

As noted, basic sound on this motherboard should work “out of the box”. Check your mixer carefully. Move up both PCM and master volume. Also use an appropriate speaker test. … i.e. to determine if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times.

You could try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

If you have no success with the audio troubleshooting guide, then I will need more information if I am to make a recommendation … So can you provide more very detailed information so a good recommendation can be given? You can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and typing:
/usr/sbin/alsa-info.shthat will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. Just the URL. It may be that you need to run that script with root permissions. Please note that I need that output to understand better your PC’s configuration.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Thanks a lot for your advice!

„basic sound on this motherboard should work… “
Yes I can attest this to Linux (for example „Mandriva Installation 2008 Spring“ on HDD)
„5.1 sound is not supported“
But output only <Surround L/R audio> instead of the ordinary <Line Out> jack.
„“out of the box”“
Before I used <Surround L/R audio> on Windows XP Pro to substitute a trashy <Line Out>.
Could that be a cause; are there onboard sound chipsets that remember such settings?

| # speaker-test -c2 -l5 -twav
| 1speaker-test 1.0.13
| Playback device is default
| Stream parameters are 48000Hz, S16_LE, 2 channels
| WAV file(s)
| Rate set to 48000Hz (requested 48000Hz)
| Buffer size range from 2048 to 16384
| Period size range from 1024 to 1024
| Using max buffer size 16384
| Periods = 4
| was set period_size = 1024
| was set buffer_size = 16384
| 0 - Front Left
| 1 - Front Right
| Time per period = 2.691640
| …
(At the beginning I typed -1 in place of -l and got an error message (…invalid option – 1…).)
The primal run was a mere visual - and vision: Somehow I looked again at the Alsa mixer settings:
|| gnome-volume-control > Volume Control:
|| > Edit > Preferences: [OK] Duplicate Front | > Switches: Duplicate Front [OK]
This enables sound output on <Surround L/R audio>.
To low volume yet allthough PCM slider on maximum (Master ineffectiv)
|| > Edit > Preferences: [OK] Surround | > Playback: Surround (slider)

SDB:AudioTroubleshooting
| # cat /proc/asound/version
| Advanced Linux Sound Architecture Driver Version 1.0.12rc1 (Thu Jun 22 13:55:50 2006 UTC).
| # cat /proc/asound/modules
| 0 snd_intel8x0
| # cat /proc/asound/cards
| 0 [nForce2 ]: NFORCE - NVidia nForce2
| NVidia nForce2 with ALC650F at 0xec081000, irq 185
Scripts: None of the proposed routine works on thies Read-only file system. ?

„following commands …] post here the output:“
| # rpm -qa | grep alsa
| alsa-1.0.13-22
| # rpm -qa | grep pulse
| #
| # rpm -q libasound2
| package libasound2 is not installed
| # uname -a“
| Linux linux 2.6.18.2-34-default #1 SMP Mon Nov 27 11:46:27 UTC 2006 i686 athlon i386 GNU/Linux
| # cat /etc/modprobe.d/sound
| options snd-intel8x0 enable=1 index=0
| # H0_h.AyAc5dtQ3r5:nForce2 AC97 Audio Controler (MCP)
| alias snd-card-0 snd-intel8x0

Now it I’d like to learn how to…
. avoid detours over the mixer preferences ‘Duplicate Front’ and ‘Surround’
. route the signal from <Surround L/R audio> to <Line Out>
. enable vumeter glow
. modify the info scripts for a live system

I can’t help you there.

You could try on IRC chat channel “freenode” #alsa, … but with openSUSE-10.2 being old and not supported, you may find a distinct lack of support.

10.2… old memories…

This is basic, but did you check volume settings in Yast>Hardware>Sound>Others button>Volume?