opensue stops to refresh the system - 349 packages still left in the queue - so what?

dear community,

i run the newest version of opensuse on a notebook -

from time to time there are new updated that are installed - so far so good.

but for several weeks - the updates dont get installed. - for some reasons that i do not know at the moment.

all i can ee: opensue stops to refresh the system - 349 packages still left in the queue - so what?

question: how to see why the updates stopped?
are there any log files that tell us more about this issue!?

can i use some commands to get more infos about this situation?

Stuck in which queue?

Updates are not installed automatically, you have to do so manually.

can i use some commands to get more infos about this situation?

Well, do you actually try to install the updates? If yes, how? And do you get an error message or what happens?
Try to run “sudo zypper up” to install the updates. This should also give more details if there is some problem.

Btw, if you are talking of your desktop’s update applet, there is a known problem in PackageKit regarding license agreements. So if there’s a flash-player update, the desktop’s updater will just hang after you accept the license.
Workarounds: use zypper or YaST to install updates, or interact with PackageKit in any way while it is hanging (open Apper from the K-Menu e.g. or run “pkcon get-updates” in a terminal window. It should continue to install the updates then.
http://bugzilla.opensuse.org/show_bug.cgi?id=908730

What exactly do you mean by ‘i run the newest version of opensuse’ ?

Do you mean openSUSE 13.2 ?

On 2015-05-11 23:46, ratzi wrote:
>
> dilbertone;2709439 Wrote:
>> dear community,
>>
>> i run the newest version of opensuse on a notebook
>
> What exactly do you mean by ‘i run the newest version of opensuse’ ?
>
> Do you mean openSUSE 13.2 ?

The newest would be Factory, that is even newer than Tumbleweed >;-)


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

hello dear wolfi

many thanks - you hit the point - here…

thats it - you described the situation - this is exactly what goes on.

i will try out these steps when i am at the notebook -

many many thanks for this hint;)

hello and good day

runned the code - and got back the follwing results

btw - the updates did not work either - all trials to run the update-apper failed permanently

i do not know how to proceed -

any ideas ?

**question ** - can i run any commands with the command line ?

look forwrd to hear from you

dilbert

d aktualisiert=========================]         
Fertig                        =========================]         
Problembehebung         openSUSE-2015-165-1.noarch (repo-update)                        Recommended update for postfix
Problembehebung         openSUSE-2015-166-1.noarch (repo-update)                        Recommended update for util-linux
Sicherheit      openSUSE-2015-169-1.noarch (repo-update)                        Security update for xorg-x11-server
Sicherheit      openSUSE-2015-170-1.noarch (repo-update)                        Security update for tigervnc
Problembehebung         openSUSE-2015-171-1.noarch (repo-update)                        Recommended update for dconf
Sicherheit      openSUSE-2015-173-1.noarch (repo-update)                        Security update for glibc
Problembehebung         openSUSE-2015-175-1.noarch (repo-update)                        Recommended update for yast2-bootloader
Problembehebung         openSUSE-2015-177-1.noarch (repo-update)                        Recommended update for YaST 2
Sicherheit      openSUSE-2015-179-1.noarch (repo-update)                        Security update for samba
Problembehebung         openSUSE-2015-180-1.noarch (repo-update)                        Recommended update for sysconfig
Problembehebung         openSUSE-2015-181-1.noarch (repo-update)                        Recommended update for autofs
Sicherheit      openSUSE-2015-182-1.noarch (repo-update)                        Security update for cups
Sicherheit      openSUSE-2015-185-1.noarch (repo-update)                        Security update for MozillaFirefox, mozilla-nss
Problembehebung         openSUSE-2015-187-1.noarch (repo-update)                        Recommended update for shared-mime-info
Problembehebung         openSUSE-2015-188-1.noarch (repo-update)                        Recommended update for wicked
Sicherheit      openSUSE-2015-191-1.noarch (repo-update)                        Security update for apache2
Problembehebung         openSUSE-2015-194-1.noarch (repo-update)                        Recommended update for cairo
Problembehebung         openSUSE-2015-195-1.noarch (repo-update)                        Recommended update for release-notes-openSUSE
Problembehebung         openSUSE-2015-196-1.noarch (repo-update)                        Recommended update for the KDE Applications
Problembehebung         openSUSE-2015-199-1.noarch (repo-update)                        Recommended udpate for several kde-applications
Sicherheit      openSUSE-2015-203-1.noarch (repo-update)                        Security update for php5
Sicherheit      openSUSE-2015-207-1.noarch (repo-update)                        Security update for tiff
Sicherheit      openSUSE-2015-208-1.noarch (repo-update)                        Better fix for buffer overflow causing DoS
Problembehebung         openSUSE-2015-210-1.noarch (repo-update)                        Recommended update for Tcl and Tk
Sicherheit      openSUSE-2015-220-1.noarch (repo-update)                        Security update for autofs
Problembehebung         openSUSE-2015-223-1.noarch (repo-update)                        Recommended update for xorg-x11-server
Sicherheit      openSUSE-2015-225-1.noarch (repo-update-non-oss)                Security update for flash-player
Problembehebung         openSUSE-2015-227-1.noarch (repo-update)                        Recommended update for Qt5, KF5 and Plasma5
Problembehebung         openSUSE-2015-231-1.noarch (repo-update)                        Recommended update for java-1_8_0-openjdk
Problembehebung         openSUSE-2015-233-1.noarch (repo-update)                        Recommended update for mariadb
Problembehebung         openSUSE-2015-235-1.noarch (repo-update)                        Recommended update for ntp
Problembehebung         openSUSE-2015-236-1.noarch (repo-update)                        Recommended update for sudo
Sicherheit      openSUSE-2015-239-1.noarch (repo-update)                        Security update for vorbis-tools
Sicherheit      openSUSE-2015-242-1.noarch (repo-update)                        Security update for libssh2_org
Problembehebung         openSUSE-2015-245-1.noarch (repo-update)                        Recommended udpate for KDE Applications
Sicherheit      openSUSE-2015-246-1.noarch (repo-update)                        Security update for krb5                                                                                        
Sicherheit      openSUSE-2015-247-1.noarch (repo-update)                        Security update for openssl                                                                                     
Sicherheit      openSUSE-2015-248-1.noarch (repo-update)                        Security update for libarchive                                                                                  
Problembehebung         openSUSE-2015-249-1.noarch (repo-update)                        Recommended udpate for util-linux                                                                       
Problembehebung         openSUSE-2015-252-1.noarch (repo-update)                        Recommended udpate for yast2-control-center                                                             
Problembehebung         openSUSE-2015-259-1.noarch (repo-update)                        Recommended update for the GNOME stack                                                                  
Sicherheit      openSUSE-2015-260-1.noarch (repo-update)                        Security update for less                                                                                        
Sicherheit      openSUSE-2015-263-1.noarch (repo-update)                        Security update for MozillaFirefox
Sicherheit      openSUSE-2015-265-1.noarch (repo-update)                        Security update for libzip
Sicherheit      openSUSE-2015-266-1.noarch (repo-update)                        Security update for libXfont
Sicherheit      openSUSE-2015-267-1.noarch (repo-update)                        Security update for tcpdump
Sicherheit      openSUSE-2015-269-1.noarch (repo-update)                        Security update for gnutls
Problembehebung         openSUSE-2015-271-1.noarch (repo-update)                        Recommended update for LibreOffice
Problembehebung         openSUSE-2015-273-1.noarch (repo-update)                        Recommended update for lvm2
Sicherheit      openSUSE-2015-274-1.noarch (repo-update)                        Security update for freetype2
Problembehebung         openSUSE-2015-277-1.noarch (repo-update)                        Recommended update for Bluedevil
Problembehebung         openSUSE-2015-278-1.noarch (repo-update)                        Recommended update for timezone
Sicherheit      openSUSE-2015-280-1.noarch (repo-update)                        Security update for gd
Sicherheit      openSUSE-2015-282-1.noarch (repo-update)                        Security update for php5
Problembehebung         openSUSE-2015-284-1.noarch (repo-update)                        Recommended update for systemd
Problembehebung         openSUSE-2015-285-1.noarch (repo-update-non-oss)                Recommended udpate for gst-fluendo-mp3
Problembehebung         openSUSE-2015-286-1.noarch (repo-update)                        Recommended update for krusader
Problembehebung         openSUSE-2015-287-1.noarch (repo-update)                        Recommended update for apper
Sicherheit      openSUSE-2015-290-1.noarch (repo-update)                        Security update for MozillaFirefox, MozillaThunderbird, mozilla-nspr
Problembehebung         openSUSE-2015-293-1.noarch (repo-update)                        Recommended update for tigervnc
Sicherheit      openSUSE-2015-295-1.noarch (repo-update)                        Security update for php5
Sicherheit      openSUSE-2015-302-1.noarch (repo-update)                        Security update for Linux Kernel
Sicherheit      openSUSE-2015-304-1.noarch (repo-update-non-oss)                Security update for Adobe Flash Player
Problembehebung         openSUSE-2015-306-1.noarch (repo-update)                        Recommended update for ibus
Problembehebung         openSUSE-2015-308-1.noarch (repo-update)                        Recommended update for lsof
Problembehebung         openSUSE-2015-311-1.noarch (repo-update)                        Recommended update for Apache2
Problembehebung         openSUSE-2015-312-1.noarch (repo-update)                        Recommended update for lvm2
Problembehebung         openSUSE-2015-313-1.noarch (repo-update)                        Recommended update for timezone
Problembehebung         openSUSE-2015-316-1.noarch (repo-update)                        Recommended update for tar
Problembehebung         openSUSE-2015-318-1.noarch (repo-update)                        Gnomestack update for the 3.14 stable branch
Problembehebung         openSUSE-2015-319-1.noarch (repo-update)                        Recommended update for pulseaudio
Problembehebung         openSUSE-2015-321-1.noarch (repo-update)                        Recommended update for pulseaudio
Problembehebung         openSUSE-2015-322-1.noarch (repo-update)                        Recommended update for LibreOffice
Problembehebung         openSUSE-2015-323-1.noarch (repo-update)                        Recommended update for libxine2
Sicherheit      openSUSE-2015-326-1.noarch (repo-update)                        Security update for Mozille Firefox
Problembehebung         openSUSE-2015-328-1.noarch (repo-update)                        Recommended update for perl-IO-Socket-SSL
Sicherheit      openSUSE-2015-330-1.noarch (repo-update)                        Security update for ntp
Sicherheit      openSUSE-2015-331-1.noarch (repo-update)                        Security update for java-1_7_0-openjdk
Sicherheit      openSUSE-2015-332-1.noarch (repo-update)                        Security update for java-1_8_0-openjdk
Problembehebung         openSUSE-2015-334-1.noarch (repo-update)                        Recommended udpate for myspell-dictionaries
Sicherheit      openSUSE-2015-336-1.noarch (repo-update)                        Security update for curl
Problembehebung         openSUSE-2015-339-1.noarch (repo-update)                        Recommended update for poppler
Sicherheit      openSUSE-2015-341-1.noarch (repo-update)                        Security update for wpa_supplicant
Problembehebung         openSUSE-2015-343-1.noarch (repo-update)                        Recommended update for wicked
Problembehebung         openSUSE-2015-347-1.noarch (repo-update)                        Recommended update for xorg-x11-server
Problembehebung         openSUSE-2015-349-1.noarch (repo-update)                        Recommended update for tiff
Sicherheit      openSUSE-2015-352-1.noarch (repo-update)                        Security update for php5
Sicherheit      openSUSE-2015-353-1.noarch (repo-update)                        Security update for pcre
Sicherheit      openSUSE-2015-355-1.noarch (repo-update)                        Security update for libssh
Sicherheit      openSUSE-2015-356-1.noarch (repo-update)                        Security update for curl
Sicherheit      openSUSE-2015-357-1.noarch (repo-update)                        Security update for libreoffice
Sicherheit      openSUSE-2015-359-1.noarch (repo-update)                        Security update for dnsmasq
Sicherheit      openSUSE-2015-360-1.noarch (repo-update)                        Security update for libtasn1
martin@linux-a9sq:~> 


Failed how?

i do not know how to proceed -

any ideas ?

If PackageKit got stuck again, try to run pkcon again, or start apper and check for updates there.
Any interaction with PackageKit should make it continue.

Or just kill packagekitd (or logout/login or reboot) and install the updates with YaST or zypper as I already wrote (e.g. “sudo zypper up”).

**question ** - can i run any commands with the command line ?

Of course. Haven’t you done so already? :wink: