Opensue 13.1 update then lost kde and other things

I am trying to help a friend who updated as per normal but lost the graphical kde interface.
I have tried


but the result is

can not connect to xserver config error loading shared libraries libssl
cannot open shared libraries
no such file or directory

So I decided to try to load the missing file using
zypper install libopenssl
But this gave me response that it could not find /usr/liib/libcrypto

And then things got worse so I tried to find out why zypper was not working and
ldd ./zypper gave me no such file or directory
I am at a complete loss as all the help on similar problems seems not work always resulting in “no such file or directory”
I have tried with and without sudo, so it is not a premissions problem
I have also disabled IPv6

Could be permissions sudo is not the same as Ubuntu in openSUSE you don’t get the full root environment. use su - (note the dash) to become root

startx does not work for users it is depriciated as root use startx or init5

Not sure but I don’t think startkde work either

I assume etc means other stuff but we don’t know what other stuff you tried

I doubt that IPV6 has anything to do with it

You could also try yast

become root su -
then yast

If connection problem and this is a notebook using wifi try connecting hardwired

No GUI may indicate that the root file system is full check free space with df.

Thanks for the reply
It is a desktop machine with a raid mirrored set up with lots of free space
I used startx and startkde as they are recommended in opensuse documentation
Tried su - as well as sudo
As far as YAST is concerned I started this (under root) and some of the commands work but not Software management, Online update, and Firewall. Firewall starts intialising then goes back to the YAST screen
Had a look at the last few entries in y2log but there was not anything different from a machine that is working correctly
So any more thoughts would be much appreciated

Sounds like it is truly messed up if parts of yast don’t work. If you have the full DVD install disk for 13.1 you could try an upgrade (yes 13.1 to13.1) to get something that works. This will keep all settings and installe apps and you will then have to do a major update to get it all back to current state.

It sounds like there may have been mixed version on the update the broke everything so check that there are only the basic repos and they all point to13.1 versions.

Thanks I think that you are correct. The most unfortunate thing is that my friend is not very computer savvy and lives 800 kms away, so everything has to be done by phone.
I think I will try with an upgrade to 13.2 as this seems to work quite well and be stable

Hi again
I am still trying not to do a re-install so ask my friend to do a find and then a ldd on zypper
This results in that zypper lives in /usr/bin/zypper
Then an ldd on zypper results in = > not found 3 times = > not found 2 times
Now I could re-install these if I could get zypper to work, but it does not because these are missing
Is there anyway in which to achieve this?
Thanks in advance for your patience

A reinstall or an upgrade will be much easier then trying to fix things that are as broken as described.

Totally missing parts of critical pieces may indicate a messed up file system. To fix you must boot to a live Linux media and run fsck against the root partition. The file system may or may not be fixable. If the file system is messed up it may indicate disk hardware problem so you need to run smartctl against the disk to test the reliability of the hardware.

Thanks for your advice