opensu11.1 dvd drive not mounted with audio cd

laptop: asus k50in
opensuse 11.1 installed last week
problem: I want to play a audio cd, but there is no disk found at all. “ls /media” gave me nothing. But device manager in yast showed the presence of the dvd drive as /dev/sr0.

can somebody at least tell me the command to manually mount a audio cd into dvd drive, so i can at least try to mount it by myself?
solution to fix the problem completely will be great.

i understand sometimes we still run into problems with newer devices such as the new graphics card ( aG102M, fixed 6 screens problem by adding a option clause suggested by a brilliant user). but now still has problem with dvd mounting?!, come on, linux, come on suse :(.

Kde or Gnome?

If kde in Dolphin type: audiocd:/
In the address field

Thank you very much. By typing audiocd:/ in dolphin, the cd showed up! and then I used kaffeine to play one of the wav file, but there is no sound?, then I tried youtube with no problem with sound at all. Can you give a hint?
Thanks again.

You should follow this guide carefully as multimedia apps should be supplied by Packman
Multi-media and Restricted Format Installation Guide - openSUSE Forums

thank you very much, I will look into that guide.

You are most welcome. If you have any trouble with dependencies use the expert button to save it to file and then copy here. But basically you want the change vendor to Packman option.

I finished updating multimedia following the link you gave. There are some dependency issues, but all are solved by change vendor.

Now a new problem -sound- showed up. I tried youtube again after updating, this time no sound. Kmix has 100% for all. but when restart computer, the system music was on. my device is nVidia MCP79.

i followed audiotroubleshooting page, until step 2 so far, with one retarting, but no luck. I did notice right after login, there is a message from kde phonton saying some…problem…change back to pulseaudio… not sure what that exactly means.

anyway, right now, youtube has no sound.
when i try speaker-test -c2 -l5 -twav:

Playback open error: -16, device or resource busy

any thought???


If the sound device is already in use this can be a problem. But check and see if you have a package called libflashsupport - Try removing it.

Thanks for your help. I started a new thread:

sound stop working after updating on asus k50in - openSUSE Forums

and are exchanging ideas with oldcpu. Thank you both for the great work on this forum.


I had a similar problem on my Dell Precision M65 (openSUSE 11.1, KDE4), except that I had already sorted out the problems with audio (more or less).

What I do not understand is why the Device Notifier widget does not react when a CD is inserted in the DVD player (and yet in the “File association” menu of KDE configuration I added Kaffeine as the first choice for “Audio CD” - Amarok is second, but I also tried the reverse).

Is this the intended behaviour for CDs in KDE4? Up to openSUSE 10.3 (KDE3), whenever I inserted a CD a window popped up asking me what application to use to play the newly inserted medium.

And (a probably separate problem): I do not understand why Amarok cannot play the CD at all (using Amarok from Packman, with Xine engine). If in the “Settings - Media Devices” menu I do “Autodetect Devices”, I get the following error message:

No new media devices were found. If you feel this is an error, ensure that the DBUS and HAL daemons are running and KDE was built with support for them. You can test this by running "dcop kded mediamanager fullList" in a Konsole window.

Running the above dcop command from konsole I get (last relevant items):

Audio CD



Is it all this normal? Or there is something in the configuration that should be fixed?

Currently using Amarok from package:

Any explanation/suggestion/hint are very much welcome.

In Dolphin address bar type:


Actually, I had already tried that. I can indeed browse the disk content, and copy it, say, to the HD. But if I click on one of the audio files, Dolphin calls Amarok, which in turn grumpily says:

No suitable input plugin. This often means that the url's protocol is not supported. Network failures are other possible causes.
audiocd:/Pascal Roge - 09 - Valses nobles et sentimentales - VI. Assez vif.wav

I can get around this by copying the file on the hard disk: Amarok can now play it.

Anyway, my questions were not really about that. Sorry, perhaps I have not been clear. I’ll try to reformulate my questions more concisely:

  1. Why nothing happens when I insert an audio CD? The Device Notifier widget, for instance, does not react (while it does show a video DVD when I insert it)
  2. Why Amarok has problems recognizing the CD medium?

The answer to the second question may well be that Amarok is not configured properly on my system, or that - being a KDE3 app - it does not work well in KDE4. I guess with time I can figure out the reason (but any hint is welcome).

What bothers me more is the first question: I have so far been used to expect that inserting a CD would cause the system to either prompt me about what to do, or (if configured properly) to call the pre-selected application to play the music (say: Amarok or Kaffeine).

Sure, I can manually type audiocd:/ in Dolphin or Konqueror and go on manually selecting/copying the audio files.

Or, as I mentioned in my previous post, I can manually call Kaffeine and manually click the “Play Audio CD” button from its main menu.

But is this the best that KDE4 can do? Or, again, I am missing some configuration option somewhere?


P.S.: when I say “I am used” I do not refer to Windows. I’ve been using Linux for ages now, and openSUSE for almost as long.

I dropped a cd in;](](](

Thanks, caf4926.

Any suggestions on how I could accomplish the same? Or where to look for the source of my problems?

I just noticed from your signature that you are running KDE 4.3.1. I’m still with openSUSE 11.1, i.e. KDE 4.1.3.

That might be a cause of the difference between my experience and yours :\

I’m wondering whether there are others experiencing the same problem as me and the originator of this thread.

Of course, as soon as 11.2 will be out, I will upgrade. It’s just a few weeks. But I’m still curious now… And I might learn something more about KDE4 :wink:

Open KsCD with a CD in the drive
And try hitting Play.

Upgrade kde
KDE 4.3.2 HowTo for 11.1 - openSUSE Forums

or at the very least add the build service repo for your version

As in the case of Kaffeine, KsCD sees the disk.

But the Device Notifier widget can’t still see it

Moreover, the KsCD “Eject” button does not work.

Anyway, I found a few bugs from KDE 4.0 and 4.1.2 reporting this problem:

So, it seems that indeed the solution is to upgrade KDE…

Upgrade kde
KDE 4.3.2 HowTo for 11.1 - openSUSE Forums

or at the very least add the build service repo for your version
Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.1

…which I will do sometime in the next few weeks.


You might as well just install 11.2 in a few weeks.:wink:

Otherwise - just rip the CD with k3b

I don’t know anyone that uses cd’s to playback today (wait…maybe you do?):wink: