OpensSuse 11 => MacBook rEFIt


Usually I don’t make questions on Forums (Google is my best friend!!! :P)

But, this I am not being able to solve by my self.

Ok, I installed it, made the first reboot, made the gptsync, entered in the system again using the instalattion cd:

mount /dev/sda4 /mnt
mount -t proc none /mnt/proc
mount -o bind /dev /mnt/dev

chroot /mnt /bin/bash

grub --batch < /etc/grub.conf

Error 17.

(It was using the right partition (hd0,3)).

After that I started to try with Lilo.

Entered in Repair system, changed the boot manager to Lilo, instaled, made the gptsync first time, entered again using the rescue system, made the steps above, in the place of grub --batch, i just typed lilo, ot showed linux added. Perfect.

But, when I tried to do the gptsync again, it returned:

Analysis Inconclusive, will not touch this disk.

And when I tried to boot the linux I get:

missing operating system.

Looks like some bug in rEFIt, but i’m not sure.

Another strange behavior is that if I enter in any of refit options (sync, shell, or info) I can’t boot any other system without reboot the macbook before.

Well, any tips will be welcome!

Thanks in advance


Any one knows any thing about?

I’m having the exact same problem. when I use sda4 it works but there is no partition there even though it says it has installed.:confused:

Gives you the Missing Operating System Message?

that is exactly what happens. I just got a new macbook a few days ago and I couldn’t wait to install this but I just can’t seem to get it working?

I’m locked with out know any other trick…

I instaled the 10.3 before and it worked… But now, don’t have any clue about.

Any body Else??

Only that elilo is how this is controlled, i.e. the Boot Camp compatibility mode. Perhaps the path statements are not correct? No first hand experience with this, sorry.

One strange thing is if I try inside grub:

find /boot/grub/stage1

it says that is impossible to find (but the file is there).

I will give a try to the Xubuntu…

But I really like OpenSuse.

same here … no success on installing OS11 on a macbook … fedora and ubuntu install fine though …

Fedora is LSB complaint? (this is one of my bigger problem with ubuntu).

I believe so … in line to the RedHat enterprise prods.

when you installed rEFIt did you use custom options and check support for ext2 and ext3. What I did is install openSUSE 11 then install Kubuntu and when you use rEFIt to boot Kubuntu it gives you the boot loader and you can boot openSUSE instead.

Is this problem solved? (The post seems to be older).

I’m not an expert on this but I installed openSUSE on my Macbook Pro. So, I may be able to help you still with my limited understanding.

This is still an active issue. The problem involves the ‘normal’ macbook (v3.1 in my case). The Yast2 GRUB install seems to work fine on the MacBook Pro.

Thanks for offering your help though :slight_smile:

Rgrds, Martijn

Ps. There’s a Bugzilla Bug on this issue:

I recently installed OSX, Vista and SuSe 11.0 on my MacBook.

After looking at this MacBook - openSUSE and having the same issue with

grub --batch < /etc/grub.conf → Error 17.
I checked the partitions and found out they were not in the order as they should be.

So I prepared the partitions with the partition tool which comes by Mac OS as followed:

  1. Mac
  2. Linux
  3. Win

So if you consider the Efi partition which comes by default after Mac installation, there is this partion order:

dev/sda1 - refit
dev/sda2 - macos
dev/sda3 - linux ext3
dev/sda4 - win ntfs

If you check them with ‘fdisl -l’ or ‘parted -l’ they should be exactly like this.

So in this case, after SuSe rescue boot we do ‘mount /dev/sda3 /mnt’ and not ‘mount /dev/sda4’

With ‘cat /boot/grub/menu.lst’ check if (hd0,3) is given.

Also ‘cat /etc/grub.conf’ should give you ‘setup --stage2=/boot/grub/stage2 (hd0,3) (hd0,3)’

Then ‘grub --batch < /etc/grub.conf’ should end up in ‘Running "install --stage2=/boot/grub/stage2 /boot/grub/stage1 (hd0,3) /boot/grub/stage2 p /boot/grub/menu.lst "… succeeded