openshot don't start

hi, I have a problem to start openshot on opensuse 13.2, someone found this type of problem?
trying with terminal:
------------------------- ERROR 1 ------------------------------
Failed to import ‘from openshot import main’
Error Message: cannot import name main

OpenShot (version 1.4.3)

Process no longer exists: 19485. Creating new pid lock file.
*** ERROR: MLT Python bindings failed to import ***

------------------------- ERROR 2 ------------------------------
Failed to import ‘from openshot.openshot import main’
Error Message: No module named xdg.IconTheme

OpenShot has failed to import some of the Python files or libraries
required for our application to run. Here are some trouble shooting

Tip 1) Check if MLT can be successfully imported in Python. Run the
following commands, and see if any errors are displayed. If you get
an error, you need to investigate the correct way to install MLT.
NOTE: Do not type the $ or >> characters in the examples below.

   $ python
   >> import mlt
   >> mlt.Factory().init()

Tip 2) If MLT is working from the first example, then the next tip is
to look at the above error messages very closely, and google for more
help. It’s likely the problem is already reported, and maybe there is
a simple work-around. Also, you can search for bugs or report a new
bug at Good luck!

what should I do ?:frowning:

do you have

sudo zypper in python-xdg

Unfortunately, OpenShot still doesn’t work for any but a DEB distro.
This is because the author develops only for that platform (Yes, I’ve already suggested OBS to him).

I just took a look at it, and IMO the existing problems are unresolvable without <very> significant investigation.
<Maybe> compiling from source is an option, I haven’t looked at that for a long time (Couldn’t before) but you won’t likely find any packages that work.


Before dropping this for now, I took a brief look at whether OpenShot might be compiled from source…

The OpenShot download page

The stated dependencies

** OSS and/or special openSUSE multimedia repo
** OSS
** OSS, but you may need the python bindings for sox, I found those in the Python libraries (not openSUSE), you will need to use pip

If you want to try compiling, good luck.


Hmm… I have OpenShot 1.4.3-1.19 (Packman repo) installed on a machine running openSUSE 13.1 (KDE). I have used it on a number of occasions and had no problems. In fact, I was really impressed with it and used it as my editor of choice.

It was originally installed some time ago but I can’t recall any particular problems getting it going.

As a follow-up, I just installed OpenShot from the Packman repo on a machine running Tumbleweed.

OpenShot itself appears to run well, despite reporting the same ERROR 1 as the OP. Just noise I suspect.

The package python-xdg was pulled in automatically, which apparantly didn’t happen in your case. So I would install it as previously suggested and see what happens.

Getting openshot from Packman does seem to work, at least it launches properly. The xdg file never was a problem for me, but I ran into a number of other issues with the OBS cabelo build found in http:/

Adding Packman (13.2)

zypper ar -f packman