OpenOffice writer crash on graphics


I have an issue with OpenOffice on a series of documents I am

The documents each have multiple graphics of screen shots taken in PNG
format. I import them via the Insert → Picture → From File… option
and then do “No Wrap” and set a Caption via the Context Menu.

This was working fine until a few days ago. Now when I now open the
documents, not just one, some (but not all) of the graphics do not show
the caption. Seems to be hidden or something. When I right click to
bring up the context menu OpenOffice Writer will close and the Recovery
Notification Dialog appears and disappears immediately.

When I start OpenOffice I get the Recovery dialog and the document will
recover OK. However there will be other graphics (usually not the same
ones) that have the same issue.

I am using OpenSUSE 11.0 x86 64 bit. I was using the OpenOffice from
the original media ie. 2.4 I have just today upgraded via the OpenOffice
repository to 3.0 to see if it fixed it, but has the same issue.

Have the ability to open the document on OpenOffice 3 on Windows XP and
that does NOT seem to have the problem.

I am not aware of any update to the system that occurred in time with
this issue appearing.

I thought that as I am accessing the documents over a NFS share that
this might be an issue so have copied them to local disk. Still not

Any thoughts?

Pye, James Pye. chmod 007, The Ultimate Open Source.


jimpye’s Profile:
View this thread:

I’m has no such issue in x86 system.
can you check in another way… add new user, login in his environment
and run oowriter with same task as you doing before…

also what DE did you use… try different

Linux openSUSE 11 i386
#2 nforce2|Athlon|Radeon9200|RAM1GB
#3 laptop ASUS x51r|Xpress1100|512MB

didencool’s Profile:
View this thread:

Off the top of my head, there are two locations to check: your default
template and ooo config files. By temporarily moving each one out of the
way, you may be able to narrow down the problem. It may be as simple as
reinstating the backup version (if there is one) of your ooo template.
Even if free software were crap, it should still get our preference
over the non-free crap secreted by IT corporations.
-A free rephrasing of RMS-

JosipBroz’s Profile:
View this thread:


Thanks for the quick responses.

didencool: Created another user and logged and ran up oowriter opened
the same document and same problem. I also took some screen shots of
the issue if interested.

I use KDE almost exclusively and only have enough of gnome installed to
run apps like evolution etc. that require it. As this is my “production”
machine I do not want to mess it around too much with multiple desktop
environments etc.

JosipBroz: I saw the .ooo3 dir being created on first startup of
oowriter as the new user above, but am not totally sure where the
templates you mention are. I am using some custom styles which I
created via the F11 selector and the document is created from a template
I created by saving a document as a template. This has a watermark,
header, footer, some text etc.

As I said this was working OK until a few days ago (the project has
been going for a month or so) and it seems to now be across multiple
documents. I am guessing there is a corruption that is being introduced
to the documents that, once in there, OOo is not able to clean out, even
on a Save as… to make a new version.



jimpye’s Profile:
View this thread:

I am not sure if this is a work around for this issue.

I notice that when I create the graphic via the Insert → Picture →
From File… option, and then add a caption, that both the picture and
the caption frame are anchored to the paragraph by default.

I am wondering if what I am seeing is happening after I make mods to
the text and these anchor points “get out of sync”

What I am trying as a work around is once I place the caption I change
the anchor of the graphic to be the frame. So now the picture is
anchored to the caption frame and the caption frame is anchored to the

Will see how we go as the original problem is intermittent and not



jimpye’s Profile:
View this thread: