openoffice stopped working when I installed sun java

Yesterday I disinstalled with yast java-1_6_0-openjdk- and java-1_6_0-openjdk-plugin- (which were installed as part of our sitewide suse 11.3 installation) and replaced them with java-1_6_0-sun-1.6.0.u22-1.2.1-x86_64 and java-1_6_0-sun-plugin-1.6.0.u22-1.2.1-x86_64 (et al) to solve my problem about bad graphics quality in firefox applets as described and suggested in this other postl.

That successfully solved my applet problem, but I just discovered it **triggered a new problem with openoffice **. I tried opening an existing sxc document and got this error message:

[Java framework] could not load Java runtime library:

It looks like that openoffice is still looking into the old openjdk instead of the new sun java. How can I repoint it to use the current java (assuming it really needs it) ?

Apparently even entering openoffice on a new document gives error in a popup
OpenOffice org requires a JRE to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools-Options-OpenOffice org-Java … but since openoffice does not start I cannot access those options I guess (or is such stuff located elsewhere, and if so where) ?

What is the output of this command

/usr/sbin/update-alternatives --list java


The command returns

Note that de facto I do not use explicitly either java installation for compiling and running java apps, but an institute-wide installation on a NFS mounted disk. The JRE is used only by the browser (firefox) and (I just realized) openoffice (would anything else use it ?).

I realized only yesterday about the existence of /etc/alternatives (originally I thought I could just install the sun java stuff along with the pre-existing one, but for the browser it did not work, because /usr/lib64/browser-plugins/ links to a file in /etc/alternatives which in turn should be repointed. Since moving Sun’s into /usr/lib64/browser-plugins/ did not solve my firefox problem, I used yast to disinstall the openjdk, and that repointed things ok.

I cannot really claim that the openoffice issue is a bug (just an annoyance !) in the installation procedure, since it resides in the user configuration. I did a find for the string openjdk in ~/.ooo3 and found it appears only in .ooo3/user/config/javasettings_Linux_X86_64.xml.
I did not dare editing such file, but apparently renaming the entire directory .ooo3 and invoking openoffice afresh recreates the entire directory and points the JRE to <location>file:///usr/lib64/jvm/java-1.6.0-sun-1.6.0/jre</location>

This is enough to let openoffice run. Now I’ll run a kdiff3 to see if there is any user customization to recover (but I did not go further repristinating my old one after suse 11.3 installation. Side question: I have the old .ooo-1.1/ directory, but apparently the new openoffice did non inherit it … and I did not keep trace of my customization (though surely I disabled things as auto spelling check and alike). Is there any way to migrate ?

Addendum: apparently yast2 did a half-job when disinstalling. /usr/lib64/jvm/java-1.6.0-openjdk-1.6.0 was not deleted, but remained there almost empty. Trying to make Linux resemble Windows ? :slight_smile:

did You try the following?

open the,click Extras,click options (Optionen),click Open,
look for Java (most probably the last item) and click.
The window will show the installed JRE’s.Add or activate java sun plugin.
You may deinstall the unused plug-in.

It was not possible to access any menu, because openoffice stopped before with a popup (and replying OK did not work, one had to kill the process).

The solution is to rename ~/.ooo3 and let a fresh invocation of openoffice recreate it from scratch.

On 02/01/2011 12:06 PM, luciochiappetti wrote:
> but remained
> there -almost- empty. Trying to make Linux resemble Windows ? :slight_smile:

some folks are absolutely certain there is a great need to offer the
M$ Ship Jumping new Linux user a feel familiar environment…

so, maybe you are right! :wink:

actually, there is a switch which might make ‘disinstalling’ more
Linux-like…but that option is WELL hidden (to keep the Ship Jumpers
feeling at home, maybe), try this:

YaST > Software Management > Options, and add a checkmark to “Cleanup
when deleting packages” next time you uninstall something…

maybe that helps, i don’t know–i discovered it in a posting around
here somewhere since i last deleted anything…

its probably in the YaST documentation, but you know . . .

[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11