openoffice.org crash on start

I am getting consistent crashes in all openoffice.org programs shortly after starting. Here is the commandline output:

~> ooimpress
OpenOffice.org(4917)/kdeui (KIconLoader): Opening cache "/var/tmp/kdecache-todd/icon-cache.kcache" page size is 4096
OpenOffice.org(4917)/kdeui (KIconLoader): Attached to cache, determining if it must be initialized
OpenOffice.org(4917)/kdeui (KIconLoader): Cache fully initialized -- attached to memory mapping
OpenOffice.org(4917)/kdeui (KIconLoader): 4960256 bytes available out of 10485760
X-Error: BadDrawable (invalid Pixmap or Window parameter)
        Major opcode: 62 (X_CopyArea)
        Resource ID:  0x0
        Serial No:    460 (460)
These errors are reported asynchronously,
set environment variable SAL_SYNCHRONIZE to 1 to help debugging

I am using the openoffice.org:Stable repository on opensuse 11.3 64bit. I tried renaming my .ooo3 directory without success.

Hello TheBlackCat,

This error is most likely caused by the kde4 extensions for openOffice.org.
Try removing the package: OpenOffice_org-kde4.

Best of luck!:wink:

I tried that, it didn’t work. Any other ideas?

I’m having the same problem, w/ no success in removing the OpenOffice_org-kde4. package. Running 64-bit OS as well.

On 2010-10-23 23:06, TheBlackCat wrote:
>
> I tried that, it didn’t work.

Try it in gnome >:-)


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

You really expect me to install a completely separate desktop environment just to be able to use openoffice?

I submitted a bug report: https://bugzilla.novell.com/show_bug.cgi?id=649172

After uninstalling the package, following these instructions from the bug worked as a workaround:

  1. export OOO_FORCE_DESKTOP=none
    in the console/terminal before executing
  2. make sure no soffice processes are hanging around before restarting
  3. restart in a console/terminal

It appears to be a problem with KDE:Distro:Factory.

I am not using KDE:Distro:Factory, but this works for me to get openOffice to run.

The strange thing is that Ihave this problem of oOffice crashing only on my lapiop, but on my PC
with the same openSuse 11.3 installation, this problem does not exist

Re-installing openOffice did not solve anything. **SOLVED
**
I installed the openOffice KDE debug package and then started oowriter from a terminal.
Got the following error message (to be found in a log file in /home/[user] ):

A fatal error has been detected by the Java Runtime Environment:

SIGSEGV (0xb) at pc=0x00007f7ab28763f2, pid=28390, tid=140165341812512

JRE version: 6.0_18-b18

Java VM: OpenJDK 64-Bit Server VM (14.0-b16 mixed mode linux-amd64 )

Derivative: IcedTea6 1.8.1

Distribution: Custom build (Fri Aug 20 13:23:56 UTC 2010)

Problematic frame:

C [libpolyester.so+0x1b3f2] _ZNK14PolyesterStyle13drawPrimitiveEN6QStyle16PrimitiveElementEPK12QStyleOptionP8QPainterPK7QWidget+0x1452

If you would like to submit a bug report, please include

instructions how to reproduce the bug and visit:

Bugzilla Main Page

(left out the rest of the log file)

From PolyesterStyle13draw I concluded that the crash does relate to that particular style.
In Systemsettings Appearance I had set Polyester for the Widget style. On my PC I had it set to Oxigen+no openOffice crashes.

After changing it to Oxigen on my laptop, openOffice started up back to normal again:)

On 2010-10-24 17:36, TheBlackCat wrote:
>
> You really expect me to install a completely separate desktop
> environment just to be able to use openoffice?

Didn’t you notice the smiley?

It is a procedure to learn if the problem is related to the desktop. If
you want to learn that, then the answer is yes. I have several desktops
installed in my machine: if one doesn’t work for something, I can try
another. This is not windows, there is choice.

Me, I don’t see the problem with installing another desktop :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

I wasn’t using polyster. It turned out the problem it was having was with the raster graphics system for Qt 4.7 (it was available earlier, but Qt 4.7 was the first that let you enable it globally on a per-user basis). If I disable that (or rather un-enable it), openoffice works.