openoffice impress eps images not working

I have a bunch of presentations with eps images in them. These worked fine a while ago. However, when I opened these same presentations a few days ago, all the eps images were been replaced with an box containing some text describing the eps file. This is several dozen eps images per odp file with several dozen odp files. It would be infeasible to go through and manually change each one to a different file format. It isn’t just existing eps files, new ones I add do the same thing. Anyone have any ideas what might be happening?

This may have happened when I switched to opensuse 11.3, I don’t recall if I looked at them since the switch. I am using the OBS stable version of openoffice. I am using an x64 system.

Just looked at the most recent presentation I did which has an eps in it and it displays fine; I am using the 32-bit OBS stable version.

So what could be different on my system? Is there a package I could be missing?

This is still an issue for me. Have you found a solution?

Not come across this in Impress but I have a Writer file where the same thing happens but the document prints fine. Have you tried F5?

Alternatively, install LibreOffice.