OpenOffice date format under KDE

As I’ve read OpenOffice takes its date format from system settings. I have only KDE installed, so could I expect OOo to use regional settings of KDE?

“Short date format” in KDE is: DD.MM.YYYY, but OOo uses (I guess) this: dD.mM.YYYY. Where is it taken from?

I do not think OOo is that much integrated with KDE (or with Gnome or any other of the DEs available) that it takes the prefered date/time formatting from the KDE configuration. It would be a bit tricky because it is KDE internal and KDE has the right to do it different tomorrow.

System setting imho means not KDE, but Linux. But I do not know of any mechanism there. I can also not find anything like that to be set lin the environment by /etc/profile.

When you use the OOo manual (in the Help menu) and search for Date there are several chapters about it.

Start OpenOffice, go to Extra - Options - Language settings. Pick Estonian for your local language and you should be OK.

I just hoped that maybe SuSE has integrated OOo into KDE in these aspects too.

But OK, as I couldn’t find how to automatically format dates correctly, I just turned the auto-formatting off: Tools >> Options >> Writer >> Table >> Number recognition

I have Estonian selected, but the format of dates is still picked from I-don’t-know-where and I can’t find a place to change that.

For me at least that wouldn’t be enough. When my language is Netherlands, my date written in numbers will be DD-MM-YYYY or something like that. That is not acceptable for me, I use the ISO standard (which is btw also the NEN but mostly ignored) YYYY-MM-DD.

I’ve taught myself to use date fields. If I open docs in a ‘dutch’ OO.o they appear as dd-mm-yyyy, if I open them in a ‘us’ OO.o they appear as yyyy-mm-dd.
I do agree, that date should always be ISO, but I also think we should not type dates: tonight I will be seeing a play in a small theatre, the posters say friday, 18th of march !! Their flyer says the same, some other show starts at 201:15 PM.

Is that typical for Groningen lol!

Go to Insert>Fields>Other and you will find a whole series of options for formatting fields, including dates. Select the date option and then the format.

If you create and save a template with that option in it, it will always be available in a new document created from the template.