OpenOffice Crashing in 11.3

I recently installed OpenSUSE 11.3 x86_64 on my dual core AMD box. Everything seems to run great except for OpenOffice Spreadsheet. Whenever I attempt to open a spreadsheet it crashes on me. Any thoughts on what is going on? Thanks!

Was this a clean new install or an upgrade?

I have the same problem after upgrade the system!


I had the same problem and I solved it changing the JAVA. Check if you have installed the OpenJDK installed and replace it with sun-Java.


Thank you!

I deleted OpenJDK, but still have the same problem

Hi All.
Similar problem here on one install (another seems fine with the same spreadsheet).

  • Clean install in both cases.
  • Also tried different (older) version for openoffice:buildservice repo (no joy)

Then I found this thread and the comments on java…

  • Already using sun java.
  • Tried un-checking ‘Use JRE’ -which appears to be compulsory- and it managed to open the file **once **
    OK after re-checking …then went back to crashing.
  • Thought there might be something in that, so installed OpenJDK and selected that, and in my case it seems robust so far.

Don’t know if that gives any clues, however for the next visitor it’s worth trying a change from whatever java you’re using.


I also have trouble with openoffice 3.2.1 on 11.3 upgrade.
Openoffice doesn’t work on fluxbox WM.
It seems better on kde 4.4